Announcement

Collapse
No announcement yet.

default alarm sound

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    default alarm sound

    The Manual says that you can set the default alarm sound.
    Is this possible?

    "You can use the default alarm sound, choose to be woken by an item in your Favorites - or you can a sound from Squeezebox Radio’s set of musical sounds, natural sounds, or sound effects."
    Tony
     SBTouch ♪ SBRadio ♬

    #2
    I read that a little differently. I read it as:
    You can use
    a) the default alarm sound (an electronic beeping), OR
    b) choose to be woken by an item in your Favorites, OR
    c) you can [choose] a sound from Squeezebox Radio’s set of musical sounds, natural sounds, or sound effects.

    You can set any of those to be the alarm, but you're not setting what the default is.
    Main system: SB3 > Emotiva XDA-1 > NAD C 325BEE > Vandersteen 1
    Living room: SB2 > Audioengine HD6
    Kitchen/dining: SB2 > AudioSource AMP 100 > 2-pairs of Polk Audio RC60i in-ceiling speakers
    Deck/patio: SB Receiver > AudioSource AMP 100 > Polk Atrium 45
    Study: SB Radio
    Quiet time: Hifiman Sundara headphones plugged into NAD amp or iPhone + AudioQuest Dragonfly Red DAC/amp
    LMS 8.3 running on a Raspberry Pi3 (piCore), controlled using iPeng, SB Controllers and Squeezepad

    Comment


      #3
      Originally posted by aubuti View Post
      I read that a little differently. I read it as:
      You can use
      a) the default alarm sound (an electronic beeping), OR
      b) choose to be woken by an item in your Favorites, OR
      c) you can [choose] a sound from Squeezebox Radio’s set of musical sounds, natural sounds, or sound effects.

      You can set any of those to be the alarm, but you're not setting what the default is.
      I also read it as you do, but how do I set the alarm as a)? (an electronic beeping)
      Tony
       SBTouch ♪ SBRadio ♬

      Comment


        #4
        Originally posted by Tony T View Post
        I also read it as you do, but how do I set the alarm as a)? (an electronic beeping)
        Make sure the current playlist is empty. Maybe my listing is wrong, and it really defaults to the current playlist, and then only falls back to the beeping only if the playlist is empty or no server is available. I know I just was able to get the beeping by clearing my playlist.
        Main system: SB3 > Emotiva XDA-1 > NAD C 325BEE > Vandersteen 1
        Living room: SB2 > Audioengine HD6
        Kitchen/dining: SB2 > AudioSource AMP 100 > 2-pairs of Polk Audio RC60i in-ceiling speakers
        Deck/patio: SB Receiver > AudioSource AMP 100 > Polk Atrium 45
        Study: SB Radio
        Quiet time: Hifiman Sundara headphones plugged into NAD amp or iPhone + AudioQuest Dragonfly Red DAC/amp
        LMS 8.3 running on a Raspberry Pi3 (piCore), controlled using iPeng, SB Controllers and Squeezepad

        Comment


          #5
          Originally posted by aubuti View Post
          Make sure the current playlist is empty. Maybe my listing is wrong, and it really defaults to the current playlist, and then only falls back to the beeping only if the playlist is empty or no server is available. I know I just was able to get the beeping by clearing my playlist.
          Just tried it, and yes, only if the current playlist is empty does the backup alarm sound.

          >or no server is available

          If my internet connection is down, default alarm does not sound (I tested this a few times). Not sure what happens with a squeezebox server.

          Also, the back-up alarm should be listed as an alarm option. My 'old' alarm clock had an option that after 15 minutes (user selected) of music, a beeping would trigger to wake me up if I fell back to sleep with the music playing. While the SB Radio does not have this option (it would be nice!), I can get around it by setting 2 alarms. i.e. One at 6am and another at 6:15 am (with the second using the Sub Alert Sound Effect, which I wish I could change to the back-up alarm beep).
          Last edited by Tony T; 2009-11-30, 04:47.
          Tony
           SBTouch ♪ SBRadio ♬

          Comment


            #6
            I know this is a rather old thread, but as was f*cked up by the radio sometimes waking me up with the default sound rather then my chosen one i searched for a solution. Here it is:

            - active remote login on the radio/box (in settings)
            - ssh to your box (user: root pw: 1234[can be changed])
            - default sound is in /usr/share/jive/applets/AlarmSnooze/alarm.mp3
            - you can adjust the alarm behaviour (f.e. volume) by manipulating the AlarmSnoozeApplet.lua file in the same directory
            - change the name of the alarm.mp3 in line 43:
            self.alarmTone = "applets/AlarmSnooze/myalarm.mp3"
            - slow down fadein speed in line 453:
            self.fadeInTimer = Timer(800,
            - set maxVolume in line 455
            if self.alarmVolume < 30 then
            - provide a myalarm.mp3

            If you still want to use you serversound you should adjust line 813 like this (normal wait for server is only 20s):
            local rtcSleepMsecs = interval + 300000
            But to be honest, the whole code looks rather strange to me. From a quick look it seem to work like this:
            - normally the server alarms the client to wakeup
            - at some point someone added code to have a local timer as fallback, which is complete independent from server
            - so the local fallback alarm fires away when it's RTC timer reached alarm time (+20s, so the server can fire first)
            - when the server fires, the fallback alarm is interupted

            If my assumptions are correct, this code smells, as a local RTC will run out of sync with servertime quiet fast.

            My advice:
            - either forget the server for wakeup and just use your custom fallback sound (with the method provided here) by setting a playlist for wakeup and then deleting the playlist on the server (this is what i do now)
            or
            - set the rtcSleepMsecs to +300000 (5min) and set your alarms 5 minutes earlier (as the fallback will now wait 5 minutes before firing up).

            DO ON YOU OWN RISK, BUT CHANGES WILL BE LOST WHEN YOU FACTORY RESET THE BOX!
            SO DON'T PANIC ,-)


            Have fun...

            Btw: all the natures sounds etc. seem to be hosted on mysqueezebox.com(at least i was unable to find them anywhere on my systems. So be carefull using these as they will probably not be reliable).

            Comment


              #7
              Originally posted by frank_harmann View Post
              I know this is a rather old thread, but as was f*cked up by the radio sometimes waking me up with the default sound rather then my chosen one i searched for a solution. Here it is:

              - active remote login on the radio/box (in settings)
              - ssh to your box (user: root pw: 1234[can be changed])
              - default sound is in /usr/share/jive/applets/AlarmSnooze/alarm.mp3
              - you can adjust the alarm behaviour (f.e. volume) by manipulating the AlarmSnoozeApplet.lua file in the same directory
              - change the name of the alarm.mp3 in line 43:
              self.alarmTone = "applets/AlarmSnooze/myalarm.mp3"
              - slow down fadein speed in line 453:
              self.fadeInTimer = Timer(800,
              - set maxVolume in line 455
              if self.alarmVolume < 30 then
              - provide a myalarm.mp3

              If you still want to use you serversound you should adjust line 813 like this (normal wait for server is only 20s):
              local rtcSleepMsecs = interval + 300000
              But to be honest, the whole code looks rather strange to me. From a quick look it seem to work like this:
              - normally the server alarms the client to wakeup
              - at some point someone added code to have a local timer as fallback, which is complete independent from server
              - so the local fallback alarm fires away when it's RTC timer reached alarm time (+20s, so the server can fire first)
              - when the server fires, the fallback alarm is interupted

              If my assumptions are correct, this code smells, as a local RTC will run out of sync with servertime quiet fast.

              My advice:
              - either forget the server for wakeup and just use your custom fallback sound (with the method provided here) by setting a playlist for wakeup and then deleting the playlist on the server (this is what i do now)
              or
              - set the rtcSleepMsecs to +300000 (5min) and set your alarms 5 minutes earlier (as the fallback will now wait 5 minutes before firing up).

              DO ON YOU OWN RISK, BUT CHANGES WILL BE LOST WHEN YOU FACTORY RESET THE BOX!
              SO DON'T PANIC ,-)


              Have fun...

              Btw: all the natures sounds etc. seem to be hosted on mysqueezebox.com(at least i was unable to find them anywhere on my systems. So be carefull using these as they will probably not be reliable).
              You sir, are a legend. I will forever be in your debt and hopefully will no longer have to listen to the grating sample from Datarock's Fa-Fa-Fa.

              Comment


                #8
                Thanks!

                Originally posted by frank_harmann View Post
                (...) then my chosen one i searched for a solution. Here it is:
                (...)
                Have fun...

                Btw: all the natures sounds etc. seem to be hosted on mysqueezebox.com(at least i was unable to find them anywhere on my systems. So be carefull using these as they will probably not be reliable).
                Dear Frank Harmann

                Thank you VERY MUCH for this extremely helpful posting! I was at the edge of throwing away my Squeezebox because of that horrible default fallback alarm.

                Everything from your directions works fine after the Squeezebox is restarted and AlarmSnoozeApplet.lua loaded with the new settings.

                Swissmorgy

                Comment


                  #9
                  The main issue for me is not to trigger the alarm initially, usually is starts to play the server music, then after a while sometimes something happens that makes the Radio temporarily loose network connection, and that triggers the fallback alarm and it never returns to the server alarm any more.

                  I'd love if anyone would take some time to provide a patch that completely disabled the fallback when temporarily loosing the connection with the server.
                  Erland Lindmark (My homepage)
                  Developer of many plugins/applets
                  Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

                  Comment


                    #10
                    Sorry to bring this up again, but the instructions above look to be just what I need to kill the disco soundtrack which occasionally blurts out. I've got into the Radio via Putty but once past the username/password stage I'm completely lost. Does anyone know if there are any more detailed instructions anywhere that I could use? I'm not used to using SSH at all and have no idea what to type! Thanks very much.

                    Comment


                      #11
                      for MV1976

                      If you're still interested in directions of how to manipulate the file system once you login, you can e-mail me n5_cv ( at ) ar_rl.net Remove all the underscores from the email address.

                      Comment


                        #12
                        Originally posted by frank_harmann View Post
                        I know this is a rather old thread, but as was f*cked up by the radio sometimes waking me up with the default sound rather then my chosen one i searched for a solution. Here it is:
                        From 2022, thank you so very much for this! I have nothing against disco, but it's not my first choice at 0630 if I happen to have wifi problems!

                        Comment

                        Working...
                        X