Announcement

Collapse
No announcement yet.

Simplified instructions for Squeezebox Radio Wi-Fi fix (wlanpoke)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    I have just modified one of my 3 SBR. So, I'll see if problems gone. Anyway, problems disappeared for a couple of months.

    Comment


      #32
      Setting for inactivity?

      The WLANpoke solution basically works fine for my SB Radio. But I have noticed that after about (or exactly?) one week of not using the SB Radio it looses the WLAN connection and needs to be restarted.
      This is not a big problem, but I was wondering if this is somehow configurable? If so, how can I go about to extend this setting to let's say two weeks instead?

      Comment


        #33
        Is there a way to to turn off wlanpoke? I want to turn it off for some testing.

        Comment


          #34
          Originally posted by P Nelson View Post
          Is there a way to to turn off wlanpoke? I want to turn it off for some testing.
          Remove the /etc/init.d/rcS.local file on your Squeezebox and then reboot the Squeezebox.

          To turn it back on you will need to recreate/replace this file.

          Comment


            #35
            Various questions..

            This looks like a possible life saver for my radios, thanks a lot for this.
            But i would like to better understand what is really going on:

            - What is the root cause for the problem, e.g.: why do the radios loose wifi ? and not reconnect. I can not even force the radio to reconnect with the menu item of repair network. Just with reboot.
            - And what does wlanPoke do to fix this ?
            - Are there alternative solutions, e.g.: newer firmware for the radios? I just see there is also community firmware.

            I had this problem for many years. In one place i figured that the problem was related to the hardware version, likely differnt wifi chips ? So i wired up the radios with the biggest issue.

            Now i have the problem when i move a radio further away. Works well on wifi in close proximity to the AP, but not in the next room.

            So quite curious what the heck is going on...

            Comment


              #36
              Turn off for Testing

              Originally posted by P Nelson View Post
              Is there a way to to turn off wlanpoke? I want to turn it off for some testing.
              Removing the rcS.local file and rebooting will restore your radio to nearly its original state. You can still manually launch the script.

              Besides that, depending on what you want to do, there are several other ways to disable wlanpoke.

              The first is to use the wlanpoke's kill app function. From an ssh prompt (copy and paste):
              /etc/wlanpoke/wlanpoke.sh -k
              to exit the script. The script should exit and stay off until the next reboot, or until you relaunch it.

              If you want the script to not run at the next reboot, a quick way is to rename the script so that it will be launched at boot, e.g.:
              mv /etc/wlanpoke/wlanpoke.sh /etc/wlanpoke/wlanpoke.sh.disabled
              You could instead rename the rcS.local file.

              (For testing, which sounds advanced, if you want to retain or expand the script's logging capability, you could disable the script's RestartNetwork() function by adding "return" as the first line.)

              Comment


                #37
                Originally posted by te36 View Post
                This looks like a possible life saver for my radios, thanks a lot for this. But i would like to better understand what is really going on:
                - What is the root cause for the problem, e.g.: why do the radios loose wifi ? and not reconnect...
                Briefly: WiFi-6 and mesh are disrupting (incompatible with) the radio's WiFi chip firmware. For a history of the investigation into this issue, start here and keep reading. Many pages.

                - And what does wlanPoke do to fix this? - Are there alternative solutions ...
                The script does not fix the disruption issue. Instead, it restarts the wireless radio after a disruption has been detected, frequently quickly enough so that music that has been downloaded to the radio does not "run out" before the radio reconnects.

                One alternative solution is to use Ethernet. However, this makes the radio non-portable. Another solution is to reduce or eliminate WiFi-6 and/or mesh interference (good luck with the neighbors...). One day, WiFi-6 and mesh, which were supposed to be "compatible," may actually become so, and eliminate the issue.
                Last edited by POMdev; 2021-09-01, 22:45.

                Comment


                  #38
                  Originally posted by POMdev View Post
                  Briefly: WiFi-6 and mesh are disrupting (incompatible with) the radio's WiFi chip firmware. For a history of the investigation into this issue, start here and keep reading. Many pages.

                  The script does not fix the disruption issue. Instead, it restarts the wireless radio after a disruption has been detected, frequently quickly enough so that music that has been downloaded to the radio does not "run out" before the radio reconnects.

                  One alternative solution is to use Ethernet. However, this makes the radio non-portable. Another solution is to reduce or eliminate WiFi-6 and/or mesh interference (good luck with the neighbors...). One day, WiFi-6 and mesh, which were supposed to be "compatible," may actually become so, and eliminate the issue.
                  Whow. Will read up on the thread.
                  So right now i have a Unifi Ap AC-Lite, but i already ordered to play around a newer Nano. Any idea if i might improve my situation with the radio by configuring them in a particular way ? No idea if / what i could e.g. disable at 2.4 Ghz.

                  Comment


                    #39
                    Originally posted by POMdev View Post

                    (For testing, which sounds advanced, if you want to retain or expand the script's logging capability, you could disable the script's RestartNetwork() function by adding "return" as the first line.)
                    For me, no testing that I would call advanced. I wanted to turn off wlanpoke to see if moving the Radio to a new area in my house has a interference problem.

                    Thanks for the reply. Adding this to my notes on SB Radios.

                    Paul

                    Comment


                      #40
                      Originally posted by P Nelson View Post
                      For me, no testing that I would call advanced. I wanted to turn off wlanpoke to see if moving the Radio to a new area in my house has a interference problem.
                      OK. You don't need to turn off the script to evaluate interference. Just enable the web server, and open the radio's web page on port 8080 to get the latest page of disruption statistics. (The software is almost all logging and reporting for the purpose of tuning and troubleshooting the mitigation, which is only ~10% of the code.) For more information, see the manual.txt file.

                      Add "-W slow" to rcS.local:
                      /etc/wlanpoke/wlanpoke.sh -x -W slow &
                      or
                      /etc/wlanpoke/wlanpoke.sh -W slow &
                      to enable real time remote reporting (RTM) to your desktop, etc.

                      ...Adding this to my notes on SB Radios...
                      Is there a public link for your notes?

                      Comment


                        #41
                        Originally posted by te36 View Post
                        This looks like a possible life saver for my radios, thanks a lot for this.
                        But i would like to better understand what is really going on:

                        - What is the root cause for the problem, e.g.: why do the radios loose wifi ? and not reconnect. I can not even force the radio to reconnect with the menu item of repair network. Just with reboot.
                        Firstly I also add my thanks to PomDev2 for creating WLANpoke.

                        I have two Squeezebox Radios and for the last few weeks one of them has been exhibiting this problem. I had initially been suspecting a developing chip failure for the WiFi chip and had considered either switching to using Ethernet or buying another used system but the fact I discovered this thread and solution and it works suggests fortunately this is not the issue.

                        I am still myself puzzled by the cause. As mentioned I have two Squeezebox Radio systems in operation and the only one currently showing this problem is located within feet of an Apple AirPort Extreme. The unit not having a problem is located at the other end of the house as far as is possible to get from the Apple AirPort Extreme. It definitely therefore is not range or signal strength and as an old discontinued Apple WiFi device it has not received recent firmware updates that might have introduced a problem. It also is not a mesh device nor does it support WiFi6. So I am perplexed. It could be external interference e.g. a neighbours system affecting my signal but logically this would have most impact on the Squeezebox Radio furthest from my AirPort and not the one in the same room.

                        If this fix is as seems becoming so important to an increasing number of users it would be nice to see it built-in to a future community firmware update.

                        Comment


                          #42
                          Originally posted by jelockwood View Post
                          Firstly I also add my thanks to PomDev2 for creating WLANpoke.
                          +99

                          Originally posted by jelockwood View Post
                          If this fix is as seems becoming so important to an increasing number of users it would be nice to see it built-in to a future community firmware update.
                          IMHO, it is not a fix, but a workaround. And it seems we may not fully understand the root causes, but there seems to be the suspicion that its related to wifi6 or other new wifi.

                          In one of my places, i actually have 5 radios and i had bought most of them even before logitech bought squeezebox (i think, have to go back and look). And i had over the years different degree of this wifi problem - must reboot to get wifi again. At some point in time, i felt that the problems where more pronounced in the last radio i had bought, so i thought it might be related to the HW version of the radio and differences in wifi chip used. Thats at least 5 years ago. And that was with shuffling radios around the house to compare.

                          In my place now, i have two radios, and they seem to be behaving quite the same, but on one end of the place, the problem occurs, in the other it doesn't. Now i need more time to analyze the logs of WlanPoke to maybe better figure out what might be happening.

                          But to really fix the issue in community firmware would require for all relevant parts of the wifi firmware to be open source and changeable. Not sure if that is the case. And of course it would first require to even know exactly what triggers the problem.

                          Comment


                            #43
                            The problem, for me, is interference from a neighbors WiFi and the WiFi chip in the SB Radio. No issues with my SB Touch (different WiFi. chip), and no prob with the SB Radio at a different location (vac home). Chip can’t be changed, so the only “fix” is to use the Ethernet Port of the Radio, or a WiFi to Ethernet dongle (i.e. Vonets, which I use). WLANpoke looks like a very good solution to the problem.
                            Tony
                             SBTouch ♪ SBRadio ♬

                            Comment


                              #44
                              All the new zigbee / bluetooth / ????? 2.4ghz crap people have around their house probably also doesn't help.

                              Atleast this way we can reconnect _without_ a reboot. Which is good enough I guess

                              Comment


                                #45
                                I have a few radios. One I carry outdoors (the others I use Vonets), so I finally got around to installing wlanpoke. Working well so far (thanks POMdev)
                                I like logging, so I’m not disabling with -x.
                                I see the log file in /etc/log on the Radio, but I’m confused with what’s described in the Manual:
                                “ The software will try to send messages to a logging server, by default the computer running Logitech Media Server (LMS) on the default port (1121).”

                                Is there supposed to be a log file for wlanpoke on my raspberry pi running piCore? If so, I don’t see it.
                                Tony
                                 SBTouch ♪ SBRadio ♬

                                Comment

                                Working...
                                X