Announcement

Collapse
No announcement yet.

Simplified instructions for Squeezebox Radio Wi-Fi fix (wlanpoke)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I needed to step away from this for a bit, so I waited until this morning to check again.
    Surprisingly, the Radio is still behaving normally right now, after having been up since late yesterday afternoon.
    Previous order of business:

    - Connected wired Ethernet
    - Factory restored
    - Let it connect to LAN/MSB/LMS
    - Disabled wlan via SSH

    I was still on stock firmware before I walked away from it yesterday, but it seems the radio automatically updated to the Community firmware...???
    Have not changed any settings whatsoever yet.

    This is very similar to what I had already tried, so not quite sure what's different yet.

    Also, not certain if this matters, but I did remove the battery before the last round, thinking it might be good to let the radio completely power down.
    I reinserted the battery this morning, so we'll see if that has any bearing.

    I'm going to go back to the way things were before, one step at a time (WiFi bridge > wait > set static IP > start setting radio UI back to how I had it, etc.) and see if/when it falls over again.

    The key thing here seems to be disabling wlan, but possibly requiring stock firmware when doing so?

    Comment


      Originally posted by rdeckard View Post
      The key thing here seems to be disabling wlan, but possibly requiring stock firmware when doing so?
      @POMdev identified that the WiFi components seemed to be hogging the CPU, according to your 'top' listing. That would certainly give rise to sluggishness. If the WiFi is 'regularly' misbehaving in that manner, then disabling the wlan, as you did, should remove the sluggishness. Of course we don't know why the WiFi is apparently misbehaving...

      I wouldn't expect any difference in behaviour between 'stock' and 'community' firmwares. If you find that there is a difference, reliably, please report back.

      Comment


        Solved

        Problem is definitely the wlan.
        Still not certain whether it's a WiFi 6/interference issue, or an actual hardware failure though.
        Regardless, as of right now, the radio is set up exactly how it was prior to this debacle (albeit with wired Ethernet), and it's been running for 10+ hours without issue.

        The problem was that the method I was using for disabling wlan on bootup did not work for me.
        As per https://forums.slimdevices.com/showt...=1#post1053624
        I added an rcS.local file with the following:

        /usr/etc/logger -s "Stopping wlan; disabling wifi"
        /etc/init.d/wlan stop

        However, after startup, sending /etc/init.d/wlan stop resulted in:

        root: wlan: stopping
        ..unloading all
        killall: recEvent: no process killed
        root: wlan stopped

        This indicated wlan had not actually stopped after boot.
        It should look like this if already stopped:

        root: wlan: stopping
        killall: wpa_cli: no process killed
        killall: wpa_supplicant: no process killed
        ..unloading all
        rmmod: can't unload 'ar6000': unknown symbol in module, or unknown parameter
        killall: recEvent: no process killed
        root: wlan stopped

        I then removed the rcS.local file I added previously, opened the rcS file, and commented out the following line as shown:

        #/etc/init.d/wlan start

        Rebooted again, verified wlan was not running, and the radio has been up and running with the IOGEAR WiFi bridge since.
        I'm leaving it at that for now.

        Many thanks to @POMdev and @mrw for the assist!
        Last edited by rdeckard; 2022-10-15, 04:34.

        Comment


          Originally posted by mrw View Post
          @POMdev identified that the WiFi components seemed to be hogging the CPU, according to your 'top' listing. That would certainly give rise to sluggishness. If the WiFi is 'regularly' misbehaving in that manner, then disabling the wlan, as you did, should remove the sluggishness. Of course we don't know why the WiFi is apparently misbehaving...

          I wouldn't expect any difference in behaviour between 'stock' and 'community' firmwares. If you find that there is a difference, reliably, please report back.
          Sorry - didn't see your post - had left the editor up whilst compiling info.
          The issue had resurfaced again after moving the radio back to it's original location and rebooting, which led me to try and see how I could verify if the wlan was actually stopped. Thanks again!

          Comment


            In case anybody got a good understanding of Radio's WLAN, could you please visit https://forums.slimdevices.com/showt...1#post1066465? Any help would be greatly appreciated!
            Michael

            "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
            (LMS: Settings/Information)

            Comment


              This Fix Worked!

              Originally posted by rojikewl View Post
              At some point in the past two years, my three Squeezebox Radios suddenly lost their ability to stay connected to Wi-Fi. To get them reconnected I would have to reboot them, but they would always lose their connection again in as little as five minutes. They would almost never stay connected for more than 40 minutes at a time. I was using a common Linksys router, and nothing in my setup had changed. The Radios basically became glorified clocks displayed in my home. My two Squeezebox Touch units were unaffected, but the loss of the Radios caused me to use the Touches less as well.

              A few days ago I finally installed POMdev's wlanpoke on each Radio. This fix has breathed new life into them--they now stay connected without the need for frequent reboots. POMdev, I'm grateful—thank you very much.

              In preparation to install the fix, I noticed that about six months ago, in his (?) first (and so far only) post on this forum, mankan requested that someone write "instructions for dummies" for wlanpoke. Having recently struggled through the user manual as a non-technical user, I agree that such instructions are necessary, so I am taking a stab at writing them by describing, step by step, how I installed wlanpoke on my three Squeezebox Radios. If anyone notices any problems with my instructions, please let us know. I'm afraid that most non-technical users may have given up on their Radios by now, but I hope these instructions help someone.

              Please note that these instructions are for installing the fix without enabling the logging (extensively documented in the user manual) that it provides for troubleshooting purposes. I chose to disable the logging in the hope that the fix would simply work. Since it does, I don't anticipate having to enable logging.

              Now for the instructions. I used a Windows computer on the same Wi-Fi network as my Squeezebox Radios to do the following:

              1. Download wlanpoke: Go to https://github.com/PomDev2/wlanpoke , click on the green button labeled Code and then click on Download ZIP. Save the file wlanpoke-main.zip to your computer.

              2. Open Windows Explorer and locate the downloaded file wlanpoke-main.zip. Right-click on the file, and select "Extract All". This will extract the contents of the compressed file to a folder named wlanpoke-main.

              3. Enable the Radio's SSH server by navigating as follows:
              Home | Settings | Advanced | Remote Login
              and selecting Enable SSH. When you do this, make a note of the Radio's IP address, which is displayed on the screen in the following message: "The root password for this device is 1234 and you can connect to it on address [IP address]"

              4. Back on your computer, download WinSCP from the page https://winscp.net/eng/download.php and install it.

              5. Launch WinSCP. A login window should open (if you need to open a login window manually, click on the "New Session" tab toward the top left). Under Session, for the file protocol, choose SCP. For the host name, enter the IP address you saved in step 2. Leave the port number unchanged. For user name, enter "root". For password, enter "1234". Click on "Login". You will see one or two warnings asking if you want to proceed. Answer Yes. If you get an error message that says "Error getting name of current remote directory," dismiss it by clicking OK.

              6. The WinSCP window now displays your computer's files and folders on the left and your Squeezebox Radio's files on the right. On the Squeezebox Radio side, navigate to the root directory (the folder at the very top of the hierarchy). You can do this by clicking on the root directory button that is shown above the list of files, to the left of the home button. Now, navigate to the folder named "etc" by double-clicking on it. Now click on the New button, which is just below and to the right of the root directory button. Choose "Directory", and for "New folder name", type "wlanpoke". Once the wlanpoke folder has been created, double-click on it to display the contents of the folder, i.e. nothing as of yet.

              7. In your computer files (displayed on the left-hand side of WinSCP), navigate to the contents of the folder wlanpoke-main, created in step 2. Select all 11 files and drag them to the opposite side of the WinSCP window to copy them into the wlanpoke folder. (Answer yes and/or OK to any scary-sounding confirmations.)

              8. The purpose of this step is to change permissions for the shell scripts to "executable". In the menu bar at the top of the WinSCP window, click on Commands, and then click on Open Terminal. Then, for each of the following two lines of text, copy the entire string of text, paste it into the field labeled "Enter Command" in the console, and click on the Execute button:
              chmod 755 /etc/wlanpoke/*.sh
              chmod 755 /etc/wlanpoke/rcS.local.example

              9. Click on Close to close the terminal window. The Squeezebox Radio side of the WinRCS window should still show the contents of the wlanpoke folder. Right-click on the file rcS.local.example and click on Copy. Next, navigate to the folder /etc/init.d by clicking on the root directory button (to the left of the home button) and then double clicking first on the etc folder and then on the init.d folder. Right-click in the white space below the list of files and then select Paste. A confirmation dialog box titled Duplicate will appear. Remove the characters ".example" from the end of the target remote path so that it now reads "/etc/init.d/rcS.local" and click OK. You should see that the file rcS.local has appeared in the list of files on the Radio. Right-click on the file rcS.local, select Edit, then select Edit again.

              10. Now that you have the rcS.local file open, edit the last line (/etc/wlanpoke/wlanpoke.sh &) by placing the characters -x followed by a space character before the final ampersand. In other words, edit this line so that it reads as follows (this edit is to specify that you don't want any messages to be sent to a logging server):
              /etc/wlanpoke/wlanpoke.sh -x &

              11. Close the file editor. When asked if you want to save the file, click on Yes. Answer Yes again if asked if you want to continue with the connection, and click OK to dismiss any error message.

              12. Close WinSCP, answering Yes when asked if you want to terminate the session without saving a workspace.

              13. Disable the Radio's SSH server by navigating as follows (the manual doesn't say to do this, but I disabled it because I don't know if leaving it enabled constitutes a security risk):
              Home | Settings | Advanced | Remote Login
              and deselecting Enable SSH.

              14. Restart the Squeezebox Radio (I believe this is necessary to activate the fix). Your Radio's Wi-Fi connectivity should now be back to normal, for the most part. Repeat for each additional Squeezebox Radio you are once again lucky enough to own.
              rojikewl- I installed this fix and it worked. Thank you for sharing it!

              Comment


                I am using Mac to access the Radio by SSH and have succeeded this far.
                FileZilla fails to connect, so the wget command seems most useful once I access the right link.
                The suggested [gh repo clone PomDev2/wlanpoke] -sh: gh: not found

                Has the radio wget and nano already installed, otherwise I will find a PC
                SB Touch (Community firmware v8.01) UE Radio, SMSL Sanskrit MkII, Talk Electronic Cyclone 1.2 amplifier. LMS 8.2 Snakeoil OS, HP t520 thin client.
                BBCiPlayer, BBC Sounds, Shairtunes2 plugins, edo applet

                Comment


                  Originally posted by Patricia P View Post
                  I am using Mac to access the Radio by SSH and have succeeded this far.
                  FileZilla fails to connect, so the wget command seems most useful once I access the right link.
                  The suggested [gh repo clone PomDev2/wlanpoke] -sh: gh: not found

                  Has the radio wget and nano already installed, otherwise I will find a PC
                  It does have wget but doesn't have nano. It does have vi if that's to your taste as an editor..

                  Comment


                    Originally posted by Patricia P View Post
                    I am using Mac to access the Radio by SSH and have succeeded this far.
                    FileZilla fails to connect, so the wget command seems most useful once I access the right link.
                    The suggested [gh repo clone PomDev2/wlanpoke] -sh: gh: not found

                    Has the radio wget and nano already installed, otherwise I will find a PC
                    Patricia,

                    Check out the thread linked below... in post number 14 I've outlined step by step instructions to load and setup wlanpoke into a Squeezebox Radio directly from MacOS with no other tools required.
                    You can copy and paste each command required from the thread.



                    Cheers

                    Kev
                    Last edited by KeBul; 2023-01-23, 20:54.

                    Comment


                      Will this fix the blue icon of wifi signal loss. Right now, my current fix just unplug and plug back the radio

                      Comment


                        Originally posted by hatng View Post
                        Will this fix the blue icon of wifi signal loss. Right now, my current fix just unplug and plug back the radio
                        wlanpoke helps resolve the wifi6 (ax) interference problem with the SB Radios that causea them to drop from the Wifi network. The interference can be caused by your router using the Wifi6 AX protocal on the 2.4 GHz band or even when a neighbor's router is using wifi6. A symptom is the Radio will disconnect randomly from the wifi network and a reboot fixes the problem temporarily.
                        Are you sure that is the problem you are experiencing? A test would be to connect the Radio via ethernet to see if the problem disappears.

                        In my case, wlanpoke significantly helped with disconnect problem, but did not eliminate having to reboot occasionally.

                        Paul

                        Comment


                          Originally posted by hatng View Post
                          Will this fix the blue icon of wifi signal loss. Right now, my current fix just unplug and plug back the radio
                          The blue icon does not indicate wifi signal loss. It is intended to indicate that the network connection is running, but that no contact can be made with LMS.

                          The red icon indicates that the network connection is not running. (Which may, inter-alia, indicate that there is wifi signal loss).

                          Comment


                            Originally posted by mrw View Post

                            The blue icon does not indicate wifi signal loss. It is intended to indicate that the network connection is running, but that no contact can be made with LMS.

                            The red icon indicates that the network connection is not running. (Which may, inter-alia, indicate that there is wifi signal loss).
                            I have had my Radio show the Blue Icon, but I cannot get it to reconnect to LMS running on pCP. Trying repair network does not fix it. Only a reboot of the Radio restores the function.
                            Perhaps the Radio's wifi is in some incomplete confused state of connection, but non-functional. This is what is so frustrating with the Wifi6 (ax) problem.

                            Comment


                              Originally posted by KeBul View Post

                              Patricia,

                              Check out the thread linked below... in post number 14 I've outlined step by step instructions to load and setup wlanpoke into a Squeezebox Radio directly from MacOS with no other tools required.
                              You can copy and paste each command required from the thread.



                              Cheers

                              Kev
                              Much appreciated Kev, but the radio access has such a short window of opportunity that I keep getting stuck. It’s the unzip and mv commands that appear to produce an empty directory wlanpoke-mainman. Its shows the renamed directory after I tried to zip and upload it again.

                              # unzip -o /etc/wlanpoke-mainman.zip -d/etc/wlanpoke
                              Archive: /etc/wlanpoke-mainman.zip
                              creating: wlanpoke-mainman/
                              unzip: zip flags 1 and 8 are not supported
                              # mv -f /etc/wlanpoke/wlanpoke-mainman/* /etc/wlanpoke
                              mv: can't rename '/etc/wlanpoke/wlanpoke-mainman/*': No such file or directory​

                              Do the terminal responses offer any light?
                              Last edited by Patricia P; 2023-01-26, 20:51.
                              SB Touch (Community firmware v8.01) UE Radio, SMSL Sanskrit MkII, Talk Electronic Cyclone 1.2 amplifier. LMS 8.2 Snakeoil OS, HP t520 thin client.
                              BBCiPlayer, BBC Sounds, Shairtunes2 plugins, edo applet

                              Comment


                                Originally posted by P Nelson View Post
                                Perhaps the Radio's wifi is in some incomplete confused state of connection, but non-functional.
                                That is possible. The check on network status (every 5 seconds) is somewhat rudimentary, it does not actually check for connectivity, just that the network appears to be configured. In principal a loss of wi-fi connection should show itself, but...

                                It's a pity that "repair network" doesn't fix it. Unfortunately, without being able to replicate the circumstances here, it's difficult to work out what needs fixing. The code for network setup and management is somewhat intricate.

                                Comment

                                Working...
                                X