Announcement

Collapse
No announcement yet.

WiFi connection unstable/lost on three Radios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Similar problems in new home with new WiFi6......... But I can't find anything called "band steering" in the router management, but what with moving and Madame preparing for knee surgery, I haven't really had a chance to see if this exists. Even with WiFi6 turned off, the Radios (Wlan-poked) will not hold the connection, so maybe it is a band issue rather than a WiFi6 issue as such.

    The other thing that has me puzzled is that when I first try to connect either Radios or Touches *via ethernet*, I still have a heck of a time. I keep getting a "Can't find a DHCP address" error. But, oddly, if I just leave it plugged in to ethernet and walk off for lunch or more unpacking of moving boxes, after half an hour or so, the device *has* connected to ethernet, and works fine from then on. Which makes me think that some odd things are going on with the new router settings, WiFi and Ethernet. I'm too busy to properly fault-chase for a week or so, but I'm sure I'll track the issue down somehow.....
    8.2.1 - 1639114554
    Win11
    Control: Web GUI; MaterialSkin on Android phones / pads

    b) Freebox Pop Wifi6 / Mesh
    External SSD, WiFi Laptop
    2 x Touch Wireless (Firmware:8.0.1-r16907)
    1 x SB Radio, LAN into Vonets WiFi Bridge (8.0.1-r16907)

    Comment


      Originally posted by mrw View Post
      An interesting observation .

      What firmware version are you using on the 'normal' Radios that are affected ?

      I think I would have expected no difference in behaviour.
      All on latest community f/w. One UE which fails to connect, two Logitech which have no problem connecting. Easy to reproduce the behaviour and UE is now behaving as before I switched band steering on. Maybe UE has a different WiFi chip?

      Originally posted by agbagb View Post
      But I can't find anything called "band steering" in the router management,
      On the Unifi it looks like this:


      Also worth trying with mesh network switched off if you have multiple AP's..
      Last edited by Heuer; 2022-12-13, 16:38.
      Lounge: Transporter>Audio Synthesis DAX Decade>Audio Research LS22>Krell FPB300>Wilson Benesch Act 1's + 2 x Velodyne SPL1000 sub's
      Kitchen: Touch>Topping DAC>Arcam Solo>Anthony Gallo Micro's+Sub, Joggler controller
      Office: DAC32>Acoustic Energy AE1 Active's, Joggler controller
      Garage: Boom>QAcoustics 7000s subwoofer
      Bedroom: Radio
      Shed: Radio
      Workshop: Boom
      Garden 1: SB3>JVC amp>Rock outdoor speakers
      Garden 2: SB3>JVC amp>Rock outdoor speakers

      Comment


        Originally posted by Heuer View Post
        Maybe UE has a different WiFi chip?
        Maybe. As far as I can see, there was no change to the WiFi element of the firmware.

        Comment


          Originally posted by Heuer View Post
          I have a full Unifi system with four AP's (no Wi-Fi 6) and I lost connection to one of my three Radio's last week. Tried installing wlanpoke with no improvement and tried two different Vonets bridge's but neither would connect reliably. Whilst troubleshooting I found both the Radio and Vonets would connect reliably to the AP in my office but not to any of the other three AP's. A swift comparison of the AP settings revealed three had 'band steering' switched on whereas the Office AP did not. Switched all off and Radio now connects happily and no need for Vonets.

          Interestingly this setting only affected the UE Radio, other two 'normal' Radio's are not affected by band steering.

          If your equipment allows it, try binding the problem clients to the primary router or the AP that is allowing the initial connection. You may lose some roaming range, but it can solve the dropouts.

          We are now into our second generation of Asus WiFi 6 mesh systems, and have been able to maintain a stable Radio connection by binding it to the router. Typically we use an upper tier chipset primary router; not the usual Orbi or Zen setup.

          Comment


            Originally posted by agbagb View Post
            Similar problems in new home with new WiFi6......... But I can't find anything called "band steering" in the router management, but what with moving and Madame preparing for knee surgery, I haven't really had a chance to see if this exists. Even with WiFi6 turned off, the Radios (Wlan-poked) will not hold the connection, so maybe it is a band issue rather than a WiFi6 issue as such.

            The other thing that has me puzzled is that when I first try to connect either Radios or Touches *via ethernet*, I still have a heck of a time. I keep getting a "Can't find a DHCP address" error. But, oddly, if I just leave it plugged in to ethernet and walk off for lunch or more unpacking of moving boxes, after half an hour or so, the device *has* connected to ethernet, and works fine from then on. Which makes me think that some odd things are going on with the new router settings, WiFi and Ethernet. I'm too busy to properly fault-chase for a week or so, but I'm sure I'll track the issue down somehow.....
            That may be an address conflict issue. Depending on lease times, that can sometimes take hours to days to clear itself.

            Try resetting the DHCP table on the router with all clients connected, which usually forces a DHCP rescan.

            Comment


              Originally posted by sgmlaw View Post
              If your equipment allows it, try binding the problem clients to the primary router or the AP that is allowing the initial connection. You may lose some roaming range, but it can solve the dropouts.

              We are now into our second generation of Asus WiFi 6 mesh systems, and have been able to maintain a stable Radio connection by binding it to the router. Typically we use an upper tier chipset primary router; not the usual Orbi or Zen setup.
              That's interesting - I'm not sure of correct terminology, but are you saying that getting the router to use a static IP (instead of an DHCP-allocated and changing one....) has enabled a steady Radio connection even on WiFi6 kit?
              8.2.1 - 1639114554
              Win11
              Control: Web GUI; MaterialSkin on Android phones / pads

              b) Freebox Pop Wifi6 / Mesh
              External SSD, WiFi Laptop
              2 x Touch Wireless (Firmware:8.0.1-r16907)
              1 x SB Radio, LAN into Vonets WiFi Bridge (8.0.1-r16907)

              Comment


                Originally posted by agbagb View Post
                That's interesting - I'm not sure of correct terminology, but are you saying that getting the router to use a static IP (instead of an DHCP-allocated and changing one....) has enabled a steady Radio connection even on WiFi6 kit?
                No, not exactly. While I am a proponent of assigning a static IP to the LMS server machine, what I was referring to was binding a wireless client to a particular AP in extender, media bridge, roaming or mesh environments.

                What we initially experienced, not just with the SB Radio, but with other legacy 2.4 Ghz clients as well, is that the connection would drop, either on the initial ‘optimization’ phase, when the system assigns each client to its optimal AP, and during the ‘handoff’ phase, when a system transfers a client from one AP or ‘node’ to another. Either the AP and/or the client chipsets can’t handle that handshake routine, either initially or on renegotiation, and the connection would drop.

                What I found solved the problem (for us) in these multi AP environments was binding those clients to the main wireless router. That is done on the AP side, at the router or DHCP server, and it forces a continuing static connection to that AP, and that AP alone, with no roaming, handoff, or renegotiation events, and the backhaul and repeater links are also completely removed from the equation. Ideally, the client should be bound to the router AP if the router is equipped with one. It is a much simpler connection in more complicated wireless environments (with increasingly diverse traffic).

                Not all roaming, extender-equipped, and mesh equipment supports wireless client binding. And if you are already running a single AP wireless network, it is inapplicable.

                And we were unable to pull this off for one fringe range Touch where binding to the router AP was impractical, and even a bound connection to the nearest node would inevitably drop. In that extreme situation, the solution was an EX2700 extender operating as a media bridge, where the Touch enjoys an ethernet connection, and the wireless network sees only an N protocol client (which presents no problem).

                Comment


                  Ahh - thanks! On my French Freebox POP router, I can't find either what you describe, or the "band steering" that others have mentioned..........
                  8.2.1 - 1639114554
                  Win11
                  Control: Web GUI; MaterialSkin on Android phones / pads

                  b) Freebox Pop Wifi6 / Mesh
                  External SSD, WiFi Laptop
                  2 x Touch Wireless (Firmware:8.0.1-r16907)
                  1 x SB Radio, LAN into Vonets WiFi Bridge (8.0.1-r16907)

                  Comment


                    Originally posted by agbagb View Post
                    Ahh - thanks! On my French Freebox POP router, I can't find either what you describe, or the "band steering" that others have mentioned..........
                    I am unsure what others have suggested. I presume by “band steering” they are referring to auto-switching between 2.4G and 5Ghz bands depending on connection conditions. If that is the case, disabling band steering tends to adversely affect newer clients, preventing them from negotiating up and down on the bands as they roam. It may help an old Squeezebox, but at a very high price to other much higher bandwidth demanding clients. I would resist that solution if you have such mixed clients.

                    In your situation, if binding is not as option, you might want to try an N band AP set up in repeater mode, but with a distinctive SSID. For instance, the EX2700 mentioned above, connected to your network (either wirelessly, or by Ethernet), and accessible as a separate AP as “yournetwork.LMS” or whatever. And then have the Radio connect just to that N protocol AP. That is ‘binding’ of a different form, but it completely segregates the Radio from the primary wireless AP architecture (and all its problems).

                    These SB clients use very little bandwidth by today’s standards, so even an N repeater with wireless up and down links should still get plenty of data to them.

                    Whether these are sold outside the US, I do not know. But you may have similar alternatives where you live.

                    Say goodbye to WiFi dead zones. Convenient, discreet and easy to install, extended WiFi coverage is just an outlet away with this essentials edition extender. Boost your WiFi for mobile devices and connect a wired device such as Smart TVs or game consoles.
                    Last edited by sgmlaw; 2022-12-16, 16:04.

                    Comment


                      This is what Ubiquiti say:

                      "The main purpose of enabling band steering is to decongest the 2.4GHz due to the high number of users connected. Band steering allows users to connect to a 5GHz band which provides faster speed, and less interference, thus reducing the congestion on the 2.4 GHz. However, 5GHz only works on a limited range compared to 2.4 GHz. It cannot penetrate solid objects such as walls. Therefore, the signal wouldn’t be that reliable when you are roaming. Enabling or disabling band steering on your UniFi depends on the user’s preference and the need to steer into a 5GHz band. It would make more sense to stay on 2.4 GHz if there are only a few users connected to your network. Although there would be more interference than the 5GHz band, it provides better coverage. Band steering is not always recommended. Users can always customize band steering per device name depending on need."
                      Lounge: Transporter>Audio Synthesis DAX Decade>Audio Research LS22>Krell FPB300>Wilson Benesch Act 1's + 2 x Velodyne SPL1000 sub's
                      Kitchen: Touch>Topping DAC>Arcam Solo>Anthony Gallo Micro's+Sub, Joggler controller
                      Office: DAC32>Acoustic Energy AE1 Active's, Joggler controller
                      Garage: Boom>QAcoustics 7000s subwoofer
                      Bedroom: Radio
                      Shed: Radio
                      Workshop: Boom
                      Garden 1: SB3>JVC amp>Rock outdoor speakers
                      Garden 2: SB3>JVC amp>Rock outdoor speakers

                      Comment


                        Originally posted by Heuer View Post
                        This is what Ubiquiti say:

                        "The main purpose of enabling band steering is to decongest the 2.4GHz due to the high number of users connected. Band steering allows users to connect to a 5GHz band which provides faster speed, and less interference, thus reducing the congestion on the 2.4 GHz. However, 5GHz only works on a limited range compared to 2.4 GHz. It cannot penetrate solid objects such as walls. Therefore, the signal wouldn’t be that reliable when you are roaming. Enabling or disabling band steering on your UniFi depends on the user’s preference and the need to steer into a 5GHz band. It would make more sense to stay on 2.4 GHz if there are only a few users connected to your network. Although there would be more interference than the 5GHz band, it provides better coverage. Band steering is not always recommended. Users can always customize band steering per device name depending on need."
                        I can't tell whether that is an automatic "on-the-fly" feature, or whether it requires user intervention. My guess if it is more modern equipment, it is an automatic feature, which means it is constantly querying the clients. And that data string can get somewhat verbose to older clients.

                        And that is probably part of the problem for older legacy clients, possibly overloading their buffer ranges at some point. The older 2.4 Ghz chipsets never contemplated this sort of network management traffic.

                        But it does state that it can be client-customized. So the obvious course is to turn it off for SB clients, as they are not 5 Ghz equipped. Whether that stops the constant client queries, I do not know. That would require technical information from the AP/router manufacturer.

                        That feature is not the same as AP binding, but it may help nevertheless. The less asked of the Radio's wireless chipset, the better.

                        Comment


                          Radio loses DNS after X minutes (MY SOLUTION)

                          Hi there,

                          A few weeks ago I activated the 5 GHz. network with an SSID identical to the 2,4 GHz. I was already using for my Squeezebox receivers.(same passwords also)
                          I own 4 Logitech (WE) Radios and a Transporter.
                          The Transporter seems to ignore double SSID but the (WE) Radios get confused after a while and disconnects.
                          Renamed one of them (did not change the identical passwords) and presto ! problem solved.
                          Hope this helps for you.
                          Best regards and a happy and healthy 2023 !
                          Happy TransUser

                          Comment


                            Separating the channels did not help

                            What did work for me:

                            disabling ax radio on 2.4channel. So only a,g,b,n

                            This seems to work, a couple days stable.

                            Previously was using the vonnets Ethernet adapter, which worked for months, but the radio just started to become unstable and needs a reboot after a day or so

                            Comment

                            Working...
                            X