Announcement

Collapse
No announcement yet.

dead Boom, resuscitated

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    dead Boom, resuscitated

    One one photo at a time. 823 made it.

    David

    On Sun, Oct 2, 2022, 4:50 PM tonedeaf <
    tonedeaf.aroqxc (AT) no-mx (DOT) forums.slimdevices.com> wrote:

    >
    > As suggested in the title, the Boom was completely unresponsive. I
    > tested the power supply and it was showing one or two volts flickering
    > in and out, so seems to have failed. I found a replacement power supply,
    > confirmed the 12v, but still the Boom was dead. This was odd, maybe the
    > power supply in its failure mode had taken out the Boom.. I dismantled
    > the Boom (first time - it has been incredibly reliable for many years
    > now) and found some mess around several lines of solder points, most of
    > the board was very clean however. I guess this was residual flux, that
    > should have been cleaned away during manufacture, one of the affected
    > areas was the power input connector line. I cleaned this away with
    > isopropyl alcohol plugged it in again, and it fired up perfectly! Sounds
    > even better than before !
    >
    > Just posting this to record the learning, sometimes the problems are so
    > simple and yet the thing gets chucked..
    >
    > I have attempted to attach some photos (its not obvious to me that these
    > will appear though as I write this).
    >
    > 38821
    > 38822
    > 38823
    >
    >
    > +-------------------------------------------------------------------+
    > |Filename: IMG_1479.JPG |
    > |Download:
    > http://forums.slimdevices.com/attach...hmentid=38823|
    > +-------------------------------------------------------------------+
    >
    > ------------------------------------------------------------------------
    > tonedeaf's Profile: http://forums.slimdevices.com/member.php?userid=39220
    > View this thread: http://forums.slimdevices.com/showthread.php?t=116885
    >
    >

    #2
    dead Boom, resuscitated

    As suggested in the title, the Boom was completely unresponsive. I tested the power supply and it was showing one or two volts flickering in and out, so seems to have failed. I found a replacement power supply, confirmed the 12v, plugged in, but still the Boom was dead. This was odd, maybe the original power supply in its failure mode had taken out the Boom.. I dismantled the Boom (first time - it has been incredibly reliable for many years now) and found some mess around several lines of solder points, most of the board was very clean however. I guess this was residual flux, that should have been cleaned away during manufacture, one of the affected areas was the power input connector line. I cleaned this away with isopropyl alcohol plugged it in again, and it fired up perfectly! Sounds even better than before !

    Just posting this to record the learning, sometimes the problems are so simple and yet the thing gets chucked..



    Click image for larger version

Name:	IMG_1473.JPG
Views:	1
Size:	182.5 KB
ID:	1575776
    Click image for larger version

Name:	IMG_1476.JPG
Views:	1
Size:	241.6 KB
ID:	1575777
    Click image for larger version

Name:	IMG_1479.JPG
Views:	1
Size:	188.2 KB
ID:	1575778
    Last edited by tonedeaf; 2022-10-02, 22:51.

    Comment


      #3
      Thanks David👍

      Comment


        #4
        Brown snot glue may be a problem?

        Hi, a new pre-owned Boom owner here! Keen to clean up a Boom I've just got, and checking for other things should do while I've got it open.

        I see that the original manufacture involved the use of that ghastly brown "snot" glue to hold cables in place, and/or stop high frequency items (coils, capacitors) from whining in sympathy ...

        ... but in some old electronic products I've repaired, some formulations of this horrid glue can start to break down and corrode the PCB tracks and solder joints, and/or become conductive. Its possible that this has started to happen with your Boom, in a similar way that some kinds of acidic flux residue can absorb moisture and then cause problems on a PCB.

        Cheers!

        Comment

        Working...
        X