Announcement

Collapse
No announcement yet.

LMS Update To 8.4.0 - RPi pCP - Media Folders - Pictures & Videos - Gone !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sc1pzb
    replied
    Many thanks CJS. I will do that. Appreciate your assistance.

    Leave a comment:


  • CJS
    replied
    There is an lms update script for pCP for manually updating LMS on pCP, but as far as I can see with this script you can only select between:
    - latest release version (at this moment 8.3.0)
    - latest bugfix version (at this moment 8.3.1 nightly)
    - latest development version (at this moment 8.4.0 nightly)

    What you want is the latest LMS 8.2.1 or 8.2.0 for pCP. My suggestion is to open a thread on the Linux/Unix subforum with the question if it is possible to downgrade LMS to 8.2.1 on piCorePlayer.

    Leave a comment:


  • sc1pzb
    replied
    Many thanks CJS & Paul, your comments are very helpful and now I can read about why these Video and Photo scanning options are removed from LMS. I can see that I wuld have been in the minority of users.I think the comment "I'd say remove it but put a peg in the ground for the "last" release that includes it for those that do use it." Is the good compromise.

    Naturally, it begs the question for me, how can I get the RPi pCP, LMS version back to earlier than 8.3.0 ? I hope it can be possible somehow, perhaps with some work-arounds on the SD card installed in the RPi, which all of pCP runs from. This is where I will need some Linux command help I think.

    Really appreciate the speedy replies. I am trying to fix it soonest so family members can use the Smart TV DLNA access as before. I am usually the one to fix everything here. In this case I was the one to break it!

    Many thanks once again.


    Leave a comment:


  • Paul Webster
    replied
    Here is the thread about it

    Leave a comment:


  • CJS
    replied
    According to the LMS Changelog, support for media types other than audio has been removed since LMS version 8.3.0.
    There was a thread started by mherger with a discussion about this change, but I can't find that thread at this moment.
    Last edited by CJS; 2023-01-30, 12:16.

    Leave a comment:


  • LMS Update To 8.4.0 - RPi pCP - Media Folders - Pictures & Videos - Gone !

    I have been using pCP on RPi for a few years now. Works wonderful for all my legacy Squeezebox' and more recent Logitech Streaming devices. The LMS version installed during the pCP set up allowed media folders to be linked to content. (Music, Pictures, Video). Blue Check Marks as seen below. When the LMS library was scanned this allowed DLNA functionality by Smart TV's to see the Pictures and Videos stored on the HDD connected to the pCP, as well as access/play the music, either via Squeezeboxes or DLNA devices.

    Click image for larger version

Name:	Basic Settings.jpg
Views:	485
Size:	58.7 KB
ID:	1628589
    From the LMS settings I saw that a new version of LMS was recommended for install and using the piCore Player standard Linux commands procedure (which I did many times before, for these LMS updates), the LMS version was updated. I now have this LMS version installed.


    Logitech Media Server Version: 8.4.0 - 1674547289 @ Tue 24 Jan 2023 09:31:23 AM CET

    Hostname: piCoreLMS

    Server IP Address: 192.168.1.64

    Server HTTP Port Number: 9000

    Operating system: piCore - EN - utf8

    Platform Architecture: armv8l-linux

    Perl Version: 5.28.2 - arm-linux-gnueabihf-thread-multi-64int

    Audio::Scan: 1.02

    IO::Socket::SSL: 2.066

    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    Total Players Recognized: 6


    ‚Äč
    After the LMS update to 8.4.0, there is no longer the option for Pictures & Videos media folders to be linked to content. (Music, Pictures, Video). Just a choice for Music.
    When you initiate a library scan, it only finds Music now (not a surprise, given the limited setting options). So Smart TV's with DLNA do not see Pictures or Videos anymore.

    Click image for larger version

Name:	Basic Setting After.jpg
Views:	420
Size:	51.9 KB
ID:	1628590
    I investigated some Windows versions of LMS and it's the same, the older versions support the additional Pictures & Videos media folders and the latest versions do not. I wonder if this is intended feature removal? or a bug?

    I've always ensured the well known 'Andy Grundman' uPnP/DLNA V1.0 'add-on' has been added in all LMS installations. So I don't think the problem relates to an add-on, more the LMS software itself.

    I would like to restore my RPi pCP device to it's prior functionality. I think I have to downgrade the version of LMS that it 'installs into itself' during the RPi pCP setup/upgrade process, but I am not a Linux expert, so I don't know the process of how to select the actual LMS version it installs. I only know how to install the latest version using the commands found at the link below. It's the latest versions that seem to have the problem.

    https://docs.picoreplayer.org/how-to/upgrade_lms/

    It's been very good having a nice small low power device like RPi, running pCP with LMS to support Pictures and Videos as well as Music. I hope I can make it work again.

    Would appreciate any help or guidance and apologies for weaknesses in my Linux awareness. Many thanks.


Working...
X