Announcement

Collapse
No announcement yet.

Logitech Media Server does not scan OPUS file from my UNRAID server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Logitech Media Server does not scan OPUS file from my UNRAID server

    > To note, we are running Perl 5.34 while the new LMS v8.3.1 runs Perl

    "We are running" - maybe you should stick with mainstream, and it might
    just work?...

    #2
    Logitech Media Server does not scan OPUS file from my UNRAID server

    I have a ton of OPUS files on my UNRAID server.
    Through my library scans, i see that it does not pick up any OPUS, OGG files into my library.
    I have 1 album that has scanned and it features into my library and it plays well too.
    Why not the rest of the albums ?

    Please help.
    Last edited by HerculePirate; 2022-11-06, 22:10. Reason: tags

    Comment


      #3
      What version of Audio::Scan is LMS using?

      You can find the details in Settings->Information of the LMS web interface.

      If it's less than 1.05 then that's likely the problem.
      Ralphy

      1-Touch, 5-Classics, 3-Booms, 2-UE Radio
      Squeezebox client builds donations always appreciated.

      Comment


        #4
        Originally posted by HerculePirate View Post
        I have a ton of OPUS files on my UNRAID server.
        Through my library scans, i see that it does not pick up any OPUS, OGG files into my library.
        I have 1 album that has scanned and it features into my library and it plays well too.
        Why not the rest of the albums ?
        The scanner does have a known problem with opus files that contain “largeish” amounts of metadata (more than 65k bytes). The most likely cause of that is embedded artwork. You could check if that’s your problem by experimenting with one or two of the tracks that don’t scan. (E.g. remove artwork and/or all other metadata and try again).

        Make sure that any artwork you may use is small in size, i.e. thumbnails of, say 56k bytes max size.

        Comment


          #5
          I made a fix for large embedded cover art here: https://github.com/LMS-Community/Audio-Scan/pull/1

          It works with my opus files. It's not included in an LMS release yet.

          Comment


            #6
            Originally posted by robho View Post
            I made a fix for large embedded cover art here: https://github.com/LMS-Community/Audio-Scan/pull/1

            It works with my opus files. It's not included in an LMS release yet.
            Interesting. Looks like a different approach to my own work up (in progress - not yet seen by the world). Must compare and contrast.

            Comment


              #7
              Originally posted by ralphy View Post
              What version of Audio::Scan is LMS using?

              You can find the details in Settings->Information of the LMS web interface.

              If it's less than 1.05 then that's likely the problem.
              You are correct
              Audio::Scan: 1.02

              How do I update the LMS to have a latest scanner.
              The version, i am running is Logitech Media Server Version: 8.3.0 - 1661147463
              Thank you.

              HP

              Comment


                #8
                Logitech Media Server does notscan OPUS file from my UNRAID server

                > Audio::Scan: 1.02
                >
                > How do I update the LMS to have a latest scanner.
                > The version, i am running is Logitech Media Server Version: 8.3.0 -
                > 1661147463


                What package did you install?
                Michael

                "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                (LMS: Settings/Information)

                Comment


                  #9
                  This Logitech Media Server is installed on my UNRAID Server.
                  The docker app has only 2 versions of LMS
                  1. dlandon's repository
                  2. snoopy86's repository.

                  I have installed dlandon's LMS.
                  Click image for larger version

Name:	image_2022-11-08_174134451.png
Views:	1
Size:	74.7 KB
ID:	1575956

                  Comment


                    #10
                    Logitech Media Server does notscan OPUS file from my UNRAID server

                    > The docker app has only 2 versions of LMS
                    > 1. dlandon's repository
                    > 2. snoopy86's repository.


                    Can't you use any Docker image from Dockerub? I'd recommend you use the
                    official LMS image instead. Or you'll have to ask dlandon to update his.
                    Michael

                    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                    (LMS: Settings/Information)

                    Comment


                      #11
                      Originally posted by robho View Post
                      I made a fix for large embedded cover art here: https://github.com/LMS-Community/Audio-Scan/pull/1

                      It works with my opus files. It's not included in an LMS release yet.
                      It looks good to me.

                      Comment


                        #12
                        Originally posted by mherger View Post
                        >Can't you use any Docker image from Dockerub? I'd recommend you use the
                        official LMS image instead. Or you'll have to ask dlandon to update his.
                        @mherger
                        So, I did ask dlandon to update the docker which he did and I have installed it on my UNRAID server too but the AudioScan still reads 1.02
                        He says that is the latest build which says that the audio scan is supposedly 1.05 but the install shows 1.02.
                        Any help ?

                        Code:
                        Logitech Media Server Version: 8.3.0 - 1667251155 @ Fri 04 Nov 2022 09:17:53 AM CET
                        Hostname: 0e45e0188eff
                        Server IP Address: 123.123.123.123
                        Server HTTP Port Number: 9000
                        Operating system: Debian - EN - utf8
                        Platform Architecture: x86_64-linux
                        Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
                        Audio::Scan: 1.02
                        IO::Socket::SSL: 2.067
                        Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
                        Total Players Recognized: 0
                        Last edited by HerculePirate; 2022-11-11, 05:49.

                        Comment


                          #13
                          Hello,

                          I'm sorry if this it not related to the topic but when you install logitechmediaserver_8.3.1~1667914563_all.deb on a raspberry pi 4 with Raspberry Pi OS 64 it also shows version 1.02 .

                          Code:
                          Logitech Media Server Version: 8.3.1 - 1667914563 @ Tue 08 Nov 2022 02:57:15 PM CET
                          Server-HTTP-Portnummer: 9000
                          Betriebssystem: Debian - DE - utf8
                          Plattformarchitektur: aarch64-linux
                          Perl-Version: 5.32.1 - aarch64-linux-gnu-thread-multi
                          Audio::Scan: 1.02
                          IO::Socket::SSL: 2.069
                          Datenbankversion: DBD::SQLite 1.58 (sqlite 3.22.0)

                          Comment


                            #14
                            Logitech Media Server does notscan OPUS file from my UNRAID server

                            > I'm sorry if this it not related to the topic but when you install
                            > logitechmediaserver_8.3.1~1667914563_all.deb on a raspberry pi 4 with
                            > Raspberry Pi OS 64 it also shows version 1.02 .


                            We haven't updated the module for all possible platforms and Perl
                            versions. Some are still outdated. You could try to compile the module
                            yourself using the sources and build script from
                            https://github.com/Logitech/slimserv...ublic/8.3/CPAN.
                            Basically

                            ../buildme.sh Audio::Scan

                            Michael

                            "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                            (LMS: Settings/Information)

                            Comment


                              #15
                              Logitech Media Server does notscan OPUS file from my UNRAID server

                              > So, I did ask dlandon to update the docker which he did and I have
                              > installed it on my UNRAID server too but the AudioScan still reads 1.02
                              > He says that is the latest build which says that the audio scan is
                              > supposedly 1.05 but the install shows 1.02.


                              Why don't you use the official Docker image. It's up to date with all
                              dependencies.

                              dlandon would probably have to update the base image, too. As the Perl
                              version it's coming with isn't fully supported with the latest of our
                              Audio::Scan builds.
                              Michael

                              "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                              (LMS: Settings/Information)

                              Comment

                              Working...
                              X