Announcement

Collapse
No announcement yet.

server filling syslog with messages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    server filling syslog with messages

    > Has the OP tried putting the line -SLIMOPTIONS="--quiet"- in the file
    > -/etc/default/logitechmediaserver- ?

    When the log file is filling up the filesystem then you should first of
    all figure out why it is logging that much! In normal use there should
    be very little output. Either reset the logging options, or fix whatever
    is causing the log statements (and that's what the thread initially was
    about).
    2 SB3, 1 Duet
    Debian Buster server LMS 8.3,0
    TP-Link AX3000 Wi-Fi 6 Router wireless network.

    #2
    server filling syslog with messages

    Suddenly, I'm seeing messages like:
    Sep 23 01:34:40 aptiva squeezeboxserver[634]: [22-09-22 18:28:08.7245] Slim::Web::Graphics::artworkRequest (339) Looking for: html/images/Players/receiver.jpg in skin Default
    in /var/log/syslog.
    I'm on Logitech Media Server Version: 8.2.1 - 1652959290 @ Thu 19 May 2022 01:30:57 PM CEST
    Debian 10 (buster)
    Is there a setting I'm missing?
    2 SB3, 1 Duet
    Debian Buster server LMS 8.3,0
    TP-Link AX3000 Wi-Fi 6 Router wireless network.

    Comment


      #3
      server filling syslog with messages

      > Suddenly, I'm seeing messages like:
      > Sep 23 01:34:40 aptiva squeezeboxserver[634]: [22-09-22 18:28:08.7245]
      > Slim::Web::Graphics::artworkRequest (339) Looking for:
      > html/images/Players/receiver.jpg in skin Default
      > in /var/log/syslog.


      Check your settings in Settings/Advanced/Logging. You can select the
      Default settings at the top, and make sure you check the "keep during
      reboot" or similar box.
      Michael

      "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
      (LMS: Settings/Information)

      Comment


        #4
        thanks but I was concerned about where the log was going. I expected it to be in the squeezebox logs, not in syslog.
        i will try your advice anyway.
        2 SB3, 1 Duet
        Debian Buster server LMS 8.3,0
        TP-Link AX3000 Wi-Fi 6 Router wireless network.

        Comment


          #5
          Still putting what look like scanner messages in syslog. Examples:

          Sep 25 04:00:25 aptiva squeezeboxserver[634]: [22-09-24 04:00:25.2507] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: rescan
          ...
          Sep 25 04:00:25 aptiva squeezeboxserver[634]: [22-09-24 17:00:43.3916] Slim::Utils::Scanner::Local::__ANON__ (288) Get changed tracks count

          This is triggered by a scheduled rescan.
          2 SB3, 1 Duet
          Debian Buster server LMS 8.3,0
          TP-Link AX3000 Wi-Fi 6 Router wireless network.

          Comment


            #6
            I'm also getting my syslog flooded by messages like this, several times per second:
            "squeezeboxserver[932]: #011file:///var/lib/squeezeboxserver/prefs/clientplaylist_000000000000.m3u doesn't exist on disk - skipping!"
            16145 lines out of 98886 are from squeezeboxserver.
            (some of?) the same messages also appear in the /var/log/squeezeboxserver/server.log file

            All my debug settings are the default values.
            Last edited by dborn; 2022-11-19, 02:04.
            Logitech Media Server Version: 8.3.1 - 1667914563 @ Tue 08 Nov 2022 02:53:42 PM CET

            2 Squeezebox Booms, wifi & wired
            piCorePlayer V6.1.0 on a RaspberryPi 4, 2GB and Hifiberry DAC+

            Comment


              #7
              server filling syslog with messages

              > "squeezeboxserver[932]:
              > #011file:///var/lib/squeezeboxserver/prefs/clientplaylist_000000000000.m3u
              > doesn't exist on disk - skipping!"


              Is there no different line before or after that? Can you share a longer
              excerpt pluss the full server.log.zip file?

              > Logitech Media Server Version: 7.9.2 - 1578996832 @ Tue Jan 14 12:15:02


              If that's still true, then I'd recommend you upgrade your system.
              Michael

              "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
              (LMS: Settings/Information)

              Comment


                #8
                I'm still seeing this with 8.3.0 in syslog.

                Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:11.0387] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: rescan
                Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:11.2374] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: prefset
                Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:14.7362] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: scanner notify
                Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:19.1037] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: scanner notify
                ...
                for about 100 lines.
                2 SB3, 1 Duet
                Debian Buster server LMS 8.3,0
                TP-Link AX3000 Wi-Fi 6 Router wireless network.

                Comment


                  #9
                  Originally posted by Millwood View Post
                  I'm still seeing this with 8.3.0 in syslog.

                  Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:11.0387] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: rescan
                  Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:11.2374] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: prefset
                  Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:14.7362] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: scanner notify
                  Nov 19 04:00:46 aptiva squeezeboxserver[606]: [22-11-18 04:00:19.1037] Slim::Plugin::xPL::Plugin::xplExecuteCallback (619) Warning: Called without a client: scanner notify
                  ...
                  for about 100 lines.
                  Unless you have a specific use for it disable the xPL Interface plugin.

                  Comment


                    #10
                    Removed xPL

                    Nov 21 04:00:04 aptiva squeezeboxserver[606]: [22-11-21 04:00:04.4078] main::main (202) Starting Logitech Media Server scanner (v8.3.0, 1667251155, Fri 04 Nov 2022 09:14:25 AM CET) perl 5.028001
                    Nov 21 04:00:07 aptiva squeezeboxserver[606]: [22-11-21 04:00:07.2408] Slim::Music::Import::runImporter (579) Starting Slim::Media::MediaFolderScan scan
                    Nov 21 04:00:07 aptiva squeezeboxserver[606]: [22-11-21 04:00:07.2412] Slim::Utils::Scanner::Local::rescan (179) Discovering audio files in /home/marc/BigStuff/RIPDIR
                    Nov 21 04:00:11 aptiva squeezeboxserver[606]: [22-11-21 04:00:11.5099] Slim::Utils::Scanner::Local::__ANON__ (191) Start processing found tracks
                    Nov 21 04:00:11 aptiva squeezeboxserver[606]: [22-11-21 04:00:11.5103] Slim::Utils::Scanner::Local::__ANON__ (199) Connect do DB
                    ...
                    52 lines altogether in syslog which also appear in the squeezebox scanner log.
                    2 SB3, 1 Duet
                    Debian Buster server LMS 8.3,0
                    TP-Link AX3000 Wi-Fi 6 Router wireless network.

                    Comment


                      #11
                      LMS uses Log4Perl ... so perhaps that has somehow been configured to send to syslog.

                      It look like starting LMS with -logfile syslog will make it send data there instead of its own logs.

                      Are you seeing the same log entries in syslog AND scanner.log/server.log ?
                      Paul Webster
                      Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
                      and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

                      Comment


                        #12
                        Originally posted by Paul Webster View Post
                        LMS uses Log4Perl ... so perhaps that has somehow been configured to send to syslog.

                        It look like starting LMS with -logfile syslog will make it send data there instead of its own logs.

                        Are you seeing the same log entries in syslog AND scanner.log/server.log ?
                        As I said above, scanner seems duplicated in syslog. server log is NOT duplicated in syslog.
                        2 SB3, 1 Duet
                        Debian Buster server LMS 8.3,0
                        TP-Link AX3000 Wi-Fi 6 Router wireless network.

                        Comment


                          #13
                          While scanner is running can you check to see what command line it was launched with?

                          ps -ef | grep perl

                          will probably show it
                          Paul Webster
                          Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
                          and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

                          Comment


                            #14
                            Originally posted by Paul Webster View Post
                            While scanner is running can you check to see what command line it was launched with?

                            ps -ef | grep perl

                            will probably show it
                            /usr/sbin/squeezeboxserver-scanner --logdir=/var/log/squeezeboxserver/ --prefsdir=/var/lib/squeezeboxserver/prefs --priority=0 --logconfig=/var/lib/squeezeboxserver/prefs/log.conf --rescan --debug artwork=ERROR,formats.playlists=ERROR,plugin.tidal =ERROR,database.info=ERROR,database.virtuallibrari es=ERROR,scan=ERROR,formats.audio=ERROR,scan.impor t=ERROR,scan.auto=DEBUG,scan.scanner=ERROR
                            2 SB3, 1 Duet
                            Debian Buster server LMS 8.3,0
                            TP-Link AX3000 Wi-Fi 6 Router wireless network.

                            Comment


                              #15
                              Perhaps something in the referred to
                              /var/lib/squeezeboxserver/prefs/log.conf
                              might help
                              Paul Webster
                              Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
                              and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

                              Comment

                              Working...
                              X