Announcement

Collapse
No announcement yet.

Most recent MacOS update broke LMS?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Most recent MacOS update broke LMS?

    > This seems to work correctly. As expected, a one-time Allow Access
    > dialog appears, and then the allowance is added to Files & Folders, and
    > no longer requires re-authorizing with each server restart.


    Thanks for the confirmation! I'll merge that right away. New 8.3.1/8.4
    should come with signed binaries.

    #2
    Most recent MacOS update broke LMS?

    I hadn't used LMS for the past three weeks, and now suddenly neither of my Booms can connect to LMS and I keep getting the attached message about Perl and the firewall, when I restart my Mac or open the LMS preference pane. I can open the LMS preference pane, and it no longer shows the Booms on the info tab. Bash and Perl already have full disk access. The only thing that has changed since I last used LMS is that my M1 Mac Mini installed a MacOS update. I tried updating to the latest version of LMS 8.3 but it did not help.

    Click image for larger version

Name:	Perl firewall message.jpg
Views:	1
Size:	275.4 KB
ID:	1575702

    Comment


      #3
      Did you allow LMS to accept incoming connections?
      Michael

      "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
      (LMS: Settings/Information)

      Comment


        #4
        Originally posted by mherger View Post
        Did you allow LMS to accept incoming connections?
        Yes, I keep clicking "Allow" but it keeps asking, and the Booms cannot connect. And just to be clear, this behavior started spontaneously, LMS was working before for years. The only thing that changed recently was a MacOS update.

        See firewall setting below.

        Click image for larger version

Name:	LMS firewall setting.jpg
Views:	1
Size:	276.1 KB
ID:	1575704
        Last edited by dmw010; 2022-09-14, 01:45.

        Comment


          #5
          Most recent MacOS update broke LMS?

          > Yes, I keep clicking "Allow" but it keeps asking, and the Booms cannot
          > connect. And just to be clear, this behavior started spontaneously, LMS
          > was working before for years. The only thing that changed recently was a
          > MacOS update.


          Are you on 12.6 or some pre-release Version already? I'm on 12.6 and
          haven't seen that behaviour yet.
          Michael

          "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
          (LMS: Settings/Information)

          Comment


            #6
            Originally posted by mherger View Post
            >Are you on 12.6 or some pre-release Version already? I'm on 12.6 and
            haven't seen that behaviour yet.
            I'm on 12.6

            Comment


              #7
              Just installed today's new version of LMS and my Booms were able to connect again! Still got a perl connection permission request (which I allowed) when I restarted my Mac, but did not get subsequent requests when I opened the LMS preference pane. Thank you!

              Comment


                #8
                Originally posted by dmw010 View Post
                Just installed today's new version of LMS and my Booms were able to connect again! Still got a perl connection permission request (which I allowed) when I restarted my Mac, but did not get subsequent requests when I opened the LMS preference pane. Thank you!
                Ugh, this started happening again a few days ago, getting the Perl access message every time I restart my Mac, and LMS can’t see either of my Boom players. I’m running LMS 8.3 and have not upgraded to MacOS Ventura yet. I’ve tried multiple reboots of my Mac as well as the Booms.

                Comment


                  #9
                  Most recent MacOS update broke LMS?

                  > Ugh, this started happening again a few days ago, getting the Perl
                  > access message every time I restart my Mac, and LMS can’t see either of
                  > my Boom players. I’m running LMS 8.3 and have not upgraded to MacOS
                  > Ventura yet. I’ve tried multiple reboots of my Mac as well as the Booms.


                  Do you have the firewall enabled? LMS might be using the new Perl now,
                  which needs to be granted access, too.
                  Michael

                  "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                  (LMS: Settings/Information)

                  Comment


                    #10
                    Originally posted by mherger View Post
                    > Ugh, this started happening again a few days ago, getting the Perl
                    > access message every time I restart my Mac, and LMS can’t see either of
                    > my Boom players. I’m running LMS 8.3 and have not upgraded to MacOS
                    > Ventura yet. I’ve tried multiple reboots of my Mac as well as the Booms.


                    Do you have the firewall enabled? LMS might be using the new Perl now,
                    which needs to be granted access, too.
                    Yes, firewall is enabled. Where is the “new” Perl located? I’ve previously granted full access to bash and two other versions of Perl.

                    Comment


                      #11
                      Originally posted by dmw010 View Post
                      Yes, firewall is enabled. Where is the “new” Perl located? I’ve previously granted full access to bash and two other versions of Perl.
                      /Library/PreferencePanes/Squeezebox.prefPane/Contents/perl/bin/perl

                      Comment


                        #12
                        Originally posted by MrC View Post
                        /Library/PreferencePanes/Squeezebox.prefPane/Contents/perl/bin/perl
                        I just updated to 8.3 in advance of the new Mac OS update (I have an M1 iMac). I can add this version of perl to the full disk access, to allow access on my external hard drive. But the access does not stay permanent. Any help?
                        Last edited by bgalizio; 2022-11-11, 22:53.

                        Comment


                          #13
                          Originally posted by bgalizio View Post
                          I just updated to 8.3 in advance of the new Mac OS update (I have an M1 iMac). I can add this version of perl to the full disk access, to allow access on my external hard drive. But the access does not stay permanent. Any help?
                          It seems that starting via the System Settings > Logitech Media Server will always re-request Network Volume or Removable Volume access. But starting via command line does not, and allowing Network Volume or Removable Volume access from perl remains activated:

                          Code:
                          /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/slimserver.pl
                          So this is indicating that macOS is treating startup via Settings differently. The parent process of the command line above is your shell, and those commands inherit their access from the launching terminal app (e.g. Terminal, iTerm2).

                          But the parent process ID of the LMS settings panel is 1 (this is launchd), and the ultimately invoked slimserver.pl command gains its access from the System Settings > Logitech Media Server binary.

                          I'm not sure the reason why this is no longer working, and I didn't find a workaround. Ventura's GateKeeper has more restrictions.

                          So perhaps until this is discovered, just launch LMS via the command line, as in :

                          Code:
                          /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/slimserver.pl &
                          Last edited by MrC; 2022-11-12, 07:39.

                          Comment


                            #14
                            Originally posted by MrC View Post
                            I'm not sure the reason why this is no longer working, and I didn't find a workaround. Ventura's GateKeeper has more restrictions.
                            Ok, here's a workaround. You need to ad-hoc codesign the important binaries, since the distribution is not signed by Michael or Logitech. Stop LMS and run the following in Terminal:

                            Code:
                            codesign -s - /Library/PreferencePanes/Squeezebox.prefPane
                            codesign -s - /Library/PreferencePanes/Squeezebox.prefPane/Contents/perl/bin/perl
                            Start LMS via Settings. You'll get the request persmission dialog once now, and then it should remain.

                            This would need to be repeated after any new LMS installation / update.
                            Last edited by MrC; 2022-11-12, 01:51.

                            Comment


                              #15
                              Thanks - I’ll reinstall 8.3 soon and give that a try!

                              Comment

                              Working...
                              X