Announcement

Collapse
No announcement yet.

slimp3slave startup on debian

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    slimp3slave startup on debian

    I'd like to set up my slimp3slave debian player up so that it just starts up
    automatically on boot. Its a home machine inside a firewall and security
    isn't really an issue.
    Has someone got a script or maybe point me at a general purpose howto.
    I'm a happy squeezebox user, this is just for another headless dumpster
    reclaimed player to synchronize with it.

    #2
    slimp3slave startup on debian

    On Thu, 2004-04-08 at 13:18 +1200, pmcdowell wrote:

    > I'd like to set up my slimp3slave debian player up so that it just starts up
    > automatically on boot. Its a home machine inside a firewall and security
    > isn't really an issue.
    > Has someone got a script or maybe point me at a general purpose howto.
    > I'm a happy squeezebox user, this is just for another headless dumpster
    > reclaimed player to synchronize with it.


    cat /etc/init.d/README

    alexd
    --

    Comment


      #3
      Not really...

      slimp3slave has a segfault issue when it isn't foreground in a console. even backgrounding it causes a segfault... I think there's a memory allocation/access issue (from the segfault), but it's 900+ lines of code I'd rather not debug for a pointer error =/

      I ran it as a service, but it segfaults there too.

      Comment


        #4
        Re: slimp3slave startup on debian

        > slimp3slave has a segfault issue when it isn't foreground in a
        > console.
        > even backgrounding it causes a segfault... I think there's a memory
        > allocation/access issue (from the segfault), but it's 900+ lines of
        > code I'd rather not debug for a pointer error =/


        Try v0.3 (latest is IMHO 0.4). The latter caused more problems for me, too. 0.3 doesn't offer the text based UI, but did its job of playing quite fine.



        --

        Michael

        -----------------------------------------------------------
        Help translate SlimServer by using the
        SlimString Translation Helper (http://www.herger.net/slim/)
        Last edited by mherger; 2005-09-20, 07:55.
        Michael

        "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
        (LMS: Settings/Information)

        Comment


          #5
          If you are interested, I have managed to get this to work.

          I created a -b option (background) and changed one line in the code.

          Comment


            #6
            Re: slimp3slave startup on debian

            > If you are interested, I have managed to get this to work.
            >
            > I created a -b option (background) and changed one line in the code.


            Yes please!

            --

            Michael

            -----------------------------------------------------------
            Help translate SlimServer by using the
            StringEditor Plugin (http://www.herger.net/slim/)
            Michael

            "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
            (LMS: Settings/Information)

            Comment


              #7
              G'day all,

              Here is a patch to update your c code

              It works for me, no guarantee's it will work for you :-)

              Comment


                #8
                Re: slimp3slave startup on debian

                > If you are interested, I have managed to get this to work.
                >
                > I created a -b option (background) and changed one line in the code.


                Excellent! Works like a charm. Thanks a lot!

                --

                Michael

                -----------------------------------------------------------
                Help translate SlimServer by using the
                StringEditor Plugin (http://www.herger.net/slim/)
                Michael

                "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                (LMS: Settings/Information)

                Comment


                  #9
                  Originally posted by stinga`
                  If you are interested, I have managed to get this to work.

                  I created a -b option (background) and changed one line in the code.
                  I'd love to hear about this too!

                  Comment


                    #10
                    Re: slimp3slave startup on debian

                    >> If you are interested, I have managed to get this to work.
                    >> I created a -b option (background) and changed one line in the code.

                    >
                    > I'd love to hear about this too!


                    I downloaded his patch, compiled and have it running since without a
                    problem using the following command line:

                    slimp3slave -b -s localhost

                    --

                    Michael

                    -----------------------------------------------------------
                    Help translate SlimServer by using the
                    StringEditor Plugin (http://www.herger.net/slim/)
                    Michael

                    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                    (LMS: Settings/Information)

                    Comment


                      #11
                      I've managed to apply the patch and compile slimp3slave. I had to change 'curses' into 'ncurses' in slimp3slave.c and the Makefile.

                      It plays the music fine but 2 problems remain:
                      - as root, the music plays fine but it still comes up and says "Playmode: 3" every time I change the song.
                      - otherwise it says "Ignoring sigpipe" and no music plays. The Playmode message also appears in between.

                      It's on Suse 9.3 (and I know next to nothing about linux). Any tips?

                      Comment


                        #12
                        Re: slimp3slave startup on debian

                        On 25/10/05 09:55:05, Roger the Shrubber wrote:
                        >
                        > I've managed to apply the patch and compile slimp3slave. I had to
                        > change
                        > 'curses' into 'ncurses' in slimp3slave.c and the Makefile.
                        >
                        > It plays the music fine but 2 problems remain:
                        > - as root, the music plays fine but it still comes up and says
                        > "Playmode: 3" every time I change the song.
                        > - otherwise it says "Ignoring sigpipe" and no music plays. The
                        > Playmode message also appears in between.
                        >
                        > It's on Suse 9.3 (and I know next to nothing about linux). Any tips?
                        >
                        >


                        Did you run it with the -b option?
                        --
                        'ooroo

                        stinga...(-)
                        ---------------------------------------------------
                        Email: stinga (AT) wolf-rock (DOT) com o
                        You need only two tools. o /////
                        A hammer and duct tape. If it /@ `\ /) ~
                        doesn't move and it should, > (O) X< ~ Fish!!
                        use the hammer. If it moves and `\___/' \) ~
                        shouldn't, use the tape. \\\
                        ---------------------------------------------------

                        Comment


                          #13
                          Yes, with -b.
                          The patch seems to be applied properly because the .c file has 'while((opt = getopt(argc, argv, "+vlbhs:c:")) != -1)' in it.

                          Is it supposed to return to the prompt because I also don't get back when I start?

                          Comment


                            #14
                            Re: slimp3slave startup on debian

                            On 25/10/05 12:25:46, Roger the Shrubber wrote:
                            >
                            > Yes, with -b.
                            > The patch seems to be applied properly because the .c file has
                            > 'while((opt = getopt(argc, argv, "+vlbhs:c:")) != -1)' in it.
                            >
                            > Is it supposed to return to the prompt because I also don't get back
                            > when I start?
                            >
                            >


                            Nope it just supposed to sit there making noise... :-)

                            If you want ti actually background it, thaen use of the & is required!
                            Maybe 'background' was not such a good description.

                            --
                            'ooroo

                            stinga...(-)
                            ---------------------------------------------------
                            Email: stinga (AT) wolf-rock (DOT) com o
                            You need only two tools. o /////
                            A hammer and duct tape. If it /@ `\ /) ~
                            doesn't move and it should, > (O) X< ~ Fish!!
                            use the hammer. If it moves and `\___/' \) ~
                            shouldn't, use the tape. \\\
                            ---------------------------------------------------

                            Comment


                              #15
                              I don't know what & does (or how to use it), but I can get it to run and show a prompt again with:
                              startproc -u slimserver /usr/local/slimserver/slimp3slave/slimp3slave -b -s localhost

                              but then I still get "Ignoring sigpipe" (as slimserver) and "Playmode: 3" (as root and as slimserver).

                              Comment

                              Working...
                              X