Announcement

Collapse
No announcement yet.

IP Addresses PiCore

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    If 1 day is the default then it should be OK, I was thinking it may have been set to zero or something extreme.

    Comment


      #17
      Originally posted by Greg Erskine View Post
      If 1 day is the default then it should be OK, I was thinking it may have been set to zero or something extreme.
      It entirely depends on whether or not the Pi is shutdown when not in use. If it is then 1 day isn’t very long at all.
      Jim
      https://jukeradio.double6.net


      VB2.4 storage QNAP TS419p (NFS)
      Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
      Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
      Dining Room SB Radio
      Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
      Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
      Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

      Comment


        #18
        Pi is on all the time other than when I'm away for more than a couple of weeks. Other devices are off overnight. Some might be off line for a longer period. I've reset the lease time to 10 days. Will see how we go.
        Nicholas

        RPi4 / piCorePlayer v8.1.0 /Logitech Media Server Version: 8.3.0/ Hifiberry Digi+
        3 Chromecast (2 mini x1 Chromecast Audio) 2 UPNP devices
        also use a Gramofon off platform

        Comment


          #19
          I'm going to go against the "flow" here...

          I've never used a router to reserve addresses, I set the DHCP range on the router to be relatively small and then use the non DHCP unallocated blocks of addresses for types of devices that I may need to manage... and allocate and configure a fixed IP address for each of those devices... even the SB Players.

          So for example

          DHCP Range (x40) 192.168.0.10-50 - For transient devices that do not need to be managed by access via IP address

          Fixed addresses:
          Rpi servers (pCP, PiHole, Webserver, OpenVPN server) 192.168.0.81 to 85
          Printer (x1) 192.168.0.61
          Network switches (x4) 192.168.0.131 to 134
          Network Attached Storage (x3) 192.168.0.201 to 203
          Wireless APs (x3) 192.168.0.241 to 243
          SB Players (x5) 192.168.0.111 to 115

          Only have to do it once per device as I introduce and set it up, if/when I change router all I have to do is configure it to have the same IP address, subnet mask and DHCP range as the outgoing router - and all my "managed" devices reappear with their original assigned IP addresses and I always know where each device will be address wise when I need to manage it either via web page, telnet, etc...

          I've never had an issue setting up or subsequently finding a device using this system, yeah it's old school manual/total control stuff but then I started out before DHCP was introduced to help manage large networks, so it's no big deal for me.

          Kev
          Last edited by KeBul; 2022-11-16, 01:41.

          Comment


            #20
            Search for Static Leases on Your router.
            Bear in mind the IPs You define have to belong to the DHCP pool addresses.

            Comment


              #21
              Originally posted by KeBul View Post
              I'm going to go against the "flow" here...

              I've never used a router to reserve addresses, I set the DHCP range on the router to be relatively small and then use the non DHCP unallocated blocks of addresses for types of devices that I may need to manage... and allocate and configure a fixed IP address for each of those devices... even the SB Players.

              So for example

              DHCP Range (x40) 192.168.0.10-50 - For transient devices that do not need to be managed by access via IP address

              Fixed addresses:
              Rpi servers (pCP, PiHole, Webserver, OpenVPN server) 192.168.0.81 to 85
              Printer (x1) 192.168.0.61
              Network switches (x4) 192.168.0.131 to 134
              Network Attached Storage (x3) 192.168.0.201 to 203
              Wireless APs (x3) 192.168.0.241 to 243
              SB Players (x5) 192.168.0.111 to 115

              Only have to do it once per device as I introduce and set it up, if/when I change router all I have to do is configure it to have the same IP address, subnet mask and DHCP range as the outgoing router - and all my "managed" devices reappear with their original assigned IP addresses and I always know where each device will be address wise when I need to manage it either via web page, telnet, etc...

              I've never had an issue setting up or subsequently finding a device using this system, yeah it's old school manual/total control stuff but then I started out before DHCP was introduced to help manage large networks, so it's no big deal for me.

              Kev

              Methinks you aren't likely to be using a BT Hub!
              I'm also old school and used to do as you do - particularly servers which may need a different gateway for esoteric purposes - but I would always use DHCP when it is a wireless device just because it makes troubleshooting a little easier.
              Jim
              https://jukeradio.double6.net


              VB2.4 storage QNAP TS419p (NFS)
              Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
              Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
              Dining Room SB Radio
              Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
              Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
              Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

              Comment


                #22
                Originally posted by d6jg View Post
                Methinks you aren't likely to be using a BT Hub!
                I'm also old school and used to do as you do - particularly servers which may need a different gateway for esoteric purposes - but I would always use DHCP when it is a wireless device just because it makes troubleshooting a little easier.
                Haha! - Correct I now use Draytek stuff, but I have used BT Hub's in the past, they also worked fine in my setup, but I moved away from them after BT screwed things up with a pushed TR-069 update.

                Point I was trying to make was there should be no issue with setting a static IP address on pCP, if you know or can set your routers DHCP range then just pick an address outside of that range and configure the pCP accordingly in the Main page Beta functions "Static IP" button.
                Help on that states you will need to re-configure the IP address after an insitu update - have to say can't ever remember having to do that - perhaps I've never done an insitu update.

                Kev

                Comment


                  #23
                  Originally posted by KeBul View Post
                  Haha! - Correct I now use Draytek stuff, but I have used BT Hub's in the past, they also worked fine in my setup, but I moved away from them after BT screwed things up with a pushed TR-069 update.

                  Point I was trying to make was there should be no issue with setting a static IP address on pCP, if you know or can set your routers DHCP range then just pick an address outside of that range and configure the pCP accordingly in the Main page Beta functions "Static IP" button.
                  Help on that states you will need to re-configure the IP address after an insitu update - have to say can't ever remember having to do that - perhaps I've never done an insitu update.

                  Kev
                  I also use Draytek Vigor’s both for me and virtually all my customers. The dhcp server on them allows you to reserve an IP outside the usual scope which is very handy for things like servers and printers and other peripherals that you access via web gui.
                  You do get what you pay for!
                  Jim
                  https://jukeradio.double6.net


                  VB2.4 storage QNAP TS419p (NFS)
                  Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
                  Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
                  Dining Room SB Radio
                  Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
                  Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
                  Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

                  Comment


                    #24
                    In the extremely unlikely situation that someone searches this issue (BTHub 6 and reserved IP addresses) I haven't found a solution as such but I think I have discovered the cause of the issue - a wifi extender.

                    Since Spotify Connect doesn't work in LMS anymore I dusted down an old gramofon device I had in storage. By default this device extends your wifi signal and it was positioned a meter or so away from the pi. The pi was connecting to the gramofon as it had the stronger signal (the SSID is the same).

                    The problems arose because the gramofon unlike the pi is powered down over night. All this chopping and changing connections seemed to be the issue as since I disabled the wifi extending capability I've had no issues. The ip address issue always showed up first thing in the morning.

                    I thought i'd update on the off chance someone else has a similar issue.
                    Nicholas

                    RPi4 / piCorePlayer v8.1.0 /Logitech Media Server Version: 8.3.0/ Hifiberry Digi+
                    3 Chromecast (2 mini x1 Chromecast Audio) 2 UPNP devices
                    also use a Gramofon off platform

                    Comment


                      #25
                      Thanks for reporting.

                      Comment


                        #26
                        To OP:

                        On your router settings, you seem to have "Always use this IP address = NO".

                        Shouldn't that be "YES"?
                        Martin

                        Comment


                          #27
                          Originally posted by mooblie View Post
                          To OP:

                          On your router settings, you seem to have "Always use this IP address = NO".

                          Shouldn't that be "YES"?
                          You are quite right.

                          When I originally changed it to "yes", the setting would not save (after hitting the save button). It would just report that the changes need to be saved. Once I disabled the wifi extender I was able to save it and it is now changed to "Yes".
                          Nicholas

                          RPi4 / piCorePlayer v8.1.0 /Logitech Media Server Version: 8.3.0/ Hifiberry Digi+
                          3 Chromecast (2 mini x1 Chromecast Audio) 2 UPNP devices
                          also use a Gramofon off platform

                          Comment

                          Working...
                          X