Announcement

Collapse
No announcement yet.

Announce: piCorePlayer 8.0.0

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Headless RPI3 no longer headless!

    I have tried the upgrades listed above in both the 8 bit and 64 bit versions. In both cases, Squeezelite is unable to run. When I reboot with a console connected to the HDMI port all runs perfectly.....can anyone advise on this, please?
    Thanks for the help

    George

    Comment


    • Originally posted by gbcambridge
      Headless RPI3 no longer headless!
      I have tried the upgrades listed above in both the 8 bit and 64 bit versions. In both cases, Squeezelite is unable to run. When I reboot with a console connected to the HDMI port all runs perfectly.....can anyone advise on this, please?
      With upgrades listed above you mean piCorePlayer 8.2.0? And when you say 8 bit you probably mean 32 bit? How did you upgrade?

      When you run pCP without console connected to the HDMI port, can you still access the pCP web interface? FYI, when I updated from pCP 7 to PCP 8, I did a Full Update (i.e. Insitu Update) from the Main page of the pCP web interface, and that worked perfectly fine.
      | LMS 8.3.2 on Linux Mint 21.2 | Squeezebox Boom | RPi0W + pCP 8.2.0 + HiFiBerry DAC Zero | ESP Muse Luxe |

      Comment


      • Hi,
        As it is mentioned in this post: https://forums.slimdevices.com/forum...56#post1638156 I have problem with shairport-sync piCorePlayer 8.2.0. After upgrade to version 4.1.1 it is not working anymore with RPi Zero W. I have similar installation on RPi 3A and it is perfectly fine.

        Comment


        • Squeezelite v1.9.9-1430 is available.
          Click the Update button on the Main Page tab of the web admin to install.

          Also, the shairport-sync 32-bit package has been updated to fix the problem of it failing to start on armv6 based systems.
          Disable and enable shairport-sync on the tweaks tab of the web interface to update that extension.‚Äč
          Ralphy

          1-Touch, 5-Classics, 3-Booms, 2-UE Radio
          Squeezebox client builds donations always appreciated.

          Comment


          • The sourceforge mirror repo wasn't updating again.....should be fixed now.
            piCorePlayer a small player for the Raspberry Pi in RAM.
            Homepage: https://www.picoreplayer.org

            Please donate if you like the piCorePlayer

            Comment


            • Moved from Volumio to pCP and so far really like it
              Have a WIndows Server with LMS installed and that works great.
              Have 2 RPi,
              • 1 x 3B with HiFiBerry Amp2
              • 1 x RPi 3A+ that is connected to a Yamaha receiver via HDMI
              Problem I no seem to have is that Sync is not in sync.

              Could the issue be that one of the RPi has a DAC hat which introduces latency?
              Is there any way I can setup a fixed delay on one of the RPi?

              Comment


              • LMS settings > Player Tab > Synchronise.

                Click image for larger version

Name:	sync.jpg
Views:	378
Size:	45.1 KB
ID:	1638650
                Server - LMS 8.4.0 RPi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)

                Lounge - DAC32 - AudioEngine B2
                Office - RPi 3B+/HiFiBerry DAC HAT/RPi screen - Edifier D12
                Bedroom - Echo Show 8

                Spares - 1xSB Touch, 1xSB3, 4xRPi, AVI DM5 speakers

                Comment


                • I'd also look at the proxy streaming setting too.
                  sorry, I don't remember which tab it sits on though
                  rPi 3b + rasPi 7" LCD + HiFiBerry DiGi+ | rPi 3b + IQaudio DAC+ | rPi 3 + HiFiBerry DAC+ | Squeeze Box Touch | LMS on Synology Docker
                  https://www.picoreplayer.org/how_to_upgrade_lms.shtml
                  Your usb device is taking too long to become ready at boot. You need to add some delay. On the extras menu, there is a bootcodes screen. Increase the value of waitusb
                  https://forums.slimdevices.com/showt...-x-x-Bluetooth

                  Comment


                  • Originally posted by kidstypike
                    LMS settings > Player Tab > Synchronise.

                    Click image for larger version  Name:	sync.jpg Views:	27 Size:	45.1 KB ID:	1638650
                    Is this on the pCP or on LMS, can find these settings. It looks to be LMS, I'm running with material skin, could it be that these settings are not visible with that?
                    I'm not running LMS on one of the RPi but on a separate windows server.

                    The proxied streaming, I found in LMS. It is set to direct bit also states that when you synchronize 2 or more players it automatically reverts to Proxied.
                    Last edited by Izocad; 2023-05-12, 07:19.

                    Comment


                    • Originally posted by Izocad

                      Is this on the pCP or on LMS, can find these settings. It looks to be LMS, I'm running with material skin, could it be that these settings are not visible with that?
                      I'm not running LMS on one of the RPi but on a separate windows server.

                      The proxied streaming, I found in LMS. It is set to direct bit also states that when you synchronize 2 or more players it automatically reverts to Proxied.
                      In Material, 3 dots top right > Player > scroll down to "Extra Settings" > Synchronise.

                      Click image for larger version

Name:	sync material.jpg
Views:	361
Size:	34.4 KB
ID:	1638666
                      Server - LMS 8.4.0 RPi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)

                      Lounge - DAC32 - AudioEngine B2
                      Office - RPi 3B+/HiFiBerry DAC HAT/RPi screen - Edifier D12
                      Bedroom - Echo Show 8

                      Spares - 1xSB Touch, 1xSB3, 4xRPi, AVI DM5 speakers

                      Comment


                      • Originally posted by kidstypike

                        In Material, 3 dots top right > Player > scroll down to "Extra Settings" > Synchronise.

                        Click image for larger version  Name:	sync material.jpg Views:	8 Size:	34.4 KB ID:	1638666
                        Thanks!
                        I found it, a bit dumb of me. I had powered of the second RPi and the menu is only visible if you have 2 or more players

                        Other question :P
                        Have installed Jivelite on the RPi 3 A+ that s connected to HDMI to the Yamaha receiver and it works, but I cannot select any of the 1920x1080 skins? When I do pCP starts back to the console and loads Jivelite again with the previous skin.
                        Any idea what that could be?

                        PS: Thank you all for the support so far, feels like a welcoming community.
                        Last edited by Izocad; 2023-05-12, 08:24.

                        Comment


                        • Hi

                          I'm trying to get a USB DAC to work as a player via Bluetooth from my tablet, but no matter which BT output device I choose e.g. hw:CARD=B10,DEV=0 (the same as in Squeezelite), there seems to be no audio. It works fine as a normal LMS player.
                          The built-in Hifiberry DAC works fine with BT when I configure that as the output device.

                          Any ideas on what to do?

                          Code:
                          05-13 12:32 BST INFO ---- Caught Connect signal ----
                          05-13 12:32 BST DEBUG /org/bluealsa/hci0/dev_C0_3D_03_2E_FE_58/a2dpsnk/source
                          05-13 12:32 BST DEBUG HCI:hci0
                          05-13 12:32 BST INFO MAC:C0:3D:03:2E:FE:58
                          05-13 12:32 BST INFO TRANSPORT:a2dpsnk
                          05-13 12:32 BST INFO Using bluealsa-aplay for device: C0:3D:03:2E:FE:58
                          05-13 12:32 BST DEBUG LMS server IP:""
                          05-13 12:32 BST DEBUG pCP Card Conf:"USB.conf"
                          05-13 12:32 BST DEBUG pCP BT_OUT_DEVICE="hw:CARD=B10,DEV=0"
                          05-13 12:32 BST DEBUG pCP BT_ALSAVOLUME=""
                          05-13 12:32 BST INFO Starting player:"kitchentabs5" bluetooth, alsa device:"hw:CARD=B10,DEV=0", volume:"".
                          05-13 12:32 BST DEBUG PCM Devices found dbus.Dictionary({dbus.ObjectPath('/org/bluealsa/hci0/dev_C0_3D_03_2E_FE_58/a2dpsnk/source'): dbus.Dictionary({dbus.String('Device'): dbus.ObjectPath('/org/bluez/hci0/dev_C0_3D_03_2E_FE_58', variant_level=1), dbus.String('Sequence'): dbus.UInt32(0, variant_level=1), dbus.String('Transport'): dbus.String('A2DP-sink', variant_level=1), dbus.String('Mode'): dbus.String('source', variant_level=1), dbus.String('Format'): dbus.UInt16(33296, variant_level=1), dbus.String('Channels'): dbus.Byte(2, variant_level=1), dbus.String('Sampling'): dbus.UInt32(44100, variant_level=1), dbus.String('Codec'): dbus.String('SBC', variant_level=1), dbus.String('Delay'): dbus.UInt16(150, variant_level=1), dbus.String('SoftVolume'): dbus.Boolean(False, variant_level=1), dbus.String('Volume'): dbus.UInt16(32639, variant_level=1)}, signature=dbus.Signature('sv'))}, signature=dbus.Signature('oa{sv}'))
                          05-13 12:32 BST INFO Device: dev_C0_3D_03_2E_FE_58, connected with a2dp
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: sep1
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: sep1
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: sep2
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: a2dpsnk
                          05-13 13:46 BST INFO Stopping playback from kitchentabs5
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: sep3
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: sep4
                          05-13 13:46 BST INFO ---- Caught Disconnect signal ----
                          05-13 13:46 BST DEBUG HCI: hci0
                          05-13 13:46 BST INFO MAC: C0:3D:03:2E:FE:58
                          05-13 13:46 BST INFO TRANSPORT: sep5
                          Last edited by mr-b; 2023-05-13, 14:41.

                          Comment


                          • Nothing is standing out. Does the USB card work from squeezelite?
                            piCorePlayer a small player for the Raspberry Pi in RAM.
                            Homepage: https://www.picoreplayer.org

                            Please donate if you like the piCorePlayer

                            Comment


                            • Tx Paul. Yes the (Benchmark) USB DAC that I'm testing plays fine from Squeezelite using the same device name. The only thing that is different is that the output audio vol is very low and I have to turn the vol up to max for a decent output. The ALSA mixer says "your card does not have any mixer controls".

                              I tried another USB DAC (Topping) and that works fine from BT. The device name is slightly different (CARD=Balanced). The vol is *much* louder than the Benchmark, and the ALSA mixer adjustment is present and picks up the DAC model and presents a vol level slider, which defaults to 0dB, which I ghuess explains why it is so loud. If I change the slider and Save, it reverts to 0dB. This may be a red herring but are just my observations comparing different USB DACs.
                              With the Hifiberry DAC there is a huge number of ALSA options. The only other thing that might be relevant is that I've recently had to swap my RPi4 for a RPi3. I'm using wifi and I recall there was something about wifi and USB sharing a bus on RPi3s and so there might be occasional drop-outs.

                              Comment


                              • Running into an issue on the RPi with the Hifiberry Amp2, previously I ran Volumio and did not experience this.
                                When listening to music I hear some crackling, popping sound every now and then.
                                Any idea what that could be?
                                Is there any log or diagnostics I can post?

                                Code:
                                WIFI="off"
                                DEBUG="0"
                                MODE="10"
                                TEST="0"
                                NAME="Overkapping"
                                PCP_CUR_REPO="1"
                                THEME="Light"
                                OUTPUT="hw:CARD=sndrpihifiberry"
                                ALSA_PARAMS="80:4::1"
                                BUFFER_SIZE=""
                                _CODEC=""
                                XCODEC=""
                                PRIORITY=""
                                MAX_RATE=""
                                UPSAMPLE=""
                                MAC_ADDRESS=""
                                SERVER_IP=""
                                LOGLEVEL=""
                                LOGFILE=""
                                DSDOUT=""
                                VISUALISER=""
                                CLOSEOUT=""
                                UNMUTE=""
                                ALSAVOLUME=""
                                OTHER=""
                                AUDIO="hifi_dac+"
                                AUDIOBOOTSCRIPT=""
                                HOST="overkapping"
                                TIMEZONE="CET-1CEST,M3.5.0,M10.5.0/3"
                                CPUGOVERNOR="ondemand"
                                OVERCLOCK="NONE"
                                ADVOVERCLOCK="None"
                                CPUISOL=""
                                SQLAFFINITY=""
                                SQLOUTAFFINITY=""
                                CMD="Default"
                                FIQ="0xF"
                                ALSAlevelout="Custom"
                                ALSAeq="no"
                                EQUAL_OUT_DEVICE=""
                                STREAMER="no"
                                STREAMER_IN_DEVICE=""
                                REBOOT="Disabled"
                                RB_H="0"
                                RB_WD="*"
                                RB_DMONTH="*"
                                RESTART="Disabled"
                                RS_H="0"
                                RS_WD="*"
                                RS_DMONTH="*"
                                CRON_COMMAND=""
                                AUTOSTARTLMS=""
                                A_S_LMS="Disabled"
                                AUTOSTARTFAV=""
                                A_S_FAV="Disabled"
                                USER_COMMAND_1=""
                                USER_COMMAND_2=""
                                USER_COMMAND_3=""
                                JIVELITE="no"
                                SCREENROTATE="180"
                                JL_SCREEN_WIDTH="0"
                                JL_SCREEN_HEIGHT="0"
                                JL_FRAME_BUFFER="/dev/fb0"
                                JL_FRAME_RATE=""
                                JL_FRAME_DEPTH=""
                                SHAIRPORT="no"
                                LMSERVER="no"
                                LMSDATA="default"
                                LMSBRANCH="release"
                                NTPD="no"
                                SQLT_VERSION="basic"
                                SQBINARY="default"
                                SQUEEZELITE="yes"
                                POWER_GPIO=""
                                POWER_OUTPUT="L"
                                POWER_SCRIPT=""
                                GPIOPOWEROFF="no"
                                GPIOPOWEROFF_GPIO="17"
                                GPIOPOWEROFF_HI="yes"
                                GPIOSHUTDOWN="no"
                                GPIOSHUTDOWN_GPIO="22"
                                GPIOSHUTDOWN_HI="yes"
                                GPIOSHUTDOWN_PU="down"
                                IR_LIRC="no"
                                IR_KEYTABLES="no"
                                IR_GPIO_IN="25"
                                IR_GPIO_OUT=""
                                IR_DEVICE="lirc0"
                                IR_CONFIG=""
                                LMSWEBPORT=""
                                FSM="Default"
                                LMSCONTROLS="yes"
                                PLAYERTABS="yes"
                                HDMIPOWER="on"
                                APMODE="no"
                                AP_IP=""
                                RPI3INTWIFI="on"
                                RPIBLUETOOTH="off"
                                BT_OUT_DEVICE=""
                                BT_ALSAVOLUME=""
                                BTCODECS=""
                                BTDISCOVERTIME="180"
                                SAMBA="disabled"
                                WOL="no"
                                WOL_NIC=""
                                WOL_LMSMACADDRESS=""
                                SPARAMS1=""
                                SPARAMS2=""
                                SPARAMS3=""
                                SPARAMS4=""
                                SPARAMS5=""
                                INTERNET_CHECK_IP=""
                                ROTDASH="no"
                                SHAIRPORT_OUT="hw:CARD=sndrpihifiberry"
                                SHAIRPORT_CONTROL=""
                                NETWORK_WAIT="50"
                                GUI_DISABLE="0"
                                WWW_PORT="80"
                                MDNSD="yes"
                                SDIMAGELOCATION=""
                                This was with spotty running on LMS on a server
                                Last edited by Izocad; 2023-05-13, 20:03.

                                Comment

                                Working...
                                X
                                😀
                                🥰
                                🤢
                                😎
                                😡
                                👍
                                👎