Announcement

Collapse
No announcement yet.

Announce: piCorePlayer 3.00

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Originally posted by Paul Webster
    You could check to see if they are discovered as a USB device during the boot phase.
    For example - from SSH session
    dmesg | grep -i usb

    or from the web UI in Beta mode - go to the Diagnostics page and look for dmesg and the scroll through that (or Copy/Paste into a text editor and search it for "usb" without quotes)
    The ssh reports that it's there. But I'm not sure what to do next. Which if any of the Audio output device settings should I select? Details pasted below. Should mention that the Pi2 also has a memory stick and usb bluetooth attached.

    [ 0.000000] Kernel command line: bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000 tz=GMT0BST,M3.5.0/1,M10.5.0 dwc_otg.fiq_fsm_mask=0xF host=piCorePlayer dwc_otg.lpm_enable=0 console=tty1 root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed smsc95xx.turbo_mode=N noswap consoleblank=0 waitusb=2
    [ 0.055644] usbcore: registered new interface driver usbfs
    [ 0.055693] usbcore: registered new interface driver hub
    [ 0.055803] usbcore: registered new device driver usb
    [ 0.492800] usbcore: registered new interface driver lan78xx
    [ 0.492860] usbcore: registered new interface driver smsc95xx
    [ 0.520772] dwc_otg 3f980000.usb: base=0xf0980000
    [ 0.921924] dwc_otg 3f980000.usb: DWC OTG Controller
    [ 0.921957] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
    [ 0.921991] dwc_otg 3f980000.usb: irq 62, io mem 0x00000000
    [ 0.922253] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    [ 0.922262] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [ 0.922269] usb usb1: Product: DWC OTG Controller
    [ 0.922275] usb usb1: Manufacturer: Linux 4.14.81-pcpCore_v7 dwc_otg_hcd
    [ 0.922281] usb usb1: SerialNumber: 3f980000.usb
    [ 0.922897] hub 1-0:1.0: USB hub found
    [ 0.923715] usbcore: registered new interface driver usb-storage
    [ 0.927053] usbcore: registered new interface driver usbhid
    [ 0.927057] usbhid: USB HID core driver
    [ 1.371750] usb 1-1: new high-speed USB device number 2 using dwc_otg
    [ 1.612126] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
    [ 1.612142] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [ 1.612868] hub 1-1:1.0: USB hub found
    [ 1.931790] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
    [ 2.061926] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
    [ 2.061941] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [ 2.154846] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:24:8c:30
    [ 2.251678] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
    [ 2.382185] usb 1-1.4: New USB device found, idVendor=0781, idProduct=5571
    [ 2.382195] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 2.382202] usb 1-1.4: Product: Cruzer Fit
    [ 2.382208] usb 1-1.4: Manufacturer: SanDisk
    [ 2.382215] usb 1-1.4: SerialNumber: 4C530101230213104272
    [ 2.382901] usb-storage 1-1.4:1.0: USB Mass Storage device detected
    [ 2.384327] scsi host0: usb-storage 1-1.4:1.0
    [ 2.481680] usb 1-1.5: new full-speed USB device number 5 using dwc_otg
    [ 2.629184] usb 1-1.5: New USB device found, idVendor=0a5c, idProduct=21e8
    [ 2.629194] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 2.629201] usb 1-1.5: Product: BCM20702A0
    [ 2.629207] usb 1-1.5: Manufacturer: Broadcom Corp
    [ 2.629213] usb 1-1.5: SerialNumber: 000272CC9CD2
    [ 2.931678] usb 1-1.2: new full-speed USB device number 6 using dwc_otg
    [ 3.072936] usb 1-1.2: New USB device found, idVendor=210a, idProduct=a410
    [ 3.072946] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 3.072953] usb 1-1.2: Product: PAAD cubik
    [ 3.072959] usb 1-1.2: Manufacturer: PAAD cubik
    [ 3.078794] input: PAAD cubik PAAD cubik as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.2/0003:210A:A410.0001/input/input0
    [ 3.141922] hid-generic 0003:210A:A410.0001: input,hidraw0: USB HID v1.00 Device [PAAD cubik PAAD cubik ] on usb-3f980000.usb-1.2/input2
    [ 14.587801] usbcore: registered new interface driver snd-usb-audio
    [ 14.589679] usbcore: registered new interface driver btusb

    Comment


    • Now go to the pCP web interface and choose Squeezelite - and then from the "Audio settings" section at the top choose "USB Audio" and hit save.
      It should then ask to reboot ... to which you should say yes.

      Then, when it comes back, go to the same place and pick one of the listed USB audio devices.
      If the first does not work ... try one of the others ... and repeat until working.

      Also - I see that your USB speakers registered a "HID" device (human interface) ... so there is a good chance that the remote control that came with it will work.


      Also we are in the pCP 3.00 thread here ... but hopefully you are running pCP 4.something
      Paul Webster
      Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
      and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

      Comment


      • Based on the kernel, he is using 4.1.0
        piCorePlayer a small player for the Raspberry Pi in RAM.
        Homepage: https://www.picoreplayer.org

        Please donate if you like the piCorePlayer

        Comment


        • Originally posted by Paul Webster
          Now go to the pCP web interface and choose Squeezelite - and then from the "Audio settings" section at the top choose "USB Audio" and hit save.
          It should then ask to reboot ... to which you should say yes.

          Then, when it comes back, go to the same place and pick one of the listed USB audio devices.
          If the first does not work ... try one of the others ... and repeat until working.

          Also - I see that your USB speakers registered a "HID" device (human interface) ... so there is a good chance that the remote control that came with it will work.


          Also we are in the pCP 3.00 thread here ... but hopefully you are running pCP 4.something
          I'm on 4.1.0. I didn't see the 3.00 thread title. Sorry about that.

          Anyway, after adding hw:CARD=cubik to the output setting box the speakers are now working. Though the output is a bit low. If I whack the LMS output up to 100% it's still barely audible. And with lots of hiss. Used with the PC & Volumio they are loud enough to fill my home office. Is there something else I need to tweak?

          Sorry if this is getting a bit long-winded and boring. Really appreciate your time and the step-by-step help.

          Comment


          • USB devices often have many possible output settings.

            Expand the more> by the output setting, you should see all of the possible choices. You also may need to set the Alsa volume to max
            piCorePlayer a small player for the Raspberry Pi in RAM.
            Homepage: https://www.picoreplayer.org

            Please donate if you like the piCorePlayer

            Comment


            • Originally posted by pettifoggery
              I'm on 4.1.0. I didn't see the 3.00 thread title. Sorry about that.

              Anyway, after adding hw:CARD=cubik to the output setting box the speakers are now working. Though the output is a bit low. If I whack the LMS output up to 100% it's still barely audible. And with lots of hiss. Used with the PC & Volumio they are loud enough to fill my home office. Is there something else I need to tweak?

              Sorry if this is getting a bit long-winded and boring. Really appreciate your time and the step-by-step help.
              Try using SSH




              to access alsamixer?

              Click image for larger version

Name:	alsamixer.jpg
Views:	1
Size:	144.1 KB
ID:	1566511

              Comment


              • Originally posted by Man in a van
                Solved! Pumping up the alsamixer made the difference. Thanks to everyone for the help.

                Comment


                • What have I broken?

                  I have a RPi 2 running PiCore Player 3.5.0 that is my travel music system. I attach a SSD, run squeezelite and LMS on it and plus on some headphones or a speaker and it worked fine. I set up wireless access point so I can control it from my phone.

                  It worked fine a year ago. Now, the AP fires up on boot, and is visible with an IP address of 10.10.10.1 and it allocates my phone 10.10.10.75, so that is working. BUT neither the LMS, or the PiCoreplayer interface pages appear on any IP address my phone can access. If I pull out my wifi dongle and reboot on a network cable, it grabs an IP address from my DHCP and all works fine.

                  I've obviously not set something up, or I've switched something off but nothing I can find. I've not set the IP address as fixed (which is what I thought I'd done) - so any ideas?

                  Comment


                  • Been a long time since I used a 3.5 system, but it should still work similar today. Sounds like it’s waiting for network.

                    Start as you would, then plug a network cable in. You should be able to connect that way and then look at the boot logs. Or connect a keyboard and monitor to see what is going on.

                    Make sure you did not setup other network mounts while you had it connected to a wire.
                    piCorePlayer a small player for the Raspberry Pi in RAM.
                    Homepage: https://www.picoreplayer.org

                    Please donate if you like the piCorePlayer

                    Comment

                    Working...
                    X
                    😀
                    🥰
                    🤢
                    😎
                    😡
                    👍
                    👎