Announcement

Collapse
No announcement yet.

SqueezePlay for Windows with ASIO, DirectSound, WASAPI and WDMKS device support.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by Musiclover View Post
    I don´t understand, why the squeezeslave-1.2-379.exe
    is opening a dos task windows, but I´m not able to write into this window.
    1st of all - dos is dead. You mean the command shell which is cmd.exe - not command.com.
    And if you start a shell or a shell Programm - you can see the initial shell (that calls the App) and if the app is working and had no menu or an sub where you can interact with the app you cant write into this shell.

    So maybe....

    Open a shell
    Drop with ur mouse the exe into that shell
    Push the spacekey and wrote the parameter
    -or make a lnk from the exe and give that lnk your prefered parameters.

    Originally posted by Musiclover View Post
    Nobody any idea what I have done wrong?
    i do love such lines ;-)

    Comment


      #32
      Originally posted by Musiclover View Post
      Dear Ralphy,

      I tried to bring run your nice squeezeplay version R0158 with high resolution wave formats.

      The soundoutput analog is set to 24bit 192kHz; testsound is O.K.
      System W7, 64bit

      --same for me

      I installed first LogitechMediaServer-7.8.0-1353679004.exe from today
      I installed your version Squeezeplay R0158.

      --same

      I can play 24bit 192Khz flac formats, but not Wave 24bit 96/192kHz.

      --same

      If I look to Environmental variables; I can´t find the

      "There are several User Environment Variables used to provide the ability to select the output device (USEPADEVICE), maximum sample rate (USEPAMAXSAMPLERATE), audio device driver (USEPAHOSTAPI) and driver latency (USEPALATENCY)."

      --you have to add these manually Control Panel\System and Security\System\Advance System Settings\Advanced\Environment variables

      As I understood I have to start the software squeezeslave:

      "To obtain the list of available output devices that can be used for the USEPADEVICE key you can download the latest squeezeslave for windows, extract the zip file and run squeezeslave with the -L option. If you do not set USEPADEVICE squeezeplay uses the default windows audio device."

      --open a dos window, cd to the directory that squeezeslave is in and then type or copy squeezeslave-1.2-379.exe -L

      I don´t understand, why the squeezeslave-1.2-379.exe
      is opening a dos task windows, but I´m not able to write into this window.

      It seems; I didn´t understood the correct prozedure to run Squeezeplay high resolution.
      Any idea what I made wrong?

      Thank you in advance
      Ralphy, any ideas why 96/192 Wavs are not playing ?
      Touch optimisations http://touchsgotrythm.blogspot.co.uk/

      Comment


        #33
        Originally posted by SBGK View Post
        Ralphy, any ideas why 96/192 Wavs are not playing ?
        Can you describe what part(s) of post #1 are not clear?

        To play sample rates higher than 48000 you MUST set the USEPAMAXSAMPLERATE environment variable as laid out in the first post. Otherwise anything above 48000 is down sampled to 48000 by LMS.

        I can confirm that 24bit 96000 and 192000 wav files play with the latest 7.8 LMS provided you haven't changed any of the file type settings in LMS.
        Ralphy

        1-Touch, 5-Classics, 3-Booms, 2-UE Radio
        Squeezebox client builds donations always appreciated.

        Comment


          #34
          Originally posted by ralphy View Post
          Can you describe what part(s) of post #1 are not clear?

          To play sample rates higher than 48000 you MUST set the USEPAMAXSAMPLERATE environment variable as laid out in the first post. Otherwise anything above 48000 is down sampled to 48000 by LMS.

          I can confirm that 24bit 96000 and 192000 wav files play with the latest 7.8 LMS provided you haven't changed any of the file type settings in LMS.
          Charming

          What part of my post made you think that I had not set the environment variables correctly ? Can you describe your thought processes in replying in such a brusque manner ?

          I have changed the file type settings for WAV to disabled except for PCM which is native, would these changes have caused it to no longer work ?
          Touch optimisations http://touchsgotrythm.blogspot.co.uk/

          Comment


            #35
            Thanks for the support. Squeezeplay R158 is now playing HDA Wave.

            But I found a small problem:

            while playing a track, the timer status bar is jumping to sero position and after short time back to the actual played time.
            I have installed LogitechMediaServer-7.8.0-1353679004 2013 01 08.exe and Squeezeplay R158.
            This time jump you can see at:
            Squeezeplay R158
            LMS 7.8 beta
            iPeng for iPad

            Is this a problem of the beta server?

            My other devices (hardware and old software player, Squeezeplay 7.7.2) havn´t this problem.

            Any idea?

            Comment


              #36
              I installed the newest 7.8 and it seem to be solved.



              But I have another problem:

              I installed squeezeplay on several PCs and two of them have the same MAC adress in LMS 7.8.
              PC 1 squeezeplay is using the same Mac adress like PC 2 which is causing collision during the use.

              My question to RALPHY: How are you reading out the MAC adress?

              Is this done once during the installation or read out with every start of squeezeplay?
              I tried several installations but it is not changing to the physical MAC adress of PC 1.

              How can I change the MAC in your squeezeplay to the correct (physical) adress of PC1?

              Thank you in advance

              Comment


                #37
                Originally posted by Musiclover View Post
                I installed the newest 7.8 and it seem to be solved.

                But I have another problem:

                I installed squeezeplay on several PCs and two of them have the same MAC adress in LMS 7.8.
                PC 1 squeezeplay is using the same Mac adress like PC 2 which is causing collision during the use.

                My question to RALPHY: How are you reading out the MAC adress?
                It's the same as the official build, which says this in the code;

                //take the first found mac address.
                //todo: can we be smarter about which is the correct address

                Originally posted by Musiclover View Post
                Is this done once during the installation or read out with every start of squeezeplay?
                I tried several installations but it is not changing to the physical MAC adress of PC 1.

                How can I change the MAC in your squeezeplay to the correct (physical) adress of PC1?
                The MAC should be read at every startup.

                Shut down Squeezeplay and try deleting the userpath folder, mine is located at.

                C:\Documents and Settings\Ralphy\Application Data\SqueezePlay\userpath

                and start squeezeplay again.
                Ralphy

                1-Touch, 5-Classics, 3-Booms, 2-UE Radio
                Squeezebox client builds donations always appreciated.

                Comment


                  #38
                  Dear Ralphy,

                  you got it!!!
                  Thank you very much for your quick help.

                  Now the MAC in LMS for your squeezplay version is the physical MAC of my PC 1 as exspected.

                  Comment


                    #39
                    Dear Ralphy,


                    if I compare V158 to V192 I cann´t find in V192 the radio folder.
                    Externally controlled by ipeng it is possible to start the radio, this is clear.
                    But not with squeezeplay V192 on my computer.
                    (I checked if someting is deactivated in the main menu but all is activated).

                    Is this a feature or a bug?

                    Comment


                      #40
                      Te7022 wasapi

                      Hi, I'm trying to set up a Windows 7 x64 PC as "squeezebox" playing up to 24-96 flac files to a TE7022 device using a WASAPI driver.

                      Firstly I tried Squeezeslave and managed to get this working with the correct driver using squeezeslave-wasapi.exe, however Hi Res files were downsampled and a search of the interweb revealed that this does not work.

                      I then tried Sqeezeplay and this does work. The only problem is that I only get options for DirectSound Drivers not WASAPI drivers.

                      Is there any way I can use WASAPI drivers as shown by squeezeslave-wasapi.exe -L
                      Attached Files

                      Comment


                        #41
                        That is an old version. Try using the squeezeslave.exe from the "latest squeezeslave link" in post #1.
                        Ralphy

                        1-Touch, 5-Classics, 3-Booms, 2-UE Radio
                        Squeezebox client builds donations always appreciated.

                        Comment


                          #42
                          Already tried that. When USEPAHOSTAPI is set to "Windows DirectSound" and USEPALATENCY is set t 239. squeezeplay works (but with no hi res sound). When set to "Windows WDM-KS" and 40 seems to work but no sound. When set to "Windows WASAPI" and 10 SqueezePlay fails to start - "jive has stopped working"
                          Attached Files
                          Last edited by tobyjug; 2013-04-01, 20:43.

                          Comment


                            #43
                            Did you set USEPAMAXSAMPLERATE as well?

                            The default is 48000.
                            Ralphy

                            1-Touch, 5-Classics, 3-Booms, 2-UE Radio
                            Squeezebox client builds donations always appreciated.

                            Comment


                              #44
                              I did. Set to 96000
                              Using Win 7 x64 in case that makes a difference.

                              Comment


                                #45
                                I've uploaded a new Windows squeezeplay r328 package.

                                See the first post in this thread for details.
                                Ralphy

                                1-Touch, 5-Classics, 3-Booms, 2-UE Radio
                                Squeezebox client builds donations always appreciated.

                                Comment

                                Working...
                                X