Announcement

Collapse
No announcement yet.

Accessing local radio station - help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Accessing local radio station - help

    Hello,
    My wife streams a local radio (Austin City Limits Radio 97.1) station on her laptop while she's working. Her MacBook speakers are OK, but I told her that I could get one of my old Duets out of the garage and set up a much better sounding solution for her. She shrugged her shoulders and said "OK, but the computer is good enough". I insisted and told her she would be much happier listening through the stereo in her home office. So, I attached the Duet to the amp and found the station in the Internet Radio listing. I thought; I'm a hero. But, when I try to connect to the station I get an error that says "No items in playlist". Now she's rolling her eyes. How can I get this station to play through the Duet?

    I'm running LMS 7.6.2 r33953 on an old Windows 7 machine. The Duet has firmware version 77. I'm hesitant to upgrade LMS since the last time I tried to do that (back in the 8.x days) it crashed every time I tried to rescan my music library, but if this error is an issue due to older software I'll give it a try.

    Thanks in advance.

    #2
    I'm running LMS 8.4 on a Raspberry Pi. A search turned up "Austin City Limits Radio - KGSR-HD2," and it played on a Squeezelite player. (I have some Squeezebox hardware but rarely use it these days.)

    I wish that meant I could guarantee that it would work for you, if you just upgrade LMS, but I don't think it's possible to be certain, until you try it. I think the version of LMS you're running is more than 11 years old, so it's not surprising that it's not working. Incidentally, the stream sounds pretty good. It says it's a 320 kbps AAC stream.


    edit: Oh no, it doesn't! It's a 32 kbps stream, and that's what it says.
    Last edited by RobbH; 2022-11-18, 23:14. Reason: correction
    Usually running latest beta LMS nightly on Raspberry Pi OS with virtual players (Squeezelite and Airplay bridge). Occasionally using SB Radio, Boom or Classic.

    Comment


      #3
      It is in the iHeartRadio app but geo-locked so will not play for me.
      Code:
      [22-11-18 07:38:30.2523] Slim::Utils::Scanner::Remote::__ANON__ (236) Error: Can't connect to remote server to retrieve playlist for, http://18433.live.streamtheworld.com/KGSRHD2AAC_SC: 403 Forbidden.
      [22-11-18 07:38:31.2481] Slim::Utils::Scanner::Remote::__ANON__ (236) Error: Can't connect to remote server to retrieve playlist for, http://18433.live.streamtheworld.com:3690/KGSRHD2AAC_SC: 403 Forbidden.
      [22-11-18 07:38:32.2287] Slim::Utils::Scanner::Remote::__ANON__ (236) Error: Can't connect to remote server to retrieve playlist for, http://25063.live.streamtheworld.com/KGSRHD2AAC_SC: 403 Forbidden.
      [22-11-18 07:38:33.2300] Slim::Utils::Scanner::Remote::__ANON__ (236) Error: Can't connect to remote server to retrieve playlist for, http://25063.live.streamtheworld.com:3690/KGSRHD2AAC_SC: 403 Forbidden.
      [22-11-18 07:38:34.2423] Slim::Utils::Scanner::Remote::__ANON__ (236) Error: Can't connect to remote server to retrieve playlist for, http://23093.live.streamtheworld.com/KGSRHD2AAC_SC: 403 Forbidden.
      [22-11-18 07:38:35.2400] Slim::Utils::Scanner::Remote::__ANON__ (236) Error: Can't connect to remote server to retrieve playlist for, http://23093.live.streamtheworld.com:3690/KGSRHD2AAC_SC: 403 Forbidden.
      Does it show artist/title/artwork when playing via LMS (for someone in USA)?
      If not ... I can add it to Radio Now Playing as I see it has a JSON data feed.
      Paul Webster
      Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
      and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

      Comment


        #4
        Im in the US. I searched under "radio" and found the station - it plays on a boom. I have a duet in another room, I'll try that next
        Click image for larger version

Name:	kgsr.png
Views:	1
Size:	44.8 KB
ID:	1576039

        Jim

        <edit> - it plays on my receiver/duet. It's a tune in station - here is the url (you can add directly to a favorite) - http://opml.radiotime.com/Tune.ashx?...66474477b08b65
        Last edited by Redrum; 2022-11-18, 13:31.

        Comment


          #5
          Originally posted by ParkD View Post
          I'm running LMS 7.6.2 r33953 on an old Windows 7 machine. The Duet has firmware version 77. I'm hesitant to upgrade LMS since the last time I tried to do that (back in the 8.x days) it crashed every time I tried to rescan my music library, but if this error is an issue due to older software I'll give it a try.
          The station is an AAC station so it will need LMS to transcode for SB Receiver.

          Not only is LMS old but so is Win 7.
          Although URL is not a http one - it may redirect to a https URL in which case LMS 8.2.* is needed. However, there is a possibility that Win 7 doesn't have up to date underlying libraries.

          LMS 7.6 has little support for HTTPS so error message arising from inadequate HTTPS will be very misleading.

          @Redrum
          Can you confirm that URL doesn't redirect to an https URL ?

          Comment


            #6
            Using LMS 8.3.0 Austin City Limits plays just fine on my Duet receiver.
            Main system - Rock Solid with LMS 8.3.1 on WHS 2011 - 2 Duets ( both WiFi, farthest unit gets 60% signal strength and always works since new power supply) and Squeeseslave
            Cabin system - Rock solid with LMS 8.3.1 on Win10 Pro - 1 RPi 3 Model B (WiFi) /Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
            Squeezebox Boom - "At Large" player around both home and cabin
            Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

            Comment


              #7
              Originally posted by bpa View Post
              .
              @Redrum
              Can you confirm that URL doesn't redirect to an https URL ?
              I'd be happy to check, but I don't know how to check for redirection . I know, it's going to be simple....

              In the mean time, I'll try to find it via mysb.com

              <edit> I used a radio to search, find, and play the station via mysb.com. I'll save it to a mysb.com fav then connect a receiver to mysb.com and see if it plays.....
              <edit #2> Have not moved to the receiver but on the radio '+' then more info yields AAC, 32kbps CBR, and the url is http, not s.

              Jim
              Last edited by Redrum; 2022-11-18, 18:56.

              Comment


                #8
                I have the station playing via LMS, on a receiver, and when I select more->more info, this is what's displayed (in material):

                Click image for larger version

Name:	receiver.png
Views:	1
Size:	24.1 KB
ID:	1576041

                I can try it via mysb.com on the receiver if needed.

                Jim

                Comment


                  #9
                  Fixed

                  Originally posted by ParkD View Post
                  Hello,
                  My wife streams a local radio (Austin City Limits Radio 97.1) station on her laptop while she's working. Her MacBook speakers are OK, but I told her that I could get one of my old Duets out of the garage and set up a much better sounding solution for her. She shrugged her shoulders and said "OK, but the computer is good enough". I insisted and told her she would be much happier listening through the stereo in her home office. So, I attached the Duet to the amp and found the station in the Internet Radio listing. I thought; I'm a hero. But, when I try to connect to the station I get an error that says "No items in playlist". Now she's rolling her eyes. How can I get this station to play through the Duet?

                  I'm running LMS 7.6.2 r33953 on an old Windows 7 machine. The Duet has firmware version 77. I'm hesitant to upgrade LMS since the last time I tried to do that (back in the 8.x days) it crashed every time I tried to rescan my music library, but if this error is an issue due to older software I'll give it a try.

                  Thanks in advance.

                  I upgraded my LMS to the latest version (8.3.0) and am now able to stream Austin City Limits Radio. Thanks for all the suggestions.

                  Comment


                    #10
                    Originally posted by Redrum View Post
                    .

                    I can try it via mysb.com on the receiver if needed.

                    Jim
                    ok, I played it via mysb.com, on a receiver/controller, and it did indeed error (see pic), and it does look like it redirects, but, it played anyway...

                    Click image for larger version

Name:	austin.jpg
Views:	1
Size:	32.9 KB
ID:	1576042

                    let me know if there is any more testing anyone would like for me to do. In the mean time, looks like I can dust the controller

                    Jim

                    Comment


                      #11
                      Originally posted by ParkD View Post
                      I upgraded my LMS to the latest version (8.3.0) and am now able to stream Austin City Limits Radio. Thanks for all the suggestions.
                      great! so your wife is no longer rolling her eyes and she thinks you are a hero?

                      Jim

                      Comment


                        #12
                        Originally posted by Redrum View Post
                        I have the station playing via LMS, on a receiver, and when I select more->more info, this is what's displayed (in material):

                        [ATTACH]39154[/ATTACH]

                        I can try it via mysb.com on the receiver if needed.

                        Jim
                        Jim, your image showed that I needed my glasses when I reported earlier that this was a 320 kbps stream. 32 kbps is correct.
                        Usually running latest beta LMS nightly on Raspberry Pi OS with virtual players (Squeezelite and Airplay bridge). Occasionally using SB Radio, Boom or Classic.

                        Comment


                          #13
                          Originally posted by RobbH View Post
                          Jim, your image showed that I needed my glasses when I reported earlier that this was a 320 kbps stream. 32 kbps is correct.
                          or maybe the '0' is implied

                          Comment


                            #14
                            Originally posted by Redrum View Post
                            or maybe the '0' is implied
                            I don't think anyone intended to imply that. I simply INFERRED it. Not for the first time. Probably not the last.
                            Usually running latest beta LMS nightly on Raspberry Pi OS with virtual players (Squeezelite and Airplay bridge). Occasionally using SB Radio, Boom or Classic.

                            Comment


                              #15
                              Originally posted by RobbH View Post
                              I don't think anyone intended to imply that. I simply INFERRED it. Not for the first time. Probably not the last.
                              poor attempt at a joke, I need to learn to stick to the subject. I think a bit of @Ronnie tends to rub off on me . I meant that the stream felt no need to add the 0, it's implied. Like I said, a real lame joke...

                              I looked at the fact that it's 32kbps and thought "yuk", but I really am not familiar with AAC's bitrates vs quality...Happy @ParkD got his station. @bpa was spot on with the LMS version and https. I had forgotten...

                              Jim

                              Comment

                              Working...
                              X