Announcement

Collapse
No announcement yet.

Inguz EQ/DRC

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • #16
    Odd. I'll do some tests later today.
    Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

    Comment


    • #17
      Well, I've confirmed your findings. On a test with pick noise the mono single channel was approx 8 or 9dB quieter.

      I would guess that it is a bug but that doesn't get us much further. Sorry I don't have a resolution.
      Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

      Comment


      • #18
        Originally posted by JohnB
        Well, I've confirmed your findings.
        Thanks for trying it yourself. I solved the problem the "brute force" way: converted all my one-channel FLAC to "dual-mono" 2-channel. The files are no larger so I guess FLAC must record this using a flag rather than storing two identical channels.

        Comment


        • #19
          Inguz stopped working - filetypes wont select

          Hi,

          Inguz stopped working for me about a week ago. I did a reinstall etc, rebooted LMS many times but with no success. I noted also that it had stopped writing to the log.

          Elsewhere on this forum I saw a recommendation to check that the filetypes were set up correctly. When I try that I see that Inguz is only mentioned in one place, The MP3 setting looks like this:

          MP3 FLAC Disabled
          MP3 Native

          It is possible to select Lame/InguzDSP from the FLAC entry but when I try and "Apply" that it jumps back to "Disabled".

          Looking at the LMS log file I see that whenever I try and do that I get the following error message:

          [19-11-23 23:19:08.0200] Slim::Utils::Misc::msg (1252) Warning: [23:19:08.0198] Use of uninitialized value in concatenation (.) or string at C:\PROGRA~2\SQUEEZ~1\server\HTML\EN\settings\serve r\filetypes.html line 38.

          This is where my debugging skills run out. Can anyone suggest what might be wrong and how I fix it?

          My setup:

          Logitech Media Server Version: 7.9.1 - 1522157629 @ Fri Mar 30 12:17:59 WEDT 2018
          Operating system: Windows 10 - EN - cp1252
          Platform Architecture: 8664
          Perl Version: 5.14.1 - MSWin32-x86-multi-thread
          Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)

          Many thanks

          Comment


          • #20
            A couple of things to look at first:

            You say that Inguz stopped working about a week ago. Were there any changes to your PC or LMS that you did around that time?

            Inguz needs lame to be installed for Inguz to work with mp3 files, so please check that lame is installed for LMS. In Windows 7 lame.exe should be in the folder "C:\Program Files (x86)\Squeezebox\server\Bin".
            Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

            Comment


            • #21
              Interesting finding: Since updating my PC from Win 7 to Win 10, I can now see and control Inguz settings in Internet Explorer (11.535.18362.0 x64).

              Comment


              • #22
                Just installed this. When I go to plugins>EQ>settings
                I get
                "Cannot initialize Silverlight: createSilverlightControl is not defined" This happens on all browsers, including Internet Explorer.

                I do have Silverlight installed on the LMS server. What's missing?

                Plus: How do I add my RC convolution filters? If I go to my Touch interface to Extras>EQ>DRC the only option that appears in "none". ????

                Thanks
                Last edited by firedog; 2020-01-28, 14:16.
                GIK Acoustics Room Treatments. Isol Line conditioner/protection. iFi AC iPurifiers>CAPS4 Pipeline w/Sonore PS >Kii Control>Kii Three speakers.iFi iOne+ Schiit Freya Pre for analog. An SB Touch, Duet Controller, a RB Pi 3B+ running piCorePlayer as an SBT emulator in additional rooms.

                Comment


                • #23
                  Originally posted by firedog
                  I do have Silverlight installed on the LMS server. What's missing?

                  Plus: How do I add my RC convolution filters? If I go to my Touch interface to Extras>EQ>DRC the only option that appears in "none". ????

                  Thanks
                  The Silverlight thing is very unpredictable. I don't depend on it, but instead access EQ via mobile app: Orange Squeeze or Squeeze Commander. You can designate your filter file in the app or on your Touch under "Extras > EQ > Settings > Room Correction". The file first needs to be on the server in the "C:\ProgramData\InguzEQ\Impulses" folder if Windows. May also need a server restart to see it.

                  Comment


                  • #24
                    firedog,

                    Apesbrain has already covered much of this but ....

                    The Inguz browser interface is only functional with Internet Explorer (partly because only Internet Explorer supports Silverlight).

                    Silverlight needs to be installed on the same PC as the browser.

                    If you already have FIR filter files, for Inguz these should be 32bit wave files and the files should be copied to folders:

                    Windows: C:\ProgramData\InguzEQ\Impulses\

                    Ubuntu: /usr/share/InguzEQ/Impulses/
                    - Mine are set to Owner squeezeboxserver:nogroup, Permissions: 777

                    If you want to set up equalization, this can be done either using the browser interface or via iPeng on an iPad or Orange Squeeze, Squeeze Commander.

                    Let us know how you get on.
                    Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

                    Comment


                    • #25
                      almost there

                      Thanks for your help. I made progress.
                      I have convolution/filter files I made in Audiolense. They supposedly are 32 bit float, and are wav files.
                      I loaded them into my Touch, but can't get playback.
                      Here's the log output showing the error, I'd appreciate it if one of you can tell me what this means and how to fix it.

                      20200128134530: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                      20200128134530: b8:27:eb:3a:b6:bf Gain -16 dB
                      20200128134531: b8:27:eb:3a:b6:bf Impulse (null), matrix (null)
                      20200128134531: b8:27:eb:3a:b6:bf EQ flat
                      20200128134531: b8:27:eb:3a:b6:bf 16/44100 PCM => 24/44100 PCM TRIANGULAR, gain -16 dB
                      20200128134531: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                      20200128134531: b8:27:eb:3a:b6:bf 578211 samples, 468.7338 ms (78.1112 init), 27.7343 * realtime, peak -10.1932 dBfs
                      20200128134531: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                      20200128134531: b8:27:eb:3a:b6:bf Gain -16 dB
                      20200128134532: b8:27:eb:3a:b6:bf Impulse (null), matrix (null)
                      20200128134532: b8:27:eb:3a:b6:bf EQ flat
                      20200128134532: b8:27:eb:3a:b6:bf 16/44100 PCM => 24/44100 PCM TRIANGULAR, gain -16 dB
                      20200128134551: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                      20200128134551: b8:27:eb:3a:b6:bf 2718371 samples, 19409.1153 ms (78.1237 init), 3.1429 * realtime, peak -26.0895 dBfs
                      20200128134551: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                      20200128134551: b8:27:eb:3a:b6:bf Gain -16 dB
                      20200128134551: b8:27:eb:3a:b6:bf Impulse (null), matrix (null)
                      20200128134551: b8:27:eb:3a:b6:bf EQ flat
                      20200128134552: b8:27:eb:3a:b6:bf 16/44100 PCM => 24/44100 PCM TRIANGULAR, gain -16 dB
                      20200128134639: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                      20200128134639: b8:27:eb:3a:b6:bf 3664547 samples, 47862.4218 ms (78.1093 init), 1.7341 * realtime, peak -7.2698 dBfs
                      20200128134640: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                      20200128134640: b8:27:eb:3a:b6:bf Gain -16 dB
                      20200128134640: b8:27:eb:3a:b6:bf Impulse (null), matrix (null)
                      20200128134640: b8:27:eb:3a:b6:bf EQ flat
                      20200128134640: b8:27:eb:3a:b6:bf 16/44100 PCM => 24/44100 PCM TRIANGULAR, gain -16 dB
                      20200128155835: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                      20200128155835: b8:27:eb:3a:b6:bf 3764899 samples, 7915069.2555 ms (62.4987 init), 0.0107 * realtime, peak -11.3439 dBfs
                      20200128165944: InguzDSP (version 0.9.32)
                      20200128165944: -id must be specified.

                      Okay, above I wasn't getting playback but now I am. But I still don't think the RC is working properly. Question: I have 6 correction filters, one for each common sample rate: 44.1, 48, 88.2, 96, 176.4 and 192. In the "EXTRA" settings of the Touch, it seems only to allow me to use one filter. Does, Ignuz not know how to interpolate the filters for each sample rate? How do I do correction for playback files with different sample rates if I can only choose one of the filters?

                      Here's the log:
                      20200128191453: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                      20200128191454: b8:27:eb:3a:b6:bf Gain -16 dB
                      20200128191454: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 27012096.wav, matrix (null)
                      20200128191454: b8:27:eb:3a:b6:bf EQ flat
                      20200128191454: b8:27:eb:3a:b6:bf 24/96000 PCM => 24/96000 PCM TRIANGULAR, gain -16 dB
                      20200128191522: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                      20200128191522: b8:27:eb:3a:b6:bf 1987235 samples, 28734.6157 ms (203.1101 init), 0.696 * realtime, peak -4.3525 dBfs
                      20200128191523: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                      20200128191523: b8:27:eb:3a:b6:bf Gain -16 dB
                      20200128191523: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 27012096.wav, matrix (null)
                      20200128191523: b8:27:eb:3a:b6:bf Can't use Impulses\T-flat F-Default M-hogtalare 27012096.wav: its sample rate is 96000 not 44100
                      20200128191523: b8:27:eb:3a:b6:bf Can't use Temp\44100_0038F87BF0_Impulses_T-flat F-Default M-hogtalare 27012096.wav: not found
                      20200128191523: b8:27:eb:3a:b6:bf Trying sox "C:\ProgramData\InguzEQ\Temp\RE00B9A7FE0A.wav" "C:\ProgramData\InguzEQ\Temp\44100_0038F87BF0_Impu lses_T-flat F-Default M-hogtalare 27012096.wav" rate -v -I 44100
                      20200128191523: b8:27:eb:3a:b6:bf That didn't seem to work: The system cannot find the file specified
                      20200128191523: b8:27:eb:3a:b6:bf No suitable impulse found (C:\ProgramData\InguzEQ\Temp\RE00B9A7FE0A.wav).
                      20200128191523: b8:27:eb:3a:b6:bf EQ flat
                      20200128191523: b8:27:eb:3a:b6:bf 16/44100 PCM => 24/44100 PCM TRIANGULAR, gain -16 dB
                      20200128191924: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 270120441.wav, matrix (null)
                      20200128191924: b8:27:eb:3a:b6:bf EQ flat
                      20200128191929: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 27012048.wav, matrix (null)
                      20200128191929: b8:27:eb:3a:b6:bf Can't use Impulses\T-flat F-Default M-hogtalare 27012048.wav: its sample rate is 48000 not 44100
                      20200128191929: b8:27:eb:3a:b6:bf Can't use Temp\44100_0026B57238_Impulses_T-flat F-Default M-hogtalare 27012048.wav: not found
                      20200128191929: b8:27:eb:3a:b6:bf Trying sox "C:\ProgramData\InguzEQ\Temp\RE001BC9D93B.wav" "C:\ProgramData\InguzEQ\Temp\44100_0026B57238_Impu lses_T-flat F-Default M-hogtalare 27012048.wav" rate -v -I 44100
                      20200128191929: b8:27:eb:3a:b6:bf That didn't seem to work: The system cannot find the file specified
                      20200128191929: b8:27:eb:3a:b6:bf No suitable impulse found (C:\ProgramData\InguzEQ\Temp\RE001BC9D93B.wav).
                      20200128191929: b8:27:eb:3a:b6:bf EQ flat
                      20200128191931: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 270120882.wav, matrix (null)
                      20200128191931: b8:27:eb:3a:b6:bf Can't use Impulses\T-flat F-Default M-hogtalare 270120882.wav: its sample rate is 88200 not 44100
                      20200128191931: b8:27:eb:3a:b6:bf Can't use Temp\44100_0027E85427_Impulses_T-flat F-Default M-hogtalare 270120882.wav: not found
                      20200128191931: b8:27:eb:3a:b6:bf Trying sox "C:\ProgramData\InguzEQ\Temp\RE0030329889.wav" "C:\ProgramData\InguzEQ\Temp\44100_0027E85427_Impu lses_T-flat F-Default M-hogtalare 270120882.wav" rate -v -I 44100
                      20200128191931: b8:27:eb:3a:b6:bf That didn't seem to work: The system cannot find the file specified
                      20200128191931: b8:27:eb:3a:b6:bf No suitable impulse found (C:\ProgramData\InguzEQ\Temp\RE0030329889.wav).
                      20200128191931: b8:27:eb:3a:b6:bf EQ flat
                      20200128191934: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 27012096.wav, matrix (null)
                      20200128191934: b8:27:eb:3a:b6:bf Can't use Impulses\T-flat F-Default M-hogtalare 27012096.wav: its sample rate is 96000 not 44100
                      20200128191934: b8:27:eb:3a:b6:bf Can't use Temp\44100_0038F87BF0_Impulses_T-flat F-Default M-hogtalare 27012096.wav: not found
                      20200128191934: b8:27:eb:3a:b6:bf Trying sox "C:\ProgramData\InguzEQ\Temp\RE00B9A7FE0A.wav" "C:\ProgramData\InguzEQ\Temp\44100_0038F87BF0_Impu lses_T-flat F-Default M-hogtalare 27012096.wav" rate -v -I 44100
                      20200128191934: b8:27:eb:3a:b6:bf That didn't seem to work: The system cannot find the file specified
                      20200128191934: b8:27:eb:3a:b6:bf No suitable impulse found (C:\ProgramData\InguzEQ\Temp\RE00B9A7FE0A.wav).
                      20200128191934: b8:27:eb:3a:b6:bf EQ flat
                      20200128192025: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                      20200128192025: b8:27:eb:3a:b6:bf 1575587 samples, 302830.7802 ms (124.9974 init), 0.1156 * realtime, peak -6.9691 dBfs

                      Thanks a lot.
                      Last edited by firedog; 2020-01-28, 17:24.
                      GIK Acoustics Room Treatments. Isol Line conditioner/protection. iFi AC iPurifiers>CAPS4 Pipeline w/Sonore PS >Kii Control>Kii Three speakers.iFi iOne+ Schiit Freya Pre for analog. An SB Touch, Duet Controller, a RB Pi 3B+ running piCorePlayer as an SBT emulator in additional rooms.

                      Comment


                      • #26
                        You say you have loaded the FIR files into your touch.

                        Are you running LMS on your Touch, rather than on a separate PC, etc? If so you will not be able use the Inguz plugin - the Touch just doesn't have the processing power.
                        Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

                        Comment


                        • #27
                          Originally posted by JohnB
                          You say you have loaded the FIR files into your touch.

                          Are you running LMS on your Touch, rather than on a separate PC, etc? If so you will not be able use the Inguz plugin - the Touch just doesn't have the processing power.
                          No. Sorry for not being clear. I've got a pretty powerful Windows server with LMS running on it. When I said I loaded the files onto the Touch, I meant I went into Extras>EQ>Room Correction and picked one of the correction filters that show up there - the ones loaded into C:\ProgramData\InguzEQ\Impulses on my server.

                          Thanks
                          GIK Acoustics Room Treatments. Isol Line conditioner/protection. iFi AC iPurifiers>CAPS4 Pipeline w/Sonore PS >Kii Control>Kii Three speakers.iFi iOne+ Schiit Freya Pre for analog. An SB Touch, Duet Controller, a RB Pi 3B+ running piCorePlayer as an SBT emulator in additional rooms.

                          Comment


                          • #28
                            Originally posted by firedog
                            Okay, above I wasn't getting playback but now I am. But I still don't think the RC is working properly. Question: I have 6 correction filters, one for each common sample rate: 44.1, 48, 88.2, 96, 176.4 and 192. In the "EXTRA" settings of the Touch, it seems only to allow me to use one filter. Does, Ignuz not know how to interpolate the filters for each sample rate? How do I do correction for playback files with different sample rates if I can only choose one of the filters?
                            You can only choose one filter to be active at any time.

                            If the FIR filter has the same sampling rate as the file being played it will be used.

                            If the filter has a different sampling rate then Inguz will attempt to resample the filter to the sampling rate of the file and save the resampled filter in the folder C:\ProgramData\InguzEQ\Temp\

                            If it can't resample the filter then Inguz can't process the music file, but it should still play.

                            Originally posted by firedog
                            Here's the log:
                            20200128191453: InguzDSP (version 0.9.32) -id b8:27:eb:3a:b6:bf -wav -wavo -d 24
                            20200128191454: b8:27:eb:3a:b6:bf Gain -16 dB
                            20200128191454: b8:27:eb:3a:b6:bf Impulse Impulses\T-flat F-Default M-hogtalare 27012096.wav, matrix (null)
                            20200128191454: b8:27:eb:3a:b6:bf EQ flat
                            20200128191454: b8:27:eb:3a:b6:bf 24/96000 PCM => 24/96000 PCM TRIANGULAR, gain -16 dB
                            20200128191522: b8:27:eb:3a:b6:bf Write fault 232: The pipe is being closed
                            20200128191522: b8:27:eb:3a:b6:bf 1987235 samples, 28734.6157 ms (203.1101 init), 0.696 * realtime, peak -4.3525 dBfs
                            That, the first bit of the "second" log, looks right

                            In the following section you are playing a 44.1kHz file, still using the 96kHz filter.
                            Inguz first checks whether it has previously created a resampled file, but there is no resampled file present.
                            So it attempts to resample the filter file using sox.

                            BUT for some strange reason it hasn't picked up on the sox path

                            20200128191523: b8:27:eb:3a:b6:bf Trying sox "C:\ProgramData\InguzEQ\Temp\RE00B9A7FE0A.wav" "C:\ProgramData\InguzEQ\Temp\44100_0038F87BF0_Impu lses_T-flat F-Default M-hogtalare 27012096.wav" rate -v -I 44100

                            Should be

                            20200128191523: b8:27:eb:3a:b6:bf Trying "C:\Program Files (x86)\Squeezebox\server\Bin\MSWin32-x86-multi-thread\sox.exe" "C:\ProgramData\InguzEQ\Temp\RE00B9A7FE0A.wav" "C:\ProgramData\InguzEQ\Temp\44100_0038F87BF0_Impu lses_T-flat F-Default M-hogtalare 27012096.wav" rate -v -I 44100

                            I'm not sure why that has happened but Inguz needs LMS to be restarted a few times for it to be fully operational.

                            So I suggest you:

                            Stop LMS
                            Delete the contents of C:\ProgramData\InguzEQ\Temp\
                            Restart the Touch
                            Restart LMS

                            Let me know what happens

                            (I'll come back to you on Internet Explorer - it might be that Silverlight isn't enabled in its settings.)
                            Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

                            Comment


                            • #29
                              firedog,

                              I've just looked at the code for InguzDSP. It looks as though, on your PC, it couldn't fine sox.exe in the location it was expecting to find it and so just used "sox".

                              In my W10 system sox.exe is in folder: "C:\Program Files (x86)\Squeezebox\server\Bin\MSWin32-x86-multi-thread"

                              Can you check whether sox.exe is there on your Windows machine.
                              Allo Digione Signature (+LiFePo Batteries), Touch, Metrum Jade, Bryston B4 SST2, PMC OB1i speakers, HP Proliant Microserver/Ubuntu, PC/Windows 10, iPad 4, iPeng.

                              Comment


                              • #30
                                Thanks again. My Sox.exe is in the same place as yours. So the question is, why is Inguz looking for it in the wrong place? And how do I "fix" that?
                                I also followed your other advice about deleting files and restsrting LMS and the Touch. Same results as you saw above. Whenever the samplerates of thr filter and the playback file don't match, Sox isn't found.
                                GIK Acoustics Room Treatments. Isol Line conditioner/protection. iFi AC iPurifiers>CAPS4 Pipeline w/Sonore PS >Kii Control>Kii Three speakers.iFi iOne+ Schiit Freya Pre for analog. An SB Touch, Duet Controller, a RB Pi 3B+ running piCorePlayer as an SBT emulator in additional rooms.

                                Comment

                                Working...
                                X
                                😀
                                🥰
                                🤢
                                😎
                                😡
                                👍
                                👎