Announcement

Collapse
No announcement yet.

Announce: YouTube Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Announce: YouTube Plugin

    I've just released a plugin to play the audio from YouTube videos through Squeezeboxs. Please try and let me know your feedback. It should work on 7.5 and 7.6 servers. It should be available in the 3rd Party Plugin list on your squeezebox server. It will prefer an up to date version of 7.5 or 7.6.

    WARNING: please note the plugin streams the entire YouTube video even though you are only listening to the audio. This means that it will consume significantly more internet bandwidth than other streaming plugins. If you have a usage limited internet connection, then be aware that using this plugin is the equivalent of streaming videos not audio.

    Features:
    - Browse YouTube top lists of most popular videos tagged with 'music'
    - Search all YouTube videos or videos tagged with 'music'
    - Playback of specific YouTube URL (of the form: http://www.youtube.com/watch?v=t4H_Zoh7G5A)
    - Playback will search for a video resolution which can be played, there is a setting on the web settings page to set if you prefer to select lower resolution videos to reduce bandwidth. By default it will try to play the higher quality audio streams.

    Please report bugs and feature requests here, please include the specific server version used as the plugin uses some tricks to support 7.5 as well as 7.6 server and these may be the cause of bugs.

    Thanks to Pipin for the suggestion..

    #2
    Thanks. It works nice. Congratulation btw!

    PS: Maybe future versions could play back video through the web interface.

    Edit: Also, sometimes you are able to find mixes (I am not into youtube lingo, so this might not be the correct term). Anyway, it would be nice to be able to playback a mix such as this one:
    Promote your music. Find your fans. Learn how to turn your passion into a career on YouTube.
    Last edited by Pank; 2011-05-16, 00:52.

    Comment


      #3
      Thanks for this plugin, great idea.

      Sometimes the audio plays back too quickly. Sample rate issues perhaps? Did you see this before?

      I'm running a Touch, SBS 7.5.4 on Windows Server 2008 Standard.

      Any suggestions appreciated.

      One video in particular will not play at the correct speed: http://www.youtube.com/watch?v=thVZJ9TlPGs
      Last edited by badboygolf16v; 2011-05-16, 22:12.

      Comment


        #4
        Thanks. Great plugin!

        Two suggestions:
        - Playlist support (like http://www.youtube.com/playlist?p=PL7EFC7963DB9280CA or like the already mentioned http://www.youtube.com/artist?a=GxdC...yOcqr9bYeC0EkQ)
        - Improved guessing of artist / trackname (eg. remove parts in brackets from the name)

        Comment


          #5
          i've installed plusing on nas qnap ts 119 and it doesn't work. it appears icon of the video but no sound....sigh
          Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

          Comment


            #6
            Originally posted by nervoteso View Post
            i've installed plusing on nas qnap ts 119 and it doesn't work. it appears icon of the video but no sound....sigh
            There's two possible reasons for this:
            1) the NAS does not have enough CPU power
            2) the NAS does not use the logitech patched version of faad for transcoding aac streams (if this is the case then non aac based internet radio will work?)

            Have you tried setting the bitrate setting to prefer lower bitrate streams? This should help on both fronts as the lower resoltion streams are lower bitrate (less work for the NAS) and also use mp3 audio so do not need transcoding on the server.

            Comment


              #7
              Originally posted by Triode View Post
              There's two possible reasons for this:
              1) the NAS does not have enough CPU power
              2) the NAS does not use the logitech patched version of faad for transcoding aac streams (if this is the case then non aac based internet radio will work?)

              Have you tried setting the bitrate setting to prefer lower bitrate streams? This should help on both fronts as the lower resoltion streams are lower bitrate (less work for the NAS) and also use mp3 audio so do not need transcoding on the server.
              yes i did, lower resolution but it doesn't work. the cpu is good, it's atom 1.6 ghz.
              laso this is my setting

              Formato file Decodificatore
              AAC AAC native
              FLAC faad/flac
              MP3 faad/lame
              PCM faad
              Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

              Comment


                #8
                QNap doesn't have an Atom, it's a Marvell-Chip with an Arm-Core (ARM 5, I believe). The problem with therese NAS chips usually is that they don't have a floating-point processor.
                ---
                learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
                Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
                at penguinlovesmusic.com
                New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

                Comment


                  #9
                  Great plugin! I especially found the 'On Youtube' option nice in the song details page on the web interface and the iPeng song options page. But why not make it possible to also play the listed youtube videos in the browser or in the iPhone/iTouch youtube app? I managed to play them in Firefox by getting to their youtube page with the aid of a little URL-processing add-on, since the shortened 'youtube://' links you give aren't understood out of the box by firefox.

                  Comment


                    #10
                    Announce: version 0.8

                    Version 0.8 now available from the plugin page. This version supports:
                    - should play to the end of each video rather than cutting off the last few seconds (note streams may not meet the duration as this seems inacurate in some cases)
                    - additional search by playlist or channel
                    - link from the web interface to play the youtube video (on track info screen)

                    Please post feedback in this thread.

                    Comment


                      #11
                      Do you have a way to add a "weblink => <URL>" tag to the root level of that URL item in a SqueezePlay menu?
                      iPEng has a feature that I originally included for Biography and AlbumReview which allows to play a url that way.
                      I believe if it's a "youtube://" URL it will even play directly in the YouTube App.
                      ---
                      learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
                      Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
                      at penguinlovesmusic.com
                      New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

                      Comment


                        #12
                        Hmm, something is amiss now for me with version 0.8, selecting 'On Youtube' doesn't do anything any more, I just get the 'busy' cursor on the Web interface and in iPeng and the screen doesn't refresh. Logging doesn't show anything, also when set to debugging.
                        EDIT: Forgot to say that I am running
                        Version: 7.6.0 - r32427
                        Betriebssystem: Linux - DE - iso-8859-1
                        Plattformarchitektur: x86_64-linux
                        Perl-Version: 5.12.3 - x86_64-linux-thread-multi
                        Datenbankversion: DBD::SQLite 1.32_02 (sqlite 3.7.5)
                        on Arch Linux.
                        Last edited by signor_rossi; 2011-05-19, 16:46.

                        Comment


                          #13
                          Originally posted by pippin View Post
                          Do you have a way to add a "weblink => <URL>" tag to the root level of that URL item in a SqueezePlay menu?
                          iPEng has a feature that I originally included for Biography and AlbumReview which allows to play a url that way.
                          I believe if it's a "youtube://" URL it will even play directly in the YouTube App.
                          youtube:// was wrong. Here's how YouTube links work on iPhone:

                          The YouTube URL scheme is used to launch the YouTube application or connect to the YouTube website to play the specified video. If your application links to YouTube content, you can use this scheme to play videos from your application.

                          Unlike some schemes, YouTube URLs do not start with a “youtube” scheme identifier. Instead, they are specified as regular http links but are targeted at the YouTube server. The following examples show the basic strings you would use in Safari and in an application to show a YouTube video. In each example, you would need to replace the VIDEO_IDENTIFIER value with the identifier of the video you wanted to display:

                          HTML links:
                          <a href="http://www.youtube.com/watch?v=VIDEO_IDENTIFIER">Play Video</a>
                          <a href="http://www.youtube.com/v/VIDEO_IDENTIFIER">Play Video</a>
                          Native application URL strings:
                          Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

                          Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.
                          ---
                          learn more about iPeng, the iPhone and iPad remote for the Squeezebox and
                          Logitech UE Smart Radio as well as iPeng Party, the free Party-App,
                          at penguinlovesmusic.com
                          New: iPeng 9, the Universal App for iPhone, iPad and Apple Watch

                          Comment


                            #14
                            Originally posted by signor_rossi View Post
                            Hmm, something is amiss now for me with version 0.8, selecting 'On Youtube' doesn't do anything any more, I just get the 'busy' cursor on the Web interface and in iPeng and the screen doesn't refresh. Logging doesn't show anything, also when set to debugging.
                            EDIT: Forgot to say that I am running
                            Version: 7.6.0 - r32427
                            Betriebssystem: Linux - DE - iso-8859-1
                            Plattformarchitektur: x86_64-linux
                            Perl-Version: 5.12.3 - x86_64-linux-thread-multi
                            Datenbankversion: DBD::SQLite 1.32_02 (sqlite 3.7.5)
                            on Arch Linux.
                            Was this from an artist or track menu - it should work from the track menu, but is a known (by me!) bug for the artist menu. The reason for artist context menus is somewhere is the main server code and I have not found out where yet (there are logitech plugins which have this feature commented out as it doesn't work!)

                            Comment


                              #15
                              Originally posted by pippin View Post
                              youtube:// was wrong. Here's how YouTube links work on iPhone:
                              Yes youtube:// was one I made up for the plugin as SBS needs a unique url scheme for a protocol handler.

                              Can you describe in a bit more detail where you want this weblink? (I explicity check the user interface and only show it on a web session at present!)

                              Comment

                              Working...
                              X