Announcement

Collapse
No announcement yet.

Announce: Denon AVP Control Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    AVR won’t wake from «power-save-standby» when LMS resumes playing.

    Hi again.

    Not a big deal - but I’ve noticed that after an intermittent pause in the music (>60min), the AVR will automatically enter power-save standby while the LMS player (touch) will remain turned on. The player will then happily commence “playing” without turning on the AVR.

    Since the plug-in is otherwise good at reading the AVR status - I would have expected it to turn the AVR back on in this scenario?

    Comment


      Originally posted by Sportswagoneer View Post
      Hi again.

      Not a big deal - but I’ve noticed that after an intermittent pause in the music (>60min), the AVR will automatically enter power-save standby while the LMS player (touch) will remain turned on. The player will then happily commence “playing” without turning on the AVR.

      Since the plug-in is otherwise good at reading the AVR status - I would have expected it to turn the AVR back on in this scenario?
      Auto standby is an 'Eco' power saving option on newer AVR's that my old Denon doesn't have. It can be set to time intervals up to 60 mins or disabled. When it is triggered, it simply powers off the AVR the same as if you had turned it off manually. The plugin does no periodic polling of the AVR to check its status and is unaware that it has been powered off. It only reacts to LMS player commands and assumes that, once it has powered the AVR on, it is in control. Look at it this way. If you had intentionally turned the AVR off from the front panel, would you want the LMS player, which could be in another room, to immediately turn it back on because it is still playing? Probably not.

      So the solution to your problem would be to disable the AVR's Auto standby mode or, when the situation occurs, turn the LMS player off and back on or, alternatively, use the client app's "Denon/Marantz AVR settings" menu to power cycle the AVR without affecting the player at all.
      Sam

      Comment


        Originally posted by SamY View Post
        Auto standby is an 'Eco' power saving option on newer AVR's that my old Denon doesn't have. It can be set to time intervals up to 60 mins or disabled. When it is triggered, it simply powers off the AVR the same as if you had turned it off manually. The plugin does no periodic polling of the AVR to check its status and is unaware that it has been powered off. It only reacts to LMS player commands and assumes that, once it has powered the AVR on, it is in control. Look at it this way. If you had intentionally turned the AVR off from the front panel, would you want the LMS player, which could be in another room, to immediately turn it back on because it is still playing? Probably not.

        So the solution to your problem would be to disable the AVR's Auto standby mode or, when the situation occurs, turn the LMS player off and back on or, alternatively, use the client app's "Denon/Marantz AVR settings" menu to power cycle the AVR without affecting the player at all.
        Thanks for your reply!
        I understand that use-case! Would make for a low WAF if the AVR just switched back on again!

        I’ve downloaded the “power save” plugin and enabled it on the Touch after 60 minutes of inactivity. That should keep the player and the AVR pretty much synced in on/off state, making it easy to reliably turn on house-wide playback from iPeng.

        Comment


          Originally posted by Sportswagoneer View Post
          Thanks for your reply!
          I understand that use-case! Would make for a low WAF if the AVR just switched back on again!

          I’ve downloaded the “power save” plugin and enabled it on the Touch after 60 minutes of inactivity. That should keep the player and the AVR pretty much synced in on/off state, making it easy to reliably turn on house-wide playback from iPeng.
          Brilliant idea! I might try that plugin myself. It should work even without the auto standby AVR feature since turning off the player would automatically trigger the plugin to power off the AVR.
          Sam

          Comment


            Originally posted by SamY View Post
            Brilliant idea! I might try that plugin myself. It should work even without the auto standby AVR feature since turning off the player would automatically trigger the plugin to power off the AVR.
            And... it works!! Just tried it out and, after pausing the player and waiting 15 minutes (value used for testing purposes), it turned off the player, thus triggering the Denon plugin to power off the AVR. This is really a nice feature because the Denon plugin will only power off the AVR if the input source is still set to the one associated with the LMS player. Therefore if, in the meantime, the input had been switched to TV, for example, the AVR would not be turned off, thus avoiding a possible family crisis. (⁠◠⁠‿⁠◕⁠)
            Sam

            Comment


              Originally posted by SamY View Post
              And... it works!! Just tried it out and, after pausing the player and waiting 15 minutes (value used for testing purposes), it turned off the player, thus triggering the Denon plugin to power off the AVR. This is really a nice feature because the Denon plugin will only power off the AVR if the input source is still set to the one associated with the LMS player. Therefore if, in the meantime, the input had been switched to TV, for example, the AVR would not be turned off, thus avoiding a possible family crisis. (⁠◠⁠‿⁠◕⁠)
              Thanks for trying it out, I have installed it but haven't yet had a chance to give it a run. I had never given it much thought when I have seen it in the list but it will be very useful at my end apart. Some mornings I find my SBT units have turned themselves on during the night, luckily I do not have them set to auto-play! Not sure what causes them to turn on as it is always both of them and it does not relate to power outages, especially having household battery back-up. Now hopefully if they turn on randomly they will power down after the preset period. Funny story, years ago I did have them on auto-play and I was overseas at the time when they turned on, but they also turned on at near full volume, much to the neighbour's annoyance and amusement. Luckily, after they contacted me I was able to control the system remotely and turn it off.

              Cheers, David
              Serverrpi3 pCP8.1.0 LMS8.2.0
              MediaUSB hard drive
              Lounge/dining areasSBT > Denon AVR2113 > Bose Acoustimass10 / Krix Seismix3 18" 300w RMS custom cinema sub (& AR 77XB t/table, Stanton 680MkII / Grado F-1+ > NAD7155 to phono pre-amp > Amp+)
              Family/kitchenSBT > Denon AVRX3000 zone 1 > Krix Acoustix F, Centrix C, Holographix R & Original Seismix 7 15" 400w RMS sub
              AlfrescoZ2 > Krix Tropix/Klipsch SW
              OthersSB Player/androids > Bose Soundlink Mini
              SBT/SB Player Remotes Squeeze Ctrl/androids

              Comment


                Hi Sam, I have been noticing the slide up/down volume interface when using MS very jumpy and sometimes non-responsive then it jumps to a different volume. I have increments set at 2%, could possibly just be lag in my system? All while using Denon receiver. Have attached a debug in case you feel like taking a look.

                Regards, David.server.log(31).zip
                Serverrpi3 pCP8.1.0 LMS8.2.0
                MediaUSB hard drive
                Lounge/dining areasSBT > Denon AVR2113 > Bose Acoustimass10 / Krix Seismix3 18" 300w RMS custom cinema sub (& AR 77XB t/table, Stanton 680MkII / Grado F-1+ > NAD7155 to phono pre-amp > Amp+)
                Family/kitchenSBT > Denon AVRX3000 zone 1 > Krix Acoustix F, Centrix C, Holographix R & Original Seismix 7 15" 400w RMS sub
                AlfrescoZ2 > Krix Tropix/Klipsch SW
                OthersSB Player/androids > Bose Soundlink Mini
                SBT/SB Player Remotes Squeeze Ctrl/androids

                Comment


                  Originally posted by DavidBulluss View Post
                  Hi Sam, I have been noticing the slide up/down volume interface when using MS very jumpy and sometimes non-responsive then it jumps to a different volume. I have increments set at 2%, could possibly just be lag in my system? All while using Denon receiver. Have attached a debug in case you feel like taking a look.
                  Your debug log looks fine, David. The network response time between the plugin (LMS) and the AVR seems to be very good also. I would suspect a response lag between MS and LMS, but I have no means of verifying that from the log file. Is the MS client running on your phone or on some other device? You might want to experiment with different volume increments. Mine is currently set to 1%, which yields very smooth volume changes on my system. Another thing to play around with is how you slide your finger up/down on the screen. I find that it works better for me with a quick flicking motion, like scrolling through a document. Otherwise, there's always the hardware buttons.
                  Sam

                  Comment


                    Originally posted by SamY View Post
                    Your debug log looks fine, David. The network response time between the plugin (LMS) and the AVR seems to be very good also. I would suspect a response lag between MS and LMS, but I have no means of verifying that from the log file. Is the MS client running on your phone or on some other device? You might want to experiment with different volume increments. Mine is currently set to 1%, which yields very smooth volume changes on my system. Another thing to play around with is how you slide your finger up/down on the screen. I find that it works better for me with a quick flicking motion, like scrolling through a document. Otherwise, there's always the hardware buttons.
                    I took your lead and set increments to 1% and it is much better thanks. By the way, I am still persevering with using Squeeze-CTRL and have noticed that the up/down swipe on the now playing screen does affect the volume but in large jumps from which it sometimes jumps back quickly to where it was. Just mentioning out of interest.

                    Cheers, David.
                    Serverrpi3 pCP8.1.0 LMS8.2.0
                    MediaUSB hard drive
                    Lounge/dining areasSBT > Denon AVR2113 > Bose Acoustimass10 / Krix Seismix3 18" 300w RMS custom cinema sub (& AR 77XB t/table, Stanton 680MkII / Grado F-1+ > NAD7155 to phono pre-amp > Amp+)
                    Family/kitchenSBT > Denon AVRX3000 zone 1 > Krix Acoustix F, Centrix C, Holographix R & Original Seismix 7 15" 400w RMS sub
                    AlfrescoZ2 > Krix Tropix/Klipsch SW
                    OthersSB Player/androids > Bose Soundlink Mini
                    SBT/SB Player Remotes Squeeze Ctrl/androids

                    Comment


                      Originally posted by DavidBulluss View Post
                      I took your lead and set increments to 1% and it is much better thanks. By the way, I am still persevering with using Squeeze-CTRL and have noticed that the up/down swipe on the now playing screen does affect the volume but in large jumps from which it sometimes jumps back quickly to where it was. Just mentioning out of interest.
                      Yeah. I see the same behavior, which I believe is a function of the app itself. The MS volume slider is much more stable and responsive. You might want to try changing the increment value setting to 1% there too. Another setting to experiment with is the plugin's Max Volume setting, which defaults to -10 (70dB). You can change it on the fly without restarting LMS to see if it helps. Beyond that, you'd have to pursue it with the Squeeze Ctrl app developer.
                      Sam

                      Comment


                        Quick question

                        I downloaded this plugin but how do I enable it or find the settings? Thanks.
                        Pi4 w/Allo Boss 2 Player (Wired), Max2Play w/LMS Server 8.2
                        Router: Netgear R700P
                        File Storage: Samsung T5 SSD
                        Music Service: Qobuz
                        Logitech Boom

                        Comment


                          Originally posted by Fahzz View Post
                          I downloaded this plugin but how do I enable it or find the settings? Thanks.
                          Go to the LMS Settings->Player menu for the player(s) you want to use it with and select the DENON AVP/AVR Control dropdown menu to set the plugin options. See the Plugin Wiki link at the bottom of the settings menu for detailed setup and usage instructions. If you have any further questions or problems, this is the place to post them.
                          Sam

                          Comment


                            Originally posted by SamY View Post
                            Go to the LMS Settings->Player menu for the player(s) you want to use it with and select the DENON AVP/AVR Control dropdown menu to set the plugin options. See the Plugin Wiki link at the bottom of the settings menu for detailed setup and usage instructions. If you have any further questions or problems, this is the place to post them.
                            Thanks- found it under the extra settings for the player.

                            Denon website has AVR 3700 for $1199 new $999 for refurb is anybody is looking to make a move.
                            Pi4 w/Allo Boss 2 Player (Wired), Max2Play w/LMS Server 8.2
                            Router: Netgear R700P
                            File Storage: Samsung T5 SSD
                            Music Service: Qobuz
                            Logitech Boom

                            Comment


                              Any way to have this plugin work on players connected via AirPlay bridge? Basically would just need to have power off functionality as the AVR turns on automatically if AirPlay'd to (at least all of mine do) and volume is controlled by the volume slider by default. I sometimes use one of my AVRs this way and would like it to turn off like the rest of them when I hit the power off button. Without it I have to use the remote control or rely on auto-off.

                              Enabling the plugin as-is on an airplay bridge connected AVR causes some wacky behavior with volume adjusting Zone 3 and the AVR (Denon X6300H) flickering the zones on and off. Obviously it is not meant for this but I gave it a shot.

                              Comment


                                Originally posted by mctr View Post
                                Any way to have this plugin work on players connected via AirPlay bridge? Basically would just need to have power off functionality as the AVR turns on automatically if AirPlay'd to (at least all of mine do) and volume is controlled by the volume slider by default. I sometimes use one of my AVRs this way and would like it to turn off like the rest of them when I hit the power off button. Without it I have to use the remote control or rely on auto-off.

                                Enabling the plugin as-is on an airplay bridge connected AVR causes some wacky behavior with volume adjusting Zone 3 and the AVR (Denon X6300H) flickering the zones on and off. Obviously it is not meant for this but I gave it a shot.
                                It might be possible to configure the plugin settings in such a way that it does what you want. If not, I can look at rigging something in the code for the next release, which is due to be published soon. When you speak of zones flickering on and off when volume adjusting Zone 3, I'm assuming that you have set up both plugins to control Zone 3 and they are each sending competing volume commands to the Denon, one via Telnet and the other via whatever protocol Airplay uses. Other than that, are you able to power off the AVR via the Denon plugin? It might be interesting to see a debug log of what is going on. In the meantime, if you configure the LMS audio "Volume Control" setting for the associated player to "Volume controls adjust outputs" instead of "Fixed at 100%", the plugin will not send volume or muting commands to the AVR at all, which is what you want. You would also want to leave the Quick Select / Input Source blank, assuming that is all set up with the Airplay bridge. With that configuration, the only commands sent to the AVR by the plugin should be Power On and Off. The extra Power On command shouldn't cause any problems. Give it a try and see how it goes.
                                Last edited by SamY; 2022-11-27, 04:42.
                                Sam

                                Comment

                                Working...
                                X