Announcement

Collapse
No announcement yet.

[Beta Announce] Revised Inguz DSP plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [QUOTE=devgcl;1068021]Thanks for the reply. I checked the mp3 and WMAL settings in my custom-conf file and its exactly the same as per your config.
    As another side issue, I can see the equalizer working for WAV or FLAC files types but it has no effect for Spotty (Spotify) streaming. Spotty plays too loud and bass heavy which I wanted to equalize.
    Originally posted by foxesden View Post
    My custom-conf file for a single player looks like this.

    # #inguzeq#begin#rev:0.1.05#client:d0:50:99:85:19:e9 # ***** BEGIN AUTOMATICALLY GENERATED SECTION - DO NOT EDIT ****
    aac flc * d0:50:99:85:19:e9
    Hi for Spotty see my reply to earlier post

    The file format under advanced settings should look like this

    Sure, you may well have a lot of repetition (depending upon how many players you have setup), but this is the pattern

    Spotty
    FLAC (R) spotty.exe/flac
    FLAC (R) spotty.exe/sox
    MP3 (R) spotty.exe/lame
    Ogg Vorbis (R) Disabled
    PCM (R) spotty.exe
    FLAC (F) InguzDSP/flac

    For WMAL it is a similar situation, you basically have to tell LMS to use the mapping
    WMA Lossless
    FLAC (F, R) wmadec/flac
    FLAC (F, R) wmadec/InguzDSP
    MP3 (F, R) Disabled
    PCM (F, R) wmadec
    WMA Lossless (F, I) Disabled

    NB this may be slightly wrong as I don't generally us WMA as a file source.

    Comment


      REW Filter Response files (Convolver) in Inguz

      Hi,
      I tried REW and am really happy with the eq it did to each channel.
      I want to apply the rew convolver (wav) files into my LMS (7.9.X) installed on Linux (Fedora)
      Is there a way to do that?
      Note, The eq does not help as the filters require PEQ if I wanted to go through the eq route.
      Thank you

      Comment


        Originally posted by devgcl View Post
        Is there a way to do that?
        Yes. InguzEQ will load convolver files:

        Click image for larger version

Name:	Clipboard01.jpg
Views:	1
Size:	20.0 KB
ID:	1576413

        Put a copy of your convolver file in the linux equivalent of Windows' %programdata%\InguzEQ\Impulses folder, restart server, and InguzEQ should find it.

        Comment


          Worked like a charm. Managed to upload my stereo convolver file into LMS. Thanks heaps for that.
          I currently exported the filter impulse as a Stereo file at 192000 kpbs as I am upscaling all audio that rate. Is that OK or should I keep the export at 48000kpbs?
          Thanks.

          Comment


            Happy new year

            great, how to do so an an ARM NAS?

            Comment


              Originally posted by devgcl View Post
              I currently exported the filter impulse as a Stereo file at 192000 kpbs as I am upscaling all audio that rate. Is that OK or should I keep the export at 48000kpbs?
              It doesn't matter as InguzEQ will automatically scale your convolver to match the format of the source.
              Last edited by Apesbrain; 2023-01-04, 12:23.

              Comment


                Originally posted by schwimma View Post
                how to do so an an ARM NAS?
                Is the NAS running LMS? If so, try installing the InguzEQ plugin. People are running it on RPi, so it is possible. InguzEQ requires some CPU cycles so be prepared for a performance hit on low-powered chips, e.g. slow menus. I'd think it best not to run files > 16/44.

                Comment


                  yes, a qnap with 4* A55..wich Folder to put the REW file?

                  Comment


                    Originally posted by Apesbrain View Post
                    It doesn't matter as InguzEQ will automatically scale your convolver to match the format of the source.
                    Thanks. Yesterday I did some listening with the convolver but I hardly noticed much change in the sound (despite I replay the track). When I load the mono files through BruteFir, the change is palpable and immediate.
                    I wanted the the implementation via InguzEQ.... Is the convolver really working currently?

                    Comment


                      Originally posted by devgcl View Post
                      Is the convolver really working currently?
                      Have you confirmed the InguzEQ is correctly installed using the "Transistor Radio" settings mentioned up-thread?

                      Is "Flatness" set to 10?

                      Remember, loading the impulse file will not result in an immediate change; it can take 10-20 seconds to take effect as the data is flushed through your network and playback chain. Restart the current track for immediate effect.

                      Find or make a more extreme impulse file and temporarily load it just to confirm the functionality is working. Careful with volumes.

                      You can see what InguzEQ is doing by opening and examining its log (in %programdata%\InguzEQ). There is a block of entries for every played track. Reference to the impulse file should be listed there.

                      Comment


                        Depending upon what format files you are playing, and which other plugins you have installed it is possible that the DSP is by-passed. The best test is to use a local flac file and do the transistor test that Apesbrain mentioned.

                        Comment


                          Thank for the help. I played WAV files and Spotty. I also disabled BruteFir, disabled InguzEQ then re-enables few times. And definitely did the transistor test. But no success.
                          Is there a way to have the plugin completely removed then re-installed (not disable/re-enable) I am using Daphile LMS BTW. Thanks again

                          Comment


                            disabling the plugin on the plugins menu and then re-starting should remove all the code associated with it, but not any preferences. These are stored in the preferences folder on your server which can be identified under server settings information. There should be an InguzEQ folder here and removing this as well as disabling the plugin should completely remove everything from your server. Albeit you will need to re-start.

                            Comment


                              Thanks for the reply. Just to retest it properly, I installed LMS (latest version 8.3.X) on another server - my Synology NAS (DS415+). The plugin installed ok.
                              However, it still does not respond to any change (even with transistor test). I did find the settings directory such as the Impulse directory.
                              But strangely I cant find the InguzEQ log file in any directory. I am wondering if it installed ok - BTW I had to install LMS using a docker file in the NAS.

                              Comment


                                Originally posted by devgcl View Post
                                But strangely I cant find the InguzEQ log file in any directory. I am wondering if it installed ok - BTW I had to install LMS using a docker file in the NAS.
                                The log file should be created in the InguzEQ sub-folder located in the SqueezeboxServer preferences folder. The file will normally be created upon the first call to InguzEQ.

                                There are a number of steps you can take to check. You need to know the players id - looks like this (d0:50:99:85:19:e9‚Äč)
                                the custom-convert.conf file located in Squeezebox\Cache\InstalledPlugins\Plugins\InguzEQ and check this vs the format of the file you are playing. You can post it here if you like
                                you can try and set logging to debug, which should tell you if InguzEQ is bine called, but bypassed. Go to the Advanced tab on settings, select logging, scroll down to InguzEQ and set the logging to debug and re-run.
                                This last one is tricky, but is more insightful. Install the C-3PO Transcoder Helper plugin; On the player tab of settings select C-3PO plugin (do not enable it for the player), and choose the last executed command.
                                Mine looks like this

                                [flac] -dcs --totally-silent $START$ $END$ -- $FILE$ | [InguzDSP] -id "d0:50:99:85:19:e9" -wav -wavo -d 24 | [flac] -cs -0 --totally-silent -

                                This is useful because it tells you exactly what is running.

                                If your custom-convert.conf is setup correctly, but you are still seeing no logging and C-3PO is not showing something similar to the above then it is the file types that need amending, let me know what you find.

                                Comment

                                Working...
                                X