Announcement

Collapse
No announcement yet.

Announce : BBC Sounds Plugin

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Originally posted by expectingtofly

    No, the live programme should adjust the progress bar to where you are in the programme, and play at the live point. There may be a brief few seconds while it gets the info as to where it is in the programme, but it should adjust the progress bar as soon as it does. It is working fine for me, is that not working for you?
    I just started playing Radio 2 and the audio is live but the progress bar is clearly starting from zero. If I click the progress bar I can force it to the live position then "rewind" but I can't rewind without doing that. Click image for larger version

Name:	Screenshot_20230210-091940.png
Views:	243
Size:	604.2 KB
ID:	1629826
    Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
    Bedroom: Radio
    Bathroom: Radio

    Comment


    • What is interesting is that if I stop playback then restart it the progress bar initially jumps to the correct position before immediately returning to zero.
      Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
      Bedroom: Radio
      Bathroom: Radio

      Comment


      • Originally posted by slartibartfast
        What is interesting is that if I stop playback then restart it the progress bar initially jumps to the correct position before immediately returning to zero.
        Gosh, that's not right. Would you mind creating a debug log that covers the period of starting up a new live stream. You can drop the log into this dropbox location : https://www.dropbox.com/request/quaOojw7tEGyuv6iqXnW

        Thanks
        Stuart McLean

        ExpectingToFly Plugins :
        BBC Sounds, Global Player (UK), Times Radio, UK Radio Player, Virgin Radio (UK) and the Radio Favourites Plugin

        For BBC Sounds help see the BBC Sounds Wiki.

        Comment


        • Originally posted by expectingtofly

          Gosh, that's not right. Would you mind creating a debug log that covers the period of starting up a new live stream. You can drop the log into this dropbox location : https://www.dropbox.com/request/quaOojw7tEGyuv6iqXnW

          Thanks
          Will do. The Global player acts the same way except clicking the progress bar doesn't fix it.
          Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
          Bedroom: Radio
          Bathroom: Radio

          Comment


          • Originally posted by slartibartfast

            Will do. The Global player acts the same way except clicking the progress bar doesn't fix it.
            I expect its the same bug, it seems the progress bar is not updating for you. as it uses the same method to adjust the progress bar. Hmmm I wonder what has changed, that code hasn't really changed for ages.
            Stuart McLean

            ExpectingToFly Plugins :
            BBC Sounds, Global Player (UK), Times Radio, UK Radio Player, Virgin Radio (UK) and the Radio Favourites Plugin

            For BBC Sounds help see the BBC Sounds Wiki.

            Comment


            • Seems to work fine for me. Desktop and phone.

              Click image for larger version

Name:	Live.jpg
Views:	234
Size:	33.2 KB
ID:	1629834
              Server - LMS 8.4.0 RPi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)

              Lounge - DAC32 - AudioEngine B2
              Office - RPi 3B+/HiFiBerry DAC HAT/RPi screen - Edifier D12
              Bedroom - Echo Show 8

              Spares - 1xSB Touch, 1xSB3, 4xRPi, AVI DM5 speakers

              Comment


              • Originally posted by kidstypike
                Seems to work fine for me. Desktop and phone.
                Indeed, I can't recreate either. I've tried 3 different LMS installations. So hopefully its a very specific scenario/combination that's impacting slartibartfast

                Stuart McLean

                ExpectingToFly Plugins :
                BBC Sounds, Global Player (UK), Times Radio, UK Radio Player, Virgin Radio (UK) and the Radio Favourites Plugin

                For BBC Sounds help see the BBC Sounds Wiki.

                Comment


                • Originally posted by expectingtofly
                  Indeed, I can't recreate either. I've tried 3 different LMS installations. So hopefully its a very specific scenario/combination that's impacting slartibartfast
                  I've uploaded two logs. one starting from the menu and the other restarting after stopping.
                  Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                  Bedroom: Radio
                  Bathroom: Radio

                  Comment


                  • Originally posted by slartibartfast

                    I just started playing Radio 2 and the audio is live but the progress bar is clearly starting from zero. If I click the progress bar I can force it to the live position then "rewind" but I can't rewind without doing that. Click image for larger version

Name:	Screenshot_20230210-091940.png
Views:	243
Size:	604.2 KB
ID:	1629826
                    I yet have to hear that song on a local station here…
                    Michael

                    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                    (LMS: Settings/Information)

                    Comment


                    • Originally posted by slartibartfast

                      I've uploaded two logs. one starting from the menu and the other restarting after stopping.


                      Thank you for the logs.
                      Do you know what, I think your server is just way too fast, or your player is far too slow. One of the two!!!!! I think the former.!
                      The progress bar gets adjusted before the player has actually had any audio data, the player getting the progress bar seems to confuse it and is doing a seek to start of the programme messing up the progress bar again.
                      Thanks for the report, I'll put up a beta release and try and fix it.
                      Last edited by expectingtofly; 2023-02-10, 11:32.
                      Stuart McLean

                      ExpectingToFly Plugins :
                      BBC Sounds, Global Player (UK), Times Radio, UK Radio Player, Virgin Radio (UK) and the Radio Favourites Plugin

                      For BBC Sounds help see the BBC Sounds Wiki.

                      Comment


                      • Originally posted by slartibartfast

                        I've uploaded two logs. one starting from the menu and the other restarting after stopping.
                        I've taken a punt at what I think is causing it. Unfortunately I can't recreate it here to test. Please will you install version 2.28.2 from the beta repository and see if that fixes it.
                        Stuart McLean

                        ExpectingToFly Plugins :
                        BBC Sounds, Global Player (UK), Times Radio, UK Radio Player, Virgin Radio (UK) and the Radio Favourites Plugin

                        For BBC Sounds help see the BBC Sounds Wiki.

                        Comment


                        • Originally posted by expectingtofly

                          I've taken a punt at what I think is causing it. Unfortunately I can't recreate it here to test. Please will you install version 2.28.2 from the beta repository and see if that fixes it.
                          This is really strange. That fixes it for some stations but not all when restarting after stopping but not when playing directly from the menu.
                          I then thought of things I had done to LMS recently and that was installing the C3PO transcoding helper plugin which was disabled and doesn't affect aac streams anyway. If I uninstall that plugin then BBC Sounds works normally.
                          Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                          Bedroom: Radio
                          Bathroom: Radio

                          Comment


                          • Originally posted by slartibartfast

                            This is really strange. That fixes it for some stations but not all when restarting after stopping but not when playing directly from the menu.
                            I then thought of things I had done to LMS recently and that was installing the C3PO transcoding helper plugin which was disabled and doesn't affect aac streams anyway. If I uninstall that plugin then BBC Sounds works normally.
                            Oh yes!! I installed C3PO and it does indeed cause that side effect. I wonder what it's doing! Anyway, at least we got to the bottom of it.
                            Stuart McLean

                            ExpectingToFly Plugins :
                            BBC Sounds, Global Player (UK), Times Radio, UK Radio Player, Virgin Radio (UK) and the Radio Favourites Plugin

                            For BBC Sounds help see the BBC Sounds Wiki.

                            Comment


                            • Hi folks, starting Friday night when I try to Browse Categories e.g. "Home > BBC Sounds > Browse Categories > Browse all Speech > Comedy" I get a monochrome image of a laughing girl and "404 Not Found".

                              I've tried restarting the server, I've checked that I'm still logged in, "Listen Live" still works fine, so does "Podcasts". So it seems like it's something specific to "Browse Categories" and hopefully it's just that the BCC have changed the URLs of the pages the server needs to look at, rather than removing it completely ...
                              http://about.me/tallpaul
                              Server: Intel Pentium G3420 3.2GHz, 2 core, 4GB, Ubuntu 16.0.4LTS, SBS 8.2.1 - 1639114554
                              Players: piCorePlayer, Boom, SqueezePlayer on various Android devices, plus squeezelite clients on house PCs

                              Comment


                              • Originally posted by tallpaul
                                Hi folks, starting Friday night when I try to Browse Categories e.g. "Home > BBC Sounds > Browse Categories > Browse all Speech > Comedy" I get a monochrome image of a laughing girl and "404 Not Found".

                                I've tried restarting the server, I've checked that I'm still logged in, "Listen Live" still works fine, so does "Podcasts". So it seems like it's something specific to "Browse Categories" and hopefully it's just that the BCC have changed the URLs of the pages the server needs to look at, rather than removing it completely ...
                                I can confirm that is the same for me.

                                Comment

                                Working...
                                X
                                😀
                                🥰
                                🤢
                                😎
                                😡
                                👍
                                👎