Announcement

Collapse
No announcement yet.

Announce: Material Skin

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Originally posted by artatgray
    Some of my albums and tracks content multiple covers in their metadata. Ex. Front cover, back cover, insets, liner notes, etc.

    Currently there's no way to access/display anything other than the front cover, at least that I know of.
    You can access other artwork by:

    1. Navigate to album's track listing
    2. In the sub-toolbar on the far right (of the browse view) there will be a "(...)" icon (to the left of the play icon) - pressing this will show a menu
    3. From this menu choose "More"
    4. The select "Local artwork"

    This all requires the "Music and Artist Information" plugin to be installed. If you have this then in the "(...)" menu Material will also add an entry to allow access to local text files - again via MAI. However, MAI does not provide CLI access to local artwork, if it did then I'd add an entry here to, and make the process simpler.
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

    Comment


    • Originally posted by cpd73

      You can access other artwork by:

      1. Navigate to album's track listing
      2. In the sub-toolbar on the far right (of the browse view) there will be a "(...)" icon (to the left of the play icon) - pressing this will show a menu
      3. From this menu choose "More"
      4. The select "Local artwork"

      This all requires the "Music and Artist Information" plugin to be installed. If you have this then in the "(...)" menu Material will also add an entry to allow access to local text files - again via MAI. However, MAI does not provide CLI access to local artwork, if it did then I'd add an entry here to, and make the process simpler.
      I have the MAI plug-in installed and the following is all I see when following the sequence of actions you've mentioned:

      Click image for larger version

Name:	Screenshot_2023-06-03-20-26-43-50_b34bcfd62110e2ea2eb7c00873abebbe.jpg
Views:	288
Size:	155.4 KB
ID:	1640325
      Click image for larger version

Name:	Screenshot_2023-06-03-20-26-49-00_b34bcfd62110e2ea2eb7c00873abebbe.jpg
Views:	276
Size:	203.6 KB
ID:	1640326
      Click image for larger version

Name:	Screenshot_2023-06-03-20-27-00-89_b34bcfd62110e2ea2eb7c00873abebbe.jpg
Views:	274
Size:	263.5 KB
ID:	1640327

      I can access the front cover this way, but nothing else... πŸ€”
      Some friends, associates and I run a Facebook group dedicated to music streaming technologies and you're all welcome to join us:

      https://facebook.com/groups/hifiaudiostreaming/

      Comment


      • Originally posted by artatgray

        I have the MAI plug-in installed and the following is all I see when following the sequence of actions you've mentioned:
        That's not the sequence I mentioned. I said to navigate to an album's track listing - you started from a Queue track. Anyhow, this also works for me. But this is for local tracks only, not online sources. Are you using local tracks?
        Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

        Comment


        • Originally posted by artatgray

          I have the MAI plug-in installed and the following is all I see when following the sequence of actions you've mentioned:

          Click image for larger version

Name:	Screenshot_2023-06-03-20-26-43-50_b34bcfd62110e2ea2eb7c00873abebbe.jpg
Views:	288
Size:	155.4 KB
ID:	1640325
          Click image for larger version

Name:	Screenshot_2023-06-03-20-26-49-00_b34bcfd62110e2ea2eb7c00873abebbe.jpg
Views:	276
Size:	203.6 KB
ID:	1640326
          Click image for larger version

Name:	Screenshot_2023-06-03-20-27-00-89_b34bcfd62110e2ea2eb7c00873abebbe.jpg
Views:	274
Size:	263.5 KB
ID:	1640327

          I can access the front cover this way, but nothing else... πŸ€”
          Multiple covers in embedded artwork has been discussed before but the chance of finding that discussion using the forum search is slim.
          Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
          Bedroom: Radio
          Bathroom: Radio

          Comment


          • Originally posted by artatgray
            Some of my albums and tracks content multiple covers in their metadata.
            Missed that part of the info. Oops! Must admit I never use embedded covers - have the same image over multiple tracks just seems really odd to me (yes I know disk space is (relatively) cheap, but still...)

            Anyhow, I've asked if MAI can be extended to allow CLI access to local artwork, and if so I'll add that to the Material menu as I mentioned.
            Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

            Comment


            • Originally posted by cpd73

              That's not the sequence I mentioned. I said to navigate to an album's track listing - you started from a Queue track. Anyhow, this also works for me. But this is for local tracks only, not online sources. Are you using local tracks?
              Doesn't local artwork only include image files in the album folder. It wouldn't show embedded artwork would it?
              Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
              Bedroom: Radio
              Bathroom: Radio

              Comment


              • Originally posted by slartibartfast

                Doesn't local artwork only include image files in the album folder. It wouldn't show embedded artwork would it?
                No, as I said i missed that important piece of information!
                Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

                Comment


                • Originally posted by cpd73

                  Missed that part of the info. Oops! Must admit I never use embedded covers - have the same image over multiple tracks just seems really odd to me (yes I know disk space is (relatively) cheap, but still...)

                  Anyhow, I've asked if MAI can be extended to allow CLI access to local artwork, and if so I'll add that to the Material menu as I mentioned.
                  Yes, I was just about to come back to this to clarifiy that it's embedded artwork.

                  ​​​​​​While I was away, I stumbled across one of my albums that had independent *.jpg files in the folder with the tracks. The actions worked as you stated in that particular instance.

                  Thanks again... 😎
                  Some friends, associates and I run a Facebook group dedicated to music streaming technologies and you're all welcome to join us:

                  https://facebook.com/groups/hifiaudiostreaming/

                  Comment


                  • Originally posted by artatgray


                    Some of my albums and tracks content multiple covers in their metadata. Ex. Front cover, back cover, insets, liner notes, etc.

                    Currently there's no way to access/display anything other than the front cover, at least that I know of.
                    This is not a Material issue. Would you mind sharing such a file with me? https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a - that would allow me to see whether the image data even can be accessed by our scanner code.
                    Michael

                    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                    (LMS: Settings/Information)

                    Comment


                    • Originally posted by mherger

                      This is not a Material issue. Would you mind sharing such a file with me? https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a - that would allow me to see whether the image data even can be accessed by our scanner code.
                      Sure. I'll upload I am now. Thanks.
                      Some friends, associates and I run a Facebook group dedicated to music streaming technologies and you're all welcome to join us:

                      https://facebook.com/groups/hifiaudiostreaming/

                      Comment


                      • Hi!
                        This is my first post and firstly I would like to thank you for the excellent Material Skin and all the hard work.


                        I am having a couple of issues very recently, I think since yesterday:

                        - Drag and Drop from a Windows folder to the LMS/Material Skin is not working anymore. I tried with the standard skin and it is working, so I think some changes made to the latest version are affecting this.

                        - The default view is not working as it was before. When I open the Material Skin interface, the left pane with the Music Sources is empty, but if I move the separating bar the Music Sources appear. I can toggle between large icons or small icons. However if it is in the large icons view and I close the window and reopen it again the Music Sources is empty again.
                        If I close the window with view as list (small icons) and reopen the window, the window opens with the expected view.
                        So something is happening when large icons view is selected that it can't maintain that setting when reopening the window.

                        Any possible solutions?

                        Thank you very much

                        ​

                        Comment


                        • Originally posted by Stranger
                          Drag and Drop from a Windows folder to the LMS/Material Skin is not working anymore. I tried with the standard skin and it is working, so I think some changes made to the latest version are affecting this.
                          Don't have Windows, but this is working for me under Linux. Any errors logged in your browser's developer tools?

                          [Edit] Not 100% sure, but I might know the reason and made some fixes for 3.3.2 - odd that it's working for me, but not for you, but changes should make things work.

                          Originally posted by Stranger
                          The default view is not working as it was before. When I open the Material Skin interface, the left pane with the Music Sources is empty, but if I move the separating bar the Music Sources appear. I can toggle between large icons or small icons. However if it is in the large icons view and I close the window and reopen it again the Music Sources is empty again.
                          If I close the window with view as list (small icons) and reopen the window, the window opens with the expected view.
                          So something is happening when large icons view is selected that it can't maintain that setting when reopening the window.
                          ​
                          Confirmed. Fixed for 3.3.2
                          Last edited by cpd73; 2023-06-03, 20:06.
                          Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

                          Comment


                          • Originally posted by cpd73
                            3.3.1 release, changes:

                            1. Fix 'Copy browse selection here'
                            2. Fix removing selected items from queue.
                            ....
                            Thanks! Both working as expected. I use these practically every day. Being able to add multiple tracks at any arbitrary point in the current queue is a feature that had been on my wish list for a long time when you added this to Material Skin.
                            Usually running latest beta LMS nightly on Raspberry Pi OS with virtual players. Occasionally using SB Radio, Boom or Classic.

                            Comment


                            • Originally posted by cpd73

                              Don't have Windows, but this is working for me under Linux. Any errors logged in your browser's developer tools?

                              [Edit] Not 100% sure, but I might know the reason and made some fixes for 3.3.2 - odd that it's working for me, but not for you, but changes should make things work.



                              Confirmed. Fixed for 3.3.2
                              Thank you very much for your help.
                              I was trying to update to version 3.3.2 but the update does not show on PCP/LMS how can I install it?

                              Again... thank you

                              Comment


                              • Originally posted by Stranger

                                Thank you very much for your help.
                                I was trying to update to version 3.3.2 but the update does not show on PCP/LMS how can I install it?

                                Again... thank you
                                Probably not released yet.
                                Server - LMS 8.4.0 RPi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)

                                Lounge - DAC32 - AudioEngine B2
                                Office - RPi 3B+/HiFiBerry DAC HAT/RPi screen - Edifier D12
                                Bedroom - Echo Show 8

                                Spares - 1xSB Touch, 1xSB3, 4xRPi, AVI DM5 speakers

                                Comment

                                Working...
                                X
                                😀
                                🥰
                                🤢
                                😎
                                😡
                                👍
                                👎