Announcement

Collapse
No announcement yet.

Announce: Material Skin

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Is it possible to have the option in the desktop view on the left side to have something simliar to the mobile view? Maybe you could toggle between the current menu and the mobile view or something similar to the mobile view? You lose the "eye-candy" in the desktop view. Also in the mobile view can the background be similar to what happens in the music and artist info screen where it zooms into the album cover in the background? I have keypads around my house and they display like this. It just adds a little something that looks good. See below 2nd pic.

    Click image for larger version

Name:	CaptureLMS2.jpg
Views:	1
Size:	100.1 KB
ID:	1565448



    Click image for larger version

Name:	IMG_4146.jpg
Views:	2
Size:	246.2 KB
ID:	1565449

    Comment


    • +1

      Would definitely like more "eye candy" in landscape mode when viewing the "now playing" info.

      Comment


      • Wrong artwork being shown

        In the last few days I've had the wrong artwork being shown for radio stations after switching from other stations.

        Having played a particular station and then closed that and chosen another one, the correct artwork for the new station is shown. After a few tracks on the new station have been played (where the tracks themselves have artwork shown), when it switches back to what should be the default artwork for that station, the previous station's artwork from earlier is shown. Hope this makes sense.

        No idea whether this is a Material problem or is related to LMS itself.

        PS: Logic suggests this must be an LMS issue, so I'll post there too.


        PSS: Yes this is the wrong thread, apologies.
        Last edited by IanHaynes; 2018-12-10, 17:42.
        Library: Netgear NAS Duo - Server: RPi3 / PiCorePlayer with LMS 8.0 - Main System: RPi2 / iQAudio DAC+ / PiCorePlayer
        Second System: RPiZero / iQAudio DAC Zero / PiCorePlayer - PC: Squeezelite-X

        Comment


        • Announce: Material Skin

          > No idea whether this is a Material problem or is related to LMS itself.

          Then you probably shouldn't post here ;-). Next time this happens please
          check the default skin, too. And please make sure you're running the
          very latest LMS.

          --

          Michael
          Michael

          "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
          (LMS: Settings/Information)

          Comment


          • Great Interface. I have been using it on my desktop (Linux Mint 19) for a few days and it is now my preferred Interface. I notice that when I choose Radio Paradise under apps and then select "Play Something Different" nothing happens when doing this from the web interface. Sorry if this has already been covered but there appears to be 73 pages of posts for this plugin which is amazing as the plugin has only been introduced a short time ago. Kudos to the developer.


            EDIT: Now I am not sure. Play Something Different seemed to work once with my radio but not my classic. Does it not work with FLAC streams only MP3

            EDIT 2: seems to be a problem with Radio Paradise on my system as Play Something Else failed to work from player interface also
            Last edited by SlimChances; 2018-12-11, 02:31.
            Logitech Media Server Version: 8.4.0 - 1678519305 @ Sat 11 Mar 2023 08:54:37 AM CET
            Operating system: Debian - EN - utf8
            Platform Architecture: x86_64-linux
            Perl Version: 5.34.0 - x86_64-linux-gnu-thread-multi
            Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)​

            Comment


            • utf8 JA

              First of all, I thank you for creating an amazing plug-in.
              I live in Japan, I use not only English but also artist name and album name in Japanese.
              See below (original skin)

              Click image for larger version

Name:	キャプチャ.JPG
Views:	1
Size:	43.9 KB
ID:	1565513

              However, in material skin, it garbled.
              Is it possible to fix it?

              Click image for larger version

Name:	キャプチャ2.JPG
Views:	1
Size:	20.9 KB
ID:	1565514
              Click image for larger version

Name:	キャプチャ3.JPG
Views:	1
Size:	18.6 KB
ID:	1565515

              Logitech Media Server バージョン: 7.9.2 - 1539967036 @ Fri Oct 19 19:20:46 CEST 2018
              Hostname: pCP-LMS-PCM5122
              サーバーIPアドレス: 192.168.11.103
              サーバーHTTPポート番号: 9000
              Operating system: piCore - JA - utf8
              Platform Architecture: armv7l-linux
              Perl Version: 5.24.0 - arm-linux-gnueabihf-thread-multi-64int
              Audio::Scan: 1.02
              IO::Socket::SSL: 2.056
              Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
              認識されたプレーヤー数: 2

              Thank you.
              Last edited by tappy_h; 2018-12-16, 08:59.

              Comment


              • Originally posted by tappy_h
                Logitech Media Server バージョン: 7.9.2 - 1539967036 @ Fri Oct 19 19:20:46 CEST 2018
                Hostname: pCP-LMS-PCM5122
                サーバーIPアドレス: 192.168.11.103
                サーバーHTTPポート番号: 9000
                Operating system: piCore - JA - utf8
                Platform Architecture: armv7l-linux
                Perl Version: 5.24.0 - arm-linux-gnueabihf-thread-multi-64int
                Audio::Scan: 1.02
                IO::Socket::SSL: 2.056
                Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
                認識されたプレーヤー数: 2

                Thank you.
                Update your LMS and try again. I think we fixed this issue only very recently.
                Michael

                "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                (LMS: Settings/Information)

                Comment


                • Originally posted by mherger
                  Update your LMS and try again. I think we fixed this issue only very recently.
                  Thank you Michael.
                  I confirmed that it has been corrected.

                  Click image for larger version

Name:	キャプチャ4.JPG
Views:	3
Size:	19.0 KB
ID:	1565516

                  I am grateful for your quick response always.

                  Logitech Media Server バージョン: 7.9.2 - 1544453860 @ Mon Dec 10 16:25:27 CET 2018
                  Hostname: pCP-LMS-PCM5122
                  サーバーIPアドレス: 192.168.11.103
                  サーバーHTTPポート番号: 9000
                  Operating system: piCore - JA - utf8
                  Platform Architecture: armv7l-linux
                  Perl Version: 5.24.0 - arm-linux-gnueabihf-thread-multi-64int
                  Audio::Scan: 1.02
                  IO::Socket::SSL: 2.056
                  Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
                  認識されたプレーヤー数: 2

                  Comment


                  • 0.2.1 Release

                    Mainly a bug-fix release, the only real feature being drag'n'drop re-ordering of favourites.
                    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

                    Comment


                    • Originally posted by cpd73
                      Mainly a bug-fix release, the only real feature being drag'n'drop re-ordering of favourites.
                      Favourites Drag & Drop bug?

                      The artwork doesn't move with the track title until the page is reloaded, reloading the page goes back to the home menu.

                      Click image for larger version

Name:	drag.jpg
Views:	1
Size:	8.3 KB
ID:	1565521
                      Server - LMS 8.4.0 RPi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)

                      Lounge - DAC32 - AudioEngine B2
                      Office - RPi 3B+/HiFiBerry DAC HAT/RPi screen - Edifier D12
                      Bedroom - Echo Show 8

                      Spares - 1xSB Touch, 1xSB3, 4xRPi, AVI DM5 speakers

                      Comment


                      • Originally posted by kidstypike
                        Favourites Drag & Drop bug?

                        The artwork doesn't move with the track title until the page is reloaded, reloading the page goes back to the home menu.
                        Hmmm... I had seen that on one machine, but when I tried on my dev machine all was OK. And now I can see the issue again. I'll look into why this is happening.

                        [Edit] OK, I think the issue is that LMS gives the favorites an ID - based upon its position. When items are moved, so are the IDs. I then think the Javascript library I'm using thinks that as the ID of the row has not changed, then image does not need to be fetched.
                        Last edited by cpd73; 2018-12-16, 21:58.
                        Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

                        Comment


                        • Originally posted by cpd73
                          Hmmm... I had seen that on one machine, but when I tried on my dev machine all was OK. And now I can see the issue again. I'll look into why this is happening.
                          Does drag and drop of favourites work on Android? I can't seem to use it.

                          Sent from my SM-G900F using Tapatalk
                          Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                          Bedroom: Radio
                          Bathroom: Radio

                          Comment


                          • Originally posted by slartibartfast
                            Does drag and drop of favourites work on Android? I can't seem to use it.

                            Sent from my SM-G900F using Tapatalk
                            Same bug on Android, title moves but not the artwork.
                            Server - LMS 8.4.0 RPi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)

                            Lounge - DAC32 - AudioEngine B2
                            Office - RPi 3B+/HiFiBerry DAC HAT/RPi screen - Edifier D12
                            Bedroom - Echo Show 8

                            Spares - 1xSB Touch, 1xSB3, 4xRPi, AVI DM5 speakers

                            Comment


                            • Originally posted by kidstypike
                              Same bug on Android, title moves but not the artwork.
                              How do I move a favourite? Nothing happens when I try to drag one.

                              Never mind. Probably a caching issue.

                              Sent from my SM-G900F using Tapatalk
                              Last edited by slartibartfast; 2018-12-16, 22:14.
                              Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                              Bedroom: Radio
                              Bathroom: Radio

                              Comment


                              • Originally posted by kidstypike
                                Same bug on Android, title moves but not the artwork.
                                Well it would, bug is the same. Fixed in git for next release. As stated, it seems to be because the item IDs are swapped when the items are swapped - and the lazy loading code for the covers gets confused. I have worked-around this by ensuring the ID changes when the list is refreshed.

                                This (IMHO) is a minor issue, so I'll wait for more bugs+fixes before making a release.
                                Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

                                Comment

                                Working...
                                X
                                😀
                                🥰
                                🤢
                                😎
                                😡
                                👍
                                👎