Announcement

Collapse
No announcement yet.

[Announce] Radio Paradise Lossless Streaming (Plugin v2)

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Originally posted by mherger
    > Playing RP this morning, I'm finding that the FLAC stream I'm hearing is
    > about 45 minutes behind the RP website playlist.


    Bill just confirmed there was a problem on his end, and he was working
    on it.

    --

    Michael
    Bill seems to have fixed it :-)

    Sent from my SM-G900F using Tapatalk
    Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
    Bedroom: Radio
    Bathroom: Radio

    Comment


    • [Announce] Radio Paradise LosslessStreaming (Plugin v2)

      > Bill seems to have fixed it :-)

      Yep, it's been streaming fine for a few hours. Send him some love ;-).

      --

      Michael
      Michael

      "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
      (LMS: Settings/Information)

      Comment


      • Just found this today when my RP plugin updated.
        Thanks Michael!
        Tony
         SBTouch ♪ SBRadio ♬

        Comment


        • Originally posted by mherger
          "Play Something Different is no longer a thing. You should implement 'skip' instead." Bill told me. v2.1.0 does it.

          When you're playing lossless Radio Paradise you can now press the FWD button to skip a track you don't like. Simple as that. Have fun!
          I was just trying (unsuccessfully) to get PSD as a Favorite in the WebUI when I saw this.
          Not sure which I like better, this or FLAC

          BTW, do you still need PSD in the WebUI My Apps and in the Contextual Menu on the SB Radio? Maybe just a message to press FWD for PSD?
          Last edited by Tony T; 2017-11-06, 13:35.
          Tony
           SBTouch ♪ SBRadio ♬

          Comment


          • Originally posted by mherger
            If you want to add it to a playlist or prefs, use the url "radioparadise://1.flac".
            Not sure if this was mentioned, but there's more than 1. When I selected from My Apps I get "radioparadise://4.flac".
            Tony
             SBTouch ♪ SBRadio ♬

            Comment


            • I'm also having the "Enable Radio Paradise HD images" issue reported a few pages back.
              Clicking "Enable…" does not enable HD Images, and the option never toggles to "Disable…"
              I'm running 7.9.1 on a pCP

              Log (Debug) show nothing, just:

              17-11-06 08:58:34.0976] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
              [17-11-06 08:58:34.1001] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
              [17-11-06 08:59:23.2294] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
              [17-11-06 08:59:23.2319] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
              [17-11-06 08:59:23.2388] Slim::Networking::Async:NS::__ANON__ (76) Got DNS response 52.85.93.198 for img.radioparadise.com (ttl 59)
              [17-11-06 08:59:28.4243] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata



              ok, I'm done with playing with the options on the updated Plug-in, time to just enjoy the new FLAC stream and now easily selected PSD
              Last edited by Tony T; 2017-11-06, 14:05.
              Tony
               SBTouch ♪ SBRadio ♬

              Comment


              • Originally posted by Tony T
                I'm also having the "Enable Radio Paradise HD images" issue reported a few pages back.
                Clicking "Enableā€¦" does not enable HD Images, and the option never toggles to "Disableā€¦"
                I'm running 7.9.1 on a pCP

                Log (Debug) show nothing, just:

                17-11-06 08:58:34.0976] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
                [17-11-06 08:58:34.1001] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
                [17-11-06 08:59:23.2294] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
                [17-11-06 08:59:23.2319] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata
                [17-11-06 08:59:23.2388] Slim::Networking::Async:NS::__ANON__ (76) Got DNS response 52.85.93.198 for img.radioparadise.com (ttl 59)
                [17-11-06 08:59:28.4243] Plugins::RadioParadise::ProtocolHandler::getMetada taFor (179) Returning cached metadata



                ok, I'm done with playing with the options on the updated Plug-in, time to just enjoy the new FLAC stream and now easily selected PSD
                If you enable HD images from the context menu instead of the option in the App it seems to work.

                Sent from my SM-G900F using Tapatalk
                Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                Bedroom: Radio
                Bathroom: Radio

                Comment


                • Originally posted by slartibartfast
                  If you enable HD images from the context menu instead of the option in the App it seems to work.

                  Sent from my SM-G900F using Tapatalk
                  Tried that on my SB Radio, still no HD Images.
                  (I don't use HD Images, but just thought I'd report it)
                  Tony
                   SBTouch ♪ SBRadio ♬

                  Comment


                  • Originally posted by Tony T
                    Tried that on my SB Radio, still no HD Images.
                    (I don't use HD Images, but just thought I'd report it)
                    Strange. It works for me on the SB Radio and Orange Squeeze.

                    Sent from my SM-G900F using Tapatalk
                    Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                    Bedroom: Radio
                    Bathroom: Radio

                    Comment


                    • Originally posted by mherger
                      > I was just about to try it after being out all day. Your findings agree
                      > with mine. Is it an easy fix?


                      Please update to 1.0.6. It will hopefully fix the issue.

                      --

                      Michael
                      WWTT 1.0.6 seems to prevent local tracks being listed. There was a comment in the WWTT thread about this so I tried it and no local tracks at all were listed.

                      Sent from my SM-G900F using Tapatalk
                      Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                      Bedroom: Radio
                      Bathroom: Radio

                      Comment


                      • Yup, when I play tracks from my own collection, they "usually" do not appear in WWTT (v1.0.6.) I actually did see one local track appear in the WWTT display, after the track had finished playing.
                        Living Room: SB Touch + DIY PSU > CI Audio VDA.2 DAC + VAC.1 PSU > VRX.1 cables > Emotiva XSP-1 Gen 2 preamp + XPA-DR2 amp > Blue Jeans cables > B&W 804 speakers
                        Laptop: System76 Galago + Ubuntu 18.04 + Squeezelite + Epiphany/Material Skin > Emotiva Little Ego DAC > Grado PS500 headphones
                        Bedroom: RPi Zero W + Squeezelite > miniBOSS DAC HAT > Bose SoundLink Revolve
                        Phone: Pixel 6a + Termux/Squeezelite + Material APK > Senn IE80 earbuds
                        Server: System76 Meerkat + Pop!_OS 22.04 + LMS 8.4

                        Comment


                        • [Announce] Radio Paradise LosslessStreaming (Plugin v2)

                          > WWTT 1.0.6 seems to prevent local tracks being listed. There was a
                          > comment in the WWTT thread about this so I tried it and no local tracks
                          > at all were listed.


                          Thanks for the heads up. I'll follow up in the WWTT thread.

                          --

                          Michael
                          Michael

                          "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                          (LMS: Settings/Information)

                          Comment


                          • I'm really enjoying and listening to RP more now with FLAC, and the PSD with the Next Track button is great!
                            (This was enough to get me off my a$$ to finally make a support payment to RP)
                            Tony
                             SBTouch ♪ SBRadio ♬

                            Comment


                            • When in PSD (and FLAC), is there a way to get back to the RP Main Stream?
                              (Tried Prev Track, but that just restarts the track)
                              Tony
                               SBTouch ♪ SBRadio ♬

                              Comment


                              • [Announce] Radio Paradise LosslessStreaming (Plugin v2)

                                > When in PSD (and FLAC), is there a way to get back to the RP Main
                                > Stream?


                                In FLAC there's no such thing as a main stream, or even PSD. It's
                                basically a never ending playlist. If you decide to skip a track, then
                                well, you skip a track. But you can't skip back. Which means that as
                                soon as you've skipped a track, you'd be ahead of the "main stream".
                                Which allows you to know what listeners on the regular mp3 stream would
                                listen to in an hour from now :-).

                                > (Tried Prev Track, but that just restarts the track)


                                Hmm... how did you do so? I thought I had disabled Previous.

                                --

                                Michael
                                Michael

                                "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                                (LMS: Settings/Information)

                                Comment

                                Working...
                                X
                                😀
                                🥰
                                🤢
                                😎
                                😡
                                👍
                                👎