Announcement

Collapse
No announcement yet.

ANNOUNCE: AirPlay Bridge = integrate AirPlay devices with LMS (squeeze2raop)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Try 1.1.0.7
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

    Comment


      Originally posted by philippe_44 View Post
      Try 1.1.0.7
      Thanks for your time and effort. Good progress with this update in that pairing prompted me for the pin, which displayed on the ATV, but after hitting 'submit' the process never appeared to complete (although the pin did disappear from the TV display, as if accepted). I've attached the server plugin log of me attempting to submit the pin a few times. I restarted LMS and the bridge a couple of times without success. After one LMS restart I ended up with a long hexadecimal string after the player in the bridge settings page and thought then that I was in business, but no audio would play. I hope the log is of some help if you want to continue to debug this but I can appreciate it is time consuming for you so there's no need for my sake! Let me know if you need more systematic troubleshooting steps or additional logs.
      Attached Files

      Comment


        Originally posted by manx View Post
        Thanks for your time and effort. Good progress with this update in that pairing prompted me for the pin, which displayed on the ATV, but after hitting 'submit' the process never appeared to complete (although the pin did disappear from the TV display, as if accepted). I've attached the server plugin log of me attempting to submit the pin a few times. I restarted LMS and the bridge a couple of times without success. After one LMS restart I ended up with a long hexadecimal string after the player in the bridge settings page and thought then that I was in business, but no audio would play. I hope the log is of some help if you want to continue to debug this but I can appreciate it is time consuming for you so there's no need for my sake! Let me know if you need more systematic troubleshooting steps or additional logs.
        Version 1.1.0.9 should take care of pairing (it's better to stop the bridge before doing the pairing BTW). Now, there is a conflict with the plugin SuperDateTime that overwrite a system's calls. In case you have it, just disable it for the time of pairing
        LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

        Comment


          Originally posted by philippe_44 View Post
          Version 1.1.0.9 should take care of pairing (it's better to stop the bridge before doing the pairing BTW). Now, there is a conflict with the plugin SuperDateTime that overwrite a system's calls. In case you have it, just disable it for the time of pairing
          Thanks again. Pairing completes quickly and painlessly with this update but now that the ATV is paired it cannot play any audio! ���� The ATV also occasionally and randomly disappears from the list of available players in LMS. Logs record the bridge crashing but all other airplay players are available while the ATV is absent. I've cleaned the config.xml and removed and reinstalled the bridge to see if it would make a difference but no joy. Server and bridge logs attached but I'm not sure if they reveal very much.

          PS I don't have the SuperDateTime plugin installed. My installed plugins are:
          Additional Browse Modes 1.0
          AirPlay bridge 1.1.0.9
          Band's Campout 1.9.0
          BBC Sounds 2.25.7
          Client Cleanup 1.0.0
          Don't Stop The Music 1.0.0
          Full text search 1.0.0
          Material Skin 3.0.1
          Mixcloud 0.9
          Music and Artist Information 1.8.0
          PlayHLS 1.1
          Podcasts 2.0
          Radio 1.0
          Radio Now Playing 0.0.29
          Radio Paradise 3.1.1
          Random Mix 1.0
          Rescan Music Library 1.0
          Save Playlist 1.0
          Attached Files
          Last edited by manx; 2022-11-21, 18:03. Reason: EDIT

          Comment


            Originally posted by manx View Post
            Thanks again. Pairing completes quickly and painlessly with this update but now that the ATV is paired it cannot play any audio! ���� The ATV also occasionally and randomly disappears from the list of available players in LMS. Logs record the bridge crashing but all other airplay players are available while the ATV is absent. I've cleaned the config.xml and removed and reinstalled the bridge to see if it would make a difference but no joy. Server and bridge logs attached but I'm not sure if they reveal very much.
            Well... 1.1.0.11 should do
            LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

            Comment


              Originally posted by philippe_44 View Post
              Well... 1.1.0.11 should do
              And it does! Streaming without a hitch so far. Amazing work, thank you so much 👊

              Comment


                I updated to 1.1.0.11 because I wanted to fix some issues with interrupted playback (random stutters).

                The non-static binary for 1.1.0.11 kept crashing so I switched to squeeze2raop-linux-x86_64-static which works as expected. I enabled logging and waited for a stutter:

                Code:
                [14:28:45.838743] PlayerThread:556 [0xabb240]: flushing ...
                [14:28:45.877760] PlayerThread:453 [0xabb240]: Disconnecting 3194815029
                [14:28:45.877832] PlayerThread:569 [0xabb240]: processing volume device:54 request:-13.80
                [14:28:45.878666] process_strm:241 [0xa63100] strm command s
                [14:28:45.878716] process_strm:315 [0xa63100], strm s autostart: 1 transition period: 10 transition type: 0 codec: f
                [14:28:45.878880] process_strm:348 [0xa63100]: codec:f, ch:255, s:255, r:255
                [14:28:45.878978] PlayerThread:546 [0xabb240]: raop connecting ...
                [14:28:45.987652] raopcl_connect:983 [0x7f91a80090b0]: local interface 192.168.178.32
                [14:28:46.426225] exec_request:691 [0x7f91a800d440]: Body data len 713
                [14:28:46.484264] raopcl_connect:1067 [0x7f91a80090b0]: setting volume as part of connect -13.80
                [14:28:46.491904] PlayerThread:549 [0xabb240]: raop connected
                [14:28:46.491968] PlayerThread:569 [0xabb240]: processing volume device:54 request:-13.80
                [14:28:46.493521] raopcl_accept_frames:415 [0x7f91a80090b0]: begining to stream hts:0 n:1669642126.2119643669
                [14:28:46.493690] raopcl_accept_frames:423 [0x7f91a80090b0]: restarting w/o pause n:1669642126.2119643669, hts:73631217778364
                [14:28:46.505310] _output_frames:53 [0xa63100]: start buffer frames: 393216
                [14:28:46.505420] _output_frames:100 [0xa63100]: track start sample rate: 44100 replay_gain: 0
                [14:28:46.516022] output_raop_thread:98 [0xa63100]: track actual start time:3194816895 (gap:-1100150401)
                [14:28:48.512107] cli_open_socket:185 [0xa63100]: opened CLI socket 19
                [14:28:48.531484] PlayerThread:526 [0xabb240]: idx 0
                	artist:Edith Mathis
                	album:Bach, J.S.: Kantaten, Vol. 1: Advent und Weihnachten
                	title:Nun komm, der Heiden Heiland, BWV 61 - 1. Ouvertüre: Nun komm, der Heiden Heiland
                	genre:Kantaten
                	duration:237.866
                	size:0
                	cover:http://192.168.178.32:9000/music/2c444fc1/cover.jpg
                [14:28:48.549251] PlayerThread:575 [0xabb240]: Got artwork for http://192.168.178.32:9000/music/2c444fc1/cover.jpg
                [14:28:48.761270] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194817913 p:3194819154 ts:73631217878332 sn:9442
                               retr: 0, avail: 0, send: 0, select: 0)
                [14:28:58.771128] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194827923 p:3194829155 ts:73631218319388 sn:10695
                               retr: 24, avail: 0, send: 0, select: 0)
                [14:29:08.763653] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194837915 p:3194839156 ts:73631218760444 sn:11948
                               retr: 38, avail: 0, send: 0, select: 0)
                [14:29:18.767674] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194847919 p:3194849158 ts:73631219201500 sn:13201
                               retr: 41, avail: 0, send: 0, select: 0)
                [14:29:28.766040] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194857918 p:3194859159 ts:73631219642556 sn:14454
                               retr: 42, avail: 0, send: 0, select: 0)
                [14:29:38.760170] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194867912 p:3194869152 ts:73631220083260 sn:15706
                               retr: 75, avail: 0, send: 0, select: 0)
                [14:29:48.765967] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194877917 p:3194879154 ts:73631220524316 sn:16959
                               retr: 75, avail: 0, send: 0, select: 0)
                [14:29:58.766549] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194887918 p:3194889155 ts:73631220965372 sn:18212
                               retr: 77, avail: 0, send: 0, select: 0)
                [14:30:08.771766] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194897923 p:3194899156 ts:73631221406428 sn:19465
                               retr: 95, avail: 0, send: 0, select: 0)
                [14:30:18.768904] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194907920 p:3194909157 ts:73631221847484 sn:20718
                               retr: 97, avail: 0, send: 0, select: 0)
                [14:30:28.773683] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194917925 p:3194919159 ts:73631222288540 sn:21971
                               retr: 99, avail: 0, send: 0, select: 0)
                [14:30:38.759522] raopcl_send_chunk:587 [0x7f91a80090b0]: check n:3194927911 p:3194929152 ts:73631222729244 sn:23223
                               retr: 102, avail: 0, send: 0, select: 0)
                [14:30:39.887819] process_strm:241 [0xa63100] strm command p
                [14:30:39.887949] raopcl_pause:358 [0x7f91a80090b0]: set pause 73631222778524
                [14:30:39.888026] PlayerThread:556 [0xabb240]: flushing ...
                [14:30:39.888059] raopcl_flush:1098 [0x7f91a80090b0]: flushing up to s:23363 ts:73631222778524
                [14:30:40.896063] PlayerThread:453 [0xabb240]: Disconnecting 3194930048
                I'd appreciate any help.



                Server info (on Ubuntu 22.04.1 LTS):

                Logitech Media Server Version: 8.4.0 - 1668787292 @ Fri 18 Nov 2022 05:39:31 PM CET
                Hostname: nuc
                Server IP Address: 192.168.178.32
                Server HTTP Port Number: 9000
                Operating system: Debian - EN - utf8
                Platform Architecture: x86_64-linux
                Perl Version: 5.34.0 - x86_64-linux-gnu-thread-multi
                Audio::Scan: 1.05
                IO::Socket::SSL: 2.074
                Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
                Total Players Recognized: 6
                Last edited by dolodobendan; 2022-11-28, 14:52. Reason: I don't know how I got the IP pasted all over the place. Fixed.
                QLMS [email protected] x64 (digimaster) / QNAP 469L (QTS 4.3.4)
                LMS 8.4 x64 / Intel NUC8 i3 (Ubuntu 22.04.1 LTS)

                Comment


                  It’s very weird that the non-static would crash on a recent distro. Do you have have logs of that?
                  LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

                  Comment


                    This is with a clean log after enabling "Running" and hitting apply:

                    Code:
                    Starting Squeeze2raop: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64 -Z -I -f /var/log/squeezeboxserver/raopbridge.log -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                    [02:18:16.621168] main:1493 Starting squeeze2raop version: v1.1.0.11 (Nov 21 2022 @ 21:59:16)
                    
                    [02:18:16.621636] Start:1231 Cannot load SSL libraries
                    [02:18:16.621644] main:1531 Cannot start, exiting
                    
                    [B]Retarting [/B]Squeeze2raop after crash: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64-static -Z -I -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                    Grammarly suggests "Retargeting".

                    "Cannot load SSL libraries"?

                    Code:
                    openssl version -a
                    gives me

                    Code:
                    OpenSSL 3.0.2 15 Mar 2022 (Library: OpenSSL 3.0.2 15 Mar 2022)
                    built on: Thu Oct 27 17:06:56 2022 UTC
                    platform: debian-amd64
                    options:  bn(64,64)
                    compiler: gcc -fPIC -pthread -m64 -Wa,--noexecstack -Wall -Wa,--noexecstack -g -O2 -ffile-prefix-map=/build/openssl-WsPfAX/openssl-3.0.2=. -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security -DOPENSSL_TLS_SECURITY_LEVEL=2 -DOPENSSL_USE_NODELETE -DL_ENDIAN -DOPENSSL_PIC -DOPENSSL_BUILDING_OPENSSL -DNDEBUG -Wdate-time -D_FORTIFY_SOURCE=2
                    OPENSSLDIR: "/usr/lib/ssl"
                    ENGINESDIR: "/usr/lib/x86_64-linux-gnu/engines-3"
                    MODULESDIR: "/usr/lib/x86_64-linux-gnu/ossl-modules"
                    Seeding source: os-specific
                    CPUINFO: OPENSSL_ia32cap=0x7ffaf3bfffebffff:0x29c67af
                    QLMS [email protected] x64 (digimaster) / QNAP 469L (QTS 4.3.4)
                    LMS 8.4 x64 / Intel NUC8 i3 (Ubuntu 22.04.1 LTS)

                    Comment


                      Originally posted by dolodobendan View Post
                      This is with a clean log after enabling "Running" and hitting apply:

                      Code:
                      Starting Squeeze2raop: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64 -Z -I -f /var/log/squeezeboxserver/raopbridge.log -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                      [02:18:16.621168] main:1493 Starting squeeze2raop version: v1.1.0.11 (Nov 21 2022 @ 21:59:16)
                      
                      [02:18:16.621636] Start:1231 Cannot load SSL libraries
                      [02:18:16.621644] main:1531 Cannot start, exiting
                      
                      [B]Retarting [/B]Squeeze2raop after crash: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64-static -Z -I -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                      Grammarly suggests "Retargeting".

                      "Cannot load SSL libraries"?

                      Code:
                      openssl version -a
                      gives me

                      Code:
                      OpenSSL 3.0.2 15 Mar 2022 (Library: OpenSSL 3.0.2 15 Mar 2022)
                      built on: Thu Oct 27 17:06:56 2022 UTC
                      platform: debian-amd64
                      options:  bn(64,64)
                      compiler: gcc -fPIC -pthread -m64 -Wa,--noexecstack -Wall -Wa,--noexecstack -g -O2 -ffile-prefix-map=/build/openssl-WsPfAX/openssl-3.0.2=. -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security -DOPENSSL_TLS_SECURITY_LEVEL=2 -DOPENSSL_USE_NODELETE -DL_ENDIAN -DOPENSSL_PIC -DOPENSSL_BUILDING_OPENSSL -DNDEBUG -Wdate-time -D_FORTIFY_SOURCE=2
                      OPENSSLDIR: "/usr/lib/ssl"
                      ENGINESDIR: "/usr/lib/x86_64-linux-gnu/engines-3"
                      MODULESDIR: "/usr/lib/x86_64-linux-gnu/ossl-modules"
                      Seeding source: os-specific
                      CPUINFO: OPENSSL_ia32cap=0x7ffaf3bfffebffff:0x29c67af
                      At least I can correct the "Retarting" But joke aside, what are the symlinks for your openssl library? What do you find in /lib or /usr/lib that is "libssl*.so"
                      LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

                      Comment


                        Originally posted by philippe_44 View Post
                        At least I can correct the "Retarting" But joke aside, what are the symlinks for your openssl library?
                        Do you mean this?

                        Code:
                        [email protected]:/usr/lib# find . -type l -ls | grep ssl
                          6818956      0 lrwxrwxrwx   1 root     root           28 Mar 25  2022 ./x86_64-linux-gnu/libxmlsec1-openssl.so.1 -> libxmlsec1-openssl.so.1.2.33
                          6821300      0 lrwxrwxrwx   1 root     root           14 Apr 20  2020 ./ssl/certs -> /etc/ssl/certs
                          6821302      0 lrwxrwxrwx   1 root     root           16 Apr 20  2020 ./ssl/private -> /etc/ssl/private
                          6817373      0 lrwxrwxrwx   1 root     root           20 Oct 27 19:06 ./ssl/openssl.cnf -> /etc/ssl/openssl.cnf
                          6947483      0 lrwxrwxrwx   1 root     root            8 Oct 27 19:06 ./ssl/misc/tsget -> tsget.pl
                        Originally posted by philippe_44 View Post
                        What do you find in /lib or /usr/lib that is "libssl*.so"
                        This is what locate found:

                        Code:
                        [email protected]:/# locate libssl | grep ^/usr
                        /usr/lib/x86_64-linux-gnu/libssl.so.3
                        /usr/lib/x86_64-linux-gnu/libssl3.so
                        /usr/share/doc/libssl3
                        /usr/share/doc/libssl3/changelog.Debian.gz
                        /usr/share/doc/libssl3/copyright
                        /usr/share/perl-openssl-defaults/get-libssl-abi
                        I don't use Linux regularly, so I tend to forget how things are done. Thank you for your help and patience.
                        QLMS [email protected] x64 (digimaster) / QNAP 469L (QTS 4.3.4)
                        LMS 8.4 x64 / Intel NUC8 i3 (Ubuntu 22.04.1 LTS)

                        Comment


                          ANNOUNCE: AirPlay Bridge = integrate AirPlay devices with LMS (squeeze2raop)

                          Originally posted by dolodobendan View Post
                          Do you mean this?

                          Code:
                          [email protected]:/usr/lib# find . -type l -ls | grep ssl
                            6818956      0 lrwxrwxrwx   1 root     root           28 Mar 25  2022 ./x86_64-linux-gnu/libxmlsec1-openssl.so.1 -> libxmlsec1-openssl.so.1.2.33
                            6821300      0 lrwxrwxrwx   1 root     root           14 Apr 20  2020 ./ssl/certs -> /etc/ssl/certs
                            6821302      0 lrwxrwxrwx   1 root     root           16 Apr 20  2020 ./ssl/private -> /etc/ssl/private
                            6817373      0 lrwxrwxrwx   1 root     root           20 Oct 27 19:06 ./ssl/openssl.cnf -> /etc/ssl/openssl.cnf
                            6947483      0 lrwxrwxrwx   1 root     root            8 Oct 27 19:06 ./ssl/misc/tsget -> tsget.pl


                          This is what locate found:

                          Code:
                          [email protected]:/# locate libssl | grep ^/usr
                          /usr/lib/x86_64-linux-gnu/libssl.so.3
                          /usr/lib/x86_64-linux-gnu/libssl3.so
                          /usr/share/doc/libssl3
                          /usr/share/doc/libssl3/changelog.Debian.gz
                          /usr/share/doc/libssl3/copyright
                          /usr/share/perl-openssl-defaults/get-libssl-abi
                          I don't use Linux regularly, so I tend to forget how things are done. Thank you for your help and patience.
                          What Linux is this? Can you try to do a symlink to libssl3.so. named libssl.so?
                          LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

                          Comment


                            Originally posted by philippe_44 View Post
                            What Linux is this?
                            Ubuntu Server (with LXQt 0.17.0)

                            Code:
                            [email protected]:/# lsb_release -a
                            No LSB modules are available.
                            Distributor ID: Ubuntu
                            Description:    Ubuntu 22.04.1 LTS
                            Release:        22.04
                            Codename:       jammy
                            Originally posted by philippe_44 View Post
                            Can you try to do a symlink to libssl3.so. named libssl.so?
                            Like this?

                            Code:
                            [email protected]:/usr/lib/x86_64-linux-gnu# find . -type l -ls | grep ssl
                              6822242      0 lrwxrwxrwx   1 root     root           36 Dec  3 01:37 ./libssl.so -> /usr/lib/x86_64-linux-gnu/libssl3.so
                              6818956      0 lrwxrwxrwx   1 root     root           28 Mar 25  2022 ./libxmlsec1-openssl.so.1 -> libxmlsec1-openssl.so.1.2.33
                            But I still get the same error message:

                            Code:
                            Starting Squeeze2raop: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64 -Z -I -f /var/log/squeezeboxserver/raopbridge.log -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                            [01:39:40.994790] main:1493 Starting squeeze2raop version: v1.1.0.11 (Nov 21 2022 @ 21:59:16)
                            
                            [01:39:40.997404] Start:1231 Cannot load SSL libraries
                            [01:39:40.997434] main:1531 Cannot start, exiting
                            
                            Retarting Squeeze2raop after crash: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64 -Z -I -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                            
                            Starting Squeeze2raop: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64 -Z -I -f /var/log/squeezeboxserver/raopbridge.log -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                            [01:39:45.974509] main:1493 Starting squeeze2raop version: v1.1.0.11 (Nov 21 2022 @ 21:59:16)
                            
                            [01:39:45.976264] Start:1231 Cannot load SSL libraries
                            [01:39:45.976285] main:1531 Cannot start, exiting
                            
                            Retarting Squeeze2raop after crash: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/RaopBridge/Bin/squeeze2raop-linux-x86_64-static -Z -I -x /var/lib/squeezeboxserver/prefs/raopbridge.xml
                            QLMS [email protected] x64 (digimaster) / QNAP 469L (QTS 4.3.4)
                            LMS 8.4 x64 / Intel NUC8 i3 (Ubuntu 22.04.1 LTS)

                            Comment


                              Is there any additional data I can provide for this problem?

                              Updated to 1.1.1, still the same issues.
                              Last edited by dolodobendan; 2022-12-09, 17:33. Reason: Updated to 1.1.1
                              QLMS [email protected] x64 (digimaster) / QNAP 469L (QTS 4.3.4)
                              LMS 8.4 x64 / Intel NUC8 i3 (Ubuntu 22.04.1 LTS)

                              Comment


                                Originally posted by dolodobendan View Post
                                Is there any additional data I can provide for this problem?

                                Updated to 1.1.1, still the same issues.
                                You should also have a crypto lib named “libcrypto<xxx>”
                                LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

                                Comment

                                Working...
                                X