No announcement yet.

SqueezePlay running on Maemo

  • Time
  • Show
Clear All
new posts

  • #31
    n8x0 local playback ?

    Originally posted by e_esprit

    You can download my binaries here :

    Do you have local sound playback ? - I get silence and these errors:

    ALSA lib pcm.c:2144snd_pcm_open_noupdate) Unknown PCM hw:0
    19700131 17:53:26.185 ERROR audio.output - decode_alsa_fork:180 jive_alsa failed to start

    Running jive_alsa with -d hw:0 also gives this error, but a -d default returns no errors. Is this a runtime config option or defined at compile time ?



    • #32
      No, local sound playback has been disabled in order to compile (not a choice, it could not compile otherwise if I remember well).
      I compiled it in order to use it as a controller at first, so it was not a big deal for me, and I didn't look much further.


      • #33
        Local playback

        I've build it with the lastest portaudio snapshot and it compiles without error (no edits required), but when run it still shows:

        ERROR audio.output - decode_alsa_fork:180 jive_alsa failed to start

        From the command line:

        jive_alsa -d default -b 30000 -p 3 -s 16 -f 1

        Runs without visible error, but does not stay running (which I assume it should?)

        The n900 setting of "hw:0" does not seem to match a pcm device on the n800.

        /usr/share/alsa/alsa.conf suggests "default" is fine on the n800, and refers to /dev/dsptask/pcm3

        strace on jive_alsa shows /dev/dsptask/pcm3 being opened, but the a call to pcm_test fails and exits.

        Last edited by grb; 2010-06-11, 09:48.


        • #34
          Want to help with the 'official' project

          Okay, so its not official, but I was trying to get everyone together that has been compiling versions of SqueezePlay so we could get it out there to the masses. If you have compiled, or have words of wisdom to share, it would be much appreciated. The link to the project page is below, and joining is pretty painless. Thanks and congrats on getting it working.


          • #35
            Thank you!

            I would like to thank e_esprit, and anyone else who had a hand, in getting this working on the N800. While not perfect, it is very useable the way it is for controlling other players. The response is WAY better than the N800 web browser alternative.
            I was looking for a way to control my Vortexplayer (on a headless Vortexbox server) without having to turn on my workstation, or hauling my controller down from the livingroom. This is the perfect solution.
            Last edited by gmeister; 2010-06-17, 18:26. Reason: spelled name wrong


            • #36
              Command line error on extract

              tar: unrecognized option '--keep-old-files'

              I am using Xarchiver in Maemo OS 2008 on N800. I am also inexperienced in Linux beyond using Debian install packages on my Ubuntu laptop.

              I have Xterminal installed and have root access; the N800 came this way from ebay.

              Any help or suggestions are sincerely appreciated.

              Originally posted by e_esprit

              You can download my binaries here :

              It is compiled from SVN r8709 (2010-04-16 15:20:03 +0200)

              If it causes problems with anyone at Logitech for license questions or whatever, I will remove it, just ask

              The tarball should be extracted from / and will install squeezeplay in /opt/squeezeplay and 2 files (/usr/share/icons/hicolor/scalable/hildon/jive.png /usr/share/applications/hildon/jive.desktop) for the desktop menu entry.

              Then you can launch jive from the application menu.


              • #37
                Anyone have sound playback working yet?


                • #38
                  config/compile' not found

                  Originally posted by Philro

                  Ok i got it compiled. I will test this now on my N900. If somebody explain me how i had to change the Makefile.linux so i can build the install target i could make a deb Package.
                  How did you manage to compile? Got stuck with the same error: required file `config/compile' not found


                  • #39
                    I managed to compile it under qemu-arm by removing -Werror on line 171 of /squeezeplay/src/squeezeplay/ and by running `autoreconf -vif` in the /squeezeplay/src/squeezeplay/ directory.


                    • #40
                      Hi, I have had my N810 sitting and collecting dust for ages, I'm really happy that I might now find new use for it!

                      I just dusted it off and tried to install squeezeplay_7.6.0.deb.
                      While it did install fine, I couldn't get it to run. Here are the errors I get:

                      Nokia-N810-36-5:/opt/squeezeplay/bin# ./
                      ./jive: relocation error: ./jive: symbol __gnu_mcount_nc, version GLIBC_2.5 not defined in file with link time reference

                      Yes, I tried it as user and as root. Same result.
                      Is my OS that outdated? I vaguely remember doing the upgrade to Diablo though....

                      ah, I found out that the binaries from the garage page are apparently fot the N900.
                      esprit still has his binaries for the N8x0 up. They seem to be working fine!
                      Too bad there is no audio output, though!
                      Last edited by fizze; 2012-06-20, 18:47.
                      Running Squeezecenter 7.9 on MariaDB 10.1.38
                      Ubuntu 18.04.01 LTS Server
                      SqueezeBox Boom (x2) - SqueezeBox Classic - Squeezebox Radio


                      • #41
                        Squeezelite and SqueezePlay on N800 with bluetooth

                        Squeezelite runs well under easy debian on the N800. SqueezePlay can be used to control it but the music comes out choppy for me if I run both at the same time.

                        On one of my N800s I am running Turbo Diablo with a2dp for bluetooth. I can play squeezelite with output through the bluetooth speakers with these commands:

                        & sudo debian
                        & squeezelite-armv6 -a 24576:1024:16:0 -o bluetooth

                        Note that the speakers must be turned on or you will get an output not available error.
                        Last edited by darv; 2014-08-19, 13:59.