No announcement yet.

How you can help with SlimServer!

This is a sticky topic.
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by mherger
    > is there any chance of slimserver being compatable with apples proteced
    > acc files

    You'll have to ask Steve Jobs: as long as Apple does not license the
    necessary technologie, there won't be any application beside Apple's own.
    BBC, News, BBC News, news online, world, uk, international, foreign, british, online, service

    may be of interest.


    • #17
      DS as remote

      If anyone is still considering working on a skin for the Nintendo DS (I know there are several posts but nothing recent), I would be glad to help test. I have a DS Lite, SB3, and Slimserver 6.5.2.



      • #18
        Here's some help

        Well, thanks for the code however it is supported ....

        Here is a little help from me, but how to resolve the issue I am not sure.

        Your web interface is acting very odly, in the 7.9.2 server. It seems to be trying to act 'real clever' but the result of which is that it is doing exactly the opposite of what really makes sense. I have been running slim server squeeze logitech server since the early days. Never had much trouble.

        Now however I tried to re-install on a fresh install of Ubuntu Server. Strange behaviour is evident.

        The http server fires up and in netstat -l I see it is bound to no specific network interface. That's okay, but having control would be better.

        Still it gets worse. This server has multiple network interfaces, 2 internal and one external (public internet). When I connect to the server from my internal LAN subnet I get a 403: Forbidden response. The server log is trying to send its response message to my public internet address. Even though the traffic is all totally internal. If I open a hole in my firewall for port 9000, sure enough I can connect with the server on port 9000 no problem from the public Internet!!!!

        Nothing I have tried will make the server operate (bind) itself to my internal lan interface. Even if I unplug the Internet link and have only local interfaces. It refuse to use these. I think perhaps because the Internet interface is alive, but just missing an IP address. I will investigate further on this.

        I tried changing some settings in the /var/lib/squeezeboxserver/server.prefs file (allowedHosts: and bindAddress), but they just get ignored. Regardless of what these are the server only ever binds to my Internet address (BTW this is the first network interface listed on my server...go figure)

        So bottom line.....I can not yet use the damn server and worse I have no control over what it is doing.

        Maybe you can give me some better idea about how to control the server at set-up, I will if needed start messing with my underlying OS, but this is really not the best approach.
        Any tips, I have already seen others facing the same problems, so I'm not alone. Its inflexible.