Announcement

Collapse
No announcement yet.

Alarm not working with 8.3?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by mherger View Post
    Thanks! You got my blessing :-D
    You're welcome. The only thing better would be a blessing from the Pope but I understand he's pretty busy this time of year.
    Sam

    Comment


      Originally posted by didjean View Post
      Just installed and will report if any failure (or Covid)


      Testing Michaels fix... ending alarms using various control methods...

      Leaving to alarm timeout setting - OK

      From Player (SB Radio) front panel
      • Snooze alarm menu on screensaver - OK, although surprised to see it leave the now playing screen on the display during snooze period (same on LMS 8.2.1)
      • Turn off alarm menu on screensaver - OK, turned off alarm/player
      • Pause - OK, turned off alarm/player
      • Select and play something else - can’t be done on player front panel (because of alarm screensaver?)
      • Player on/off button - OK, turned off alarm/player


      Standard Web UI
      • Pause - This paused play of stream but didn’t stop alarm, player remained on alarm screensaver, then got a very brief burst of fallback alarm, then a very short while after went into fallback alarm until timeout ended alarm - Repeatable.
      • Play something else - Changed to a local track which started to play, but Alarm screensaver remained and debug didn’t show end of alarm, player turned off at end of timeout, so playing something else doesn’t stop the alarm.
      • power off - OK, turned off alarm/player


      MaterialSkin
      • pause - Same behaviour as default Web UI
      • play something else - same behaviour as default Web UI
      • power off - OK, turned off alarm/player


      ipeng
      • pause - Same behaviour as default Web UI
      • play something else - Same behaviour as default Web UI
      • power off - OK, turned off alarm/player


      Jive - Control alarm test device from another player (SB Touch)
      • pause - Same behaviour as default Web UI
      • play something else - Same behaviour as default Web UI
      • power off - OK, turned off alarm/player


      Ran same tests from Web UI LMS 8.2.1
      • pause - OK, turned off alarm/player
      • play something else - Same behaviour as default Web UI
      • power off - OK, turned off alarm/player


      So it looks like the behaviour of pressing pause, whilst alarm is on, from a remote control device has changed.

      Kev

      Comment


        Alarm not working with 8.3?

        > So it looks like the behaviour of pressing pause from a remote control
        > device has changed.


        But the change would be in 8.3.0, too?
        Michael

        "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
        (LMS: Settings/Information)

        Comment


          Originally posted by KeBul View Post


          Testing Michaels fix... ending alarms using various control methods...

          Leaving to alarm timeout setting - OK

          From Player (SB Radio) front panel
          • Snooze alarm menu on screensaver - OK, although surprised to see it leave the now playing screen on the display during snooze period (same on LMS 8.2.1)
          • Turn off alarm menu on screensaver - OK, turned off alarm/player
          • Pause - OK, turned off alarm/player
          • Select and play something else - can’t be done on player front panel (because of alarm screensaver?)
          • Player on/off button - OK, turned off alarm/player


          Standard Web UI
          • Pause - This paused play of stream but didn’t stop alarm, player remained on alarm screensaver, then got a very brief burst of fallback alarm, then a very short while after went into fallback alarm until timeout ended alarm - Repeatable.
          • Play something else - Changed to a local track which started to play, but Alarm screensaver remained and debug didn’t show end of alarm, player turned off at end of timeout, so playing something else doesn’t stop the alarm.
          • power off - OK, turned off alarm/player


          MaterialSkin
          • pause - Same behaviour as default Web UI
          • play something else - same behaviour as default Web UI
          • power off - OK, turned off alarm/player


          ipeng
          • pause - Same behaviour as default Web UI
          • play something else - Same behaviour as default Web UI
          • power off - OK, turned off alarm/player


          Jive - Control alarm test device from another player (SB Touch)
          • pause - Same behaviour as default Web UI
          • play something else - Same behaviour as default Web UI
          • power off - OK, turned off alarm/player


          Ran same tests from Web UI LMS 8.2.1
          • pause - OK, turned off alarm/player
          • play something else - Same behaviour as default Web UI
          • power off - OK, turned off alarm/player


          So it looks like the behaviour of pressing pause, whilst alarm is on, from a remote control device has changed.

          Kev
          What was the old behaviour after pressing pause?

          Sent from my Pixel 3a using Tapatalk
          Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
          Bedroom: Radio
          Bathroom: Radio

          Comment


            Originally posted by mherger View Post
            > So it looks like the behaviour of pressing pause from a remote control
            > device has changed.


            But the change would be in 8.3.0, too?
            Not sure, I'd have to roll back and re-test... only compared it to 8.2.1, bear with me. I'll retest under 8.3.0

            Kev

            Comment


              Originally posted by slartibartfast View Post
              What was the old behaviour after pressing pause?

              Sent from my Pixel 3a using Tapatalk
              Alarm paused/stopped player turned off, in my case back to clock screensaver.

              Same as pressing pause on player itself during alarm.

              Kev

              Comment


                Originally posted by KeBul View Post
                Alarm paused/stopped player turned off, in my case back to clock screensaver.

                Same as pressing pause on player itself during alarm.

                Kev
                Previously if I stopped playback in Material skin the fallback alarm would sound after 60 seconds. I haven't tried with the new build.

                Sent from my Pixel 3a using Tapatalk
                Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                Bedroom: Radio
                Bathroom: Radio

                Comment


                  Originally posted by slartibartfast View Post
                  Previously if I stopped playback in Material skin the fallback alarm would sound after 60 seconds. I haven't tried with the new build.

                  Sent from my Pixel 3a using Tapatalk
                  How do you stop playback?

                  Kev

                  Comment


                    Originally posted by KeBul View Post
                    How do you stop playback?

                    Kev
                    You can enable this in Material skin interface settings.
                    Transporter, Touch, SB3, SB2, Duet, Booms, Radios, piCorePlayer --- iPeng & Material --- LMS Version: 8.3.1 - 1668787267 on Pi4 4GB - Max2Play --- Qobuz

                    Comment


                      Originally posted by KeBul View Post
                      How do you stop playback?

                      Kev
                      If I pause now then the alarm screen continues to be displayed but I do not hear the fallback alarm after 60 seconds. If I stop playback with the optional Stop button then I get my clock screensaver and the alarm screen disappears. This is definitely different to previous behaviour and I wonder if the fallback alarm will fire if required.

                      Sent from my Pixel 3a using Tapatalk
                      Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                      Bedroom: Radio
                      Bathroom: Radio

                      Comment


                        Alarm not working with 8.3?

                        > If I pause now then the alarm screen continues to be displayed but I do
                        > not hear the fallback alarm after 60 seconds. If I stop playback with
                        > the optional Stop button then I get my clock screensaver and the alarm
                        > screen disappears. This is definitely different to previous behaviour
                        > and I wonder if the fallback alarm will fire if required.


                        Could you please confirm behaviour in v8.3.0? I'd like to understand
                        whether this is a side-effect of the recent change to Alarm, or
                        something introduced in 8.3.0 (there was a change around pause/stop
                        behaviour).
                        Michael

                        "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
                        (LMS: Settings/Information)

                        Comment


                          I tested the fallback alarm by restarting the server after the alarm was triggered and it does sound after 60 seconds. Having decided the fallback alarm should sound if the playback is paused from Material skin I tried again and the fallback alarm did sound but after 120 seconds. Maybe this new behaviour is actually preferred, after all when I first tried stopping the alarm from Material I was surprised to hear the fallback alarm.

                          Sent from my Pixel 3a using Tapatalk
                          Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                          Bedroom: Radio
                          Bathroom: Radio

                          Comment


                            Originally posted by mherger View Post
                            > If I pause now then the alarm screen continues to be displayed but I do
                            > not hear the fallback alarm after 60 seconds. If I stop playback with
                            > the optional Stop button then I get my clock screensaver and the alarm
                            > screen disappears. This is definitely different to previous behaviour
                            > and I wonder if the fallback alarm will fire if required.


                            Could you please confirm behaviour in v8.3.0? I'd like to understand
                            whether this is a side-effect of the recent change to Alarm, or
                            something introduced in 8.3.0 (there was a change around pause/stop
                            behaviour).
                            My tests were all on 8.3/8.4.
                            Before the latest changes, pressing Stop in Material Skin would leave the alarm screen active and the fallback alarm would sound after 60 seconds.
                            After the latest changes, pressing Stop in Material Skin cancels the alarm.
                            I didn't try pressing pause in Material before the changes but now the fallback alarm sounds after 120 seconds.
                            Bear in mind I didn't have the alarm issue before the changes.

                            Sent from my Pixel 3a using Tapatalk
                            Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                            Bedroom: Radio
                            Bathroom: Radio

                            Comment


                              Originally posted by slartibartfast View Post
                              My tests were all on 8.3/8.4.
                              Before the latest changes, pressing Stop in Material Skin would leave the alarm screen active and the fallback alarm would sound after 60 seconds.
                              After the latest changes, pressing Stop in Material Skin cancels the alarm.
                              I didn't try pressing pause in Material before the changes but now the fallback alarm sounds after 120 seconds.
                              Bear in mind I didn't have the alarm issue before the changes.

                              Sent from my Pixel 3a using Tapatalk
                              You asked me to try this a week ago and it did cancel the alarm, I couldn’t get the fallback. So at least the behaviour was already like this on 8.3.1 before the Alarm fix was applied
                              Transporter, Touch, SB3, SB2, Duet, Booms, Radios, piCorePlayer --- iPeng & Material --- LMS Version: 8.3.1 - 1668787267 on Pi4 4GB - Max2Play --- Qobuz

                              Comment


                                Originally posted by didjean View Post
                                You asked me to try this a week ago and it did cancel the alarm, I couldn’t get the fallback. So at least the behaviour was already like this on 8.3.1 before the Alarm fix was applied
                                For you but not for me.

                                Sent from my Pixel 3a using Tapatalk
                                Living Room: Touch or Squeezelite (Pi3B) > Topping E30 > Audiolab 8000A > Monitor Audio S5 + BK200-XLS DF
                                Bedroom: Radio
                                Bathroom: Radio

                                Comment

                                Working...
                                X