PDA

View Full Version : Toto not showing up in artist list



zune01
2013-08-26, 22:43
I have a very weird issue with my Squeezebox setup. I cannot find Toto in the artist list. They are available if I do a find (and is found as an artist), but they never show up in the alphabetical listing. iPeng behaves the same (I guess they use the same API to list though).
Apparently I've had this problem for a while, but I've always believed that a clear and rescan fixed it. Today (on 7.7.3) I tried it, and they are still missing...

Does anyone have any pointers on where I should look for the reason? COuld it be metadata glitches or something? Any pointers taken...

Cheers,
/Andreas

JJZolx
2013-08-26, 22:50
Yes. The most likely problem is that you have an ARTISTSORT field in the tagging of one or more of the files that is sending "Toto" to some place where you can't find it.

A good tagging program like Mp3tag (http://mp3tag.de/en) (assuming you use Windows) would help you figure it out.

zune01
2013-08-26, 23:16
I tagged it up with Picard a while ago, and it seems to have added ARTISTSORT ALBUMARTISTSORT etc, so I removed all but ARTIST with mp3tag and will rescan to see if it fixes it.

zune01
2013-08-27, 08:18
Very weird. Toto is still not showing up, and the interesting thing is that the individual albums aren't either! For example, I can search for "toto" and I do get a hit on the artist, but I don't get a hit on the album "Toto". But that might have to do that I removed ALBUMARTIST. I'll restore and try again...

tcutting
2013-08-27, 08:29
You might find this under "Various Artists" at the top of your Artists list? You may have the COMPILATION flag set?

JJZolx
2013-08-27, 12:47
That's a very good point.

But it doesn't necessarily take a COMPILATION tag to do this. If you have one or more tracks on any of those albums with a different ARTIST tag, then it will be detected as a compilation and appear with the other albums under Various Artists. With the default server settings, Toto would be seen only as a 'track' artist and would be kept out of the artist list.

There are several ways this could happen. One if you have a guest artist added as an additional artist on one of the tracks. Another is by having a track on an album sung by someone else, without Toto as an ARTIST. Or it could be caused by a typo, such as one track being tagged ARTIST=Totto.

The simplest way to fix this would be to add an ALBUMARTIST=Toto field to the albums. Alternatively, you could add a COMPILATION=0 field that would keep the album from being marked a compilation. You might want to review the ARTIST and ALBUMARTIST fields in these files, however, just to make sure they don't contain some kind of error.

el_chupacabra
2013-08-27, 16:01
Does it show up if you browse your music folder on the squeezebox ?
Any errors in the scanner logfile?

On 2013-08-27, at 1:43, zune01 <zune01.60pvnb (AT) no-mx (DOT) forums.slimdevices.com> wrote:

>
> I have a very weird issue with my Squeezebox setup. I cannot find Toto
> in the artist list. They are available if I do a find (and is found as
> an artist), but they never show up in the alphabetical listing. iPeng
> behaves the same (I guess they use the same API to list though).
> Apparently I've had this problem for a while, but I've always believed
> that a clear and rescan fixed it. Today (on 7.7.3) I tried it, and they
> are still missing...
>
> Does anyone have any pointers on where I should look for the reason?
> COuld it be metadata glitches or something? Any pointers taken...
>
> Cheers,
> /Andreas
>
>
> ------------------------------------------------------------------------
> zune01's Profile: http://forums.slimdevices.com/member.php?userid=35098
> View this thread: http://forums.slimdevices.com/showthread.php?t=99501
>
>

Julf
2013-08-28, 00:41
Alternatively, you could add a COMPILATION=0 field that would keep the album from being marked a compilation.

In my experience that doesn't work with LMS/Slimserver. COMPILATION=1 forces the album to be a compilation, but COMPILATION=0 does *not* force the album to not be a compilation. I would call it a bug.

d6jg
2013-08-28, 11:44
Some might consider Toto not appearing to be a bit of a bonus ;)

Seriously though I find AlbumArtist usually fixes this issue. Mp3tag will show you where the problem lies if you look hard enough.

Mnyb
2013-08-28, 12:29
If you have Toto on some best of or compilation check those files.

It only takes one misstaged toto file with an artistsort or similar done wrong to sort all of toto this way.

zune01
2013-08-31, 07:30
Thanks to all who answered! By removing all the ARTISTSORT etc tags, Toto is now back in my collection.