View Full Version : Player visible in iPeng, not in LMS, not connecting to server

2013-07-21, 13:56
Amongst several other players, I have a Receiver tucked away above my kitchen. Yesterday I was working on the electricity inside the house and therefor I cut the power on several groups. Now that the power is restored, the Receiver won't play anymore. It's not visible in the LMS web-admin either and when I use Squeezepad I don't see the player either.

When using iPeng however, I do see the player, but when I click it, a pop-up comes asking me to choose to which server I should connect it. And when I click on a server, it won't do that. Also using the controller, I can select the player, but then it starts searching for the server and can't find it.

When I cut the power to the Receiver the player disappears, when power is restored, it returns. So it actually sees the player, it's not a thing that is left in the cache or something. I've already restarted the server, rebooted the router, had a look on mysb.com to see if it was perhaps connected to there, but nothing seems to help.

Anyone care to make a suggestion as to what could be the problem here? Since it's tucked away in a cabin above my kitchen, it's rather hard to see what color the button is, so I'll use that as a last resort.

2013-07-21, 15:17
What you describe means iPeng shows the player under "unconnected players", right?

What this means is that the player has lost the connection to the server but is still present on the network.
The option in iPeng is to connect the player to a server again so that you can use it in a regular way. That's the same thing the controller does although the Controller can also do a more comprehensive setup.

Now, since your player is stowed away you probably can't see the color of the light on the Receiver so it's a bit hard to know whether it's in an appropriate state.

A few things you could try:
* power cycle the controller again and make sure the server is running while you do (if possible)
* is the server you are trying to connect to on the same network? Could you check the IP address

2013-07-22, 01:51
It's showing under unconnected players indeed. I also see it in my connected devices on the router, it gets an IP and is in the same network and IP-range as my server.

Tonight I'll try to power cycle the controller to see if that helps. Otherwise I guess there's no alternative than to open the cabinet and do a factory reset of the unit.

Thank you for your reply!

2013-07-22, 02:29
I'm sorry, that was an error. I did of course mean to power cycle the RECEIVER again, not the Controller!

2013-07-22, 02:46
Does it conect to mysqueezebox.com ,maybe try that ? And then try to conected back to the local server .

Btw do you have your mysqueezebox.com credentials entered into your local server and is the integration turned on ?
In that case players that are on mysqueezebox.com should be visible in the player tab of the web-UI and it should be possible to fetch them back that way .

Btw is it registered to your mysqueezebox.com account ? Is it new or used .

2013-07-22, 02:48
I've already power cycled that one a couple of times, with the server being on. Everytime the device disappears under "unconnected players" and comes back after a couple of minutes, apparently it has rebooted by that time. I've also disconnected the patch-cable from the receiver, rebooted the router, restarted the server with the Receiver being connected, etc.

Oh well, it has worked stable for half a year and it probably would have worked for a couple of years if I wouldn't have been cutting the electricity on all connected devices a couple of times.

2013-07-22, 04:45
I suspect that the IP address of your server has changed after the power outage and that's why it can't re-connect itself, I don't really know, though, why you can't manually connect it to a server, I suspect it gets stuck in the wrong state. I've had that with my Receiver, too, and the way to fix it, unfortunately, involved holding the button at the front.

The Receiver configuration has always been a bit hit-and-miss which is the reason I never actually implemented a full configuration in iPeng, I was just never sure it would reliably work.

2013-07-22, 05:03
Nope, the server is on a fixed IP. Ah well, at least I have some purpose for tonight. ;)