PDA

View Full Version : DirectIO.dll...???



the nightfly
2013-06-10, 08:46
I recently downloaded the latest version of SqueezePlay as well as SqueezeLite for Windows, and find that I can't get either to run because "DirectIO.dll is missing." Furthermore, my old install of an earlier version of SqueezePlay will no longer run, giving me the same error dialog.

Based on the name, I first thought DirectIO.dll was a DirectX file that had somehow gotten trashed, so I downloaded and reinstalled the latest DirectX runtime, to no avail -- not only do I still get the error, but the install apparently didn't include such a .dll. Googling the filename got me two different responses -- one, that it was a specific .dll from Avid for one of its programs (but, if so, how come two non-commercial programs like SqueezeLite and SqueezePlay require it?) and, two, a whole bunch of dodgy-sounding sites that offer to "fix the problem" if I only download and run their "free registry checker" (uh...no thanks!).

So, at the moment, I'm thoroughly confused and unable to stream to my PC. Any idea as to exactly what is going on here?

the nightfly
2013-06-10, 14:49
Anybody???

Apesbrain
2013-06-10, 15:27
FWIW, SqueezePlay runs on my Win7 PC and I don't have a DIRECTIO.DLL anywhere. I'm reaching a bit here, but did you ever set SqueezePlay to use the ASIO sound driver? It seems ASIO requires that DLL. You may want to read this thread (http://forums.slimdevices.com/showthread.php?96573-SqueezePlay-for-Windows-with-ASIO-DirectSound-WASAPI-and-WDMKS-device-support) and try to reset your configuration to use DirectSound.

the nightfly
2013-06-10, 20:07
I've never set it to anything, but I'll see what happens if I hard-code it to use DirectSound.

the nightfly
2013-06-10, 22:16
Interim result -- I finally got annoyed enough to simply uninstall SqueezePlay entirely and then re-install the beta from scratch. Good news: it no longer gives me the DirectIO error. Bad news: on my XP machine, it simply hangs after displaying the initial "Free Your Music" message. So, I wound up removing the beta and going back to the previous version, which does work once again...but, of course, won't handle Hi-Res. The saga continues...

ralphy
2013-06-11, 04:06
directio.dll is required by your audio driver not squeezelite or squeezeplay directly.

You can download an installer for it from http://port-access.sourceforge.net/

Download the MASM 32 Implementation->Setup Pack file which has a .pdf extension but is really an installer.

You just need to rename Masm32AppSP.pdf to Masm32AppSP.exe

the nightfly
2013-06-13, 01:15
O.K., I downloaded it and tried to install it, to no avail. The new SqueezePlay Beta and SqueezeLite both start up and promptly hang. I tried using regsvr32 to register the DLL, and was told I couldn't, as there was no entry point found. ???