PDA

View Full Version : WMA SOS



Dan Barahona
2004-11-20, 15:45
It seems I'm not the only person struggling with WMA files with the
Slimp3. I can successfully stream certain Internet radio stations
broadcasting in Windows Media. I've had no luck with .wma files on my
local machine. I've tried removing and re-adding the -x option in the
config.conf file, which made no difference in my case. I've run out of
ideas at this point. Is the Slimp3 just not compatible with Windows
Media? Am I better off upgrading to a Squeezebox?

Dan

------------------------------------

Thanks, that worked. Here's what I get when I run slim.exe from the
command line:

C:\Documents and Settings\Roberto D Barahona>"c:\program
files\slimserver\server
\slim.exe" --d_source
2004-11-20 09:19:47.5864 loading conversion config files...
2004-11-20 09:19:47.5910 input: 'mov' output: 'mp3' clienttype: '*':
clientid: '*': '[mov123] $FILE$ | [lame] --resample 44100 --silent -q 9
-b $BITRATE$ -r - -'
2004-11-20 09:19:47.5943 input: 'ogg' output: 'mp3' clienttype: '*':
clientid: '*': '[oggdec] -Q -o - -R $FILE$ | [lame] --resample 44100
--silent -b $BITRATE$ -r -x - -'
2004-11-20 09:19:47.5977 input: 'wav' output: 'mp3' clienttype: '*':
clientid: '*': '[lame] --resample 44100 --silent -q 9 -b $BITRATE$
$FILE$ -'
2004-11-20 09:19:47.6000 input: 'aif' output: 'mp3' clienttype: '*':
clientid: '*': '[lame] --resample 44100 --silent -q 9 -b $BITRATE$
$FILE$ -'
2004-11-20 09:19:47.6023 input: 'shn' output: 'mp3' clienttype: '*':
clientid: '*': '[shorten] -x $FILE$ - | [lame] --resample 44100
--silent -q 9 -b $BITRATE$ - -'
2004-11-20 09:19:47.6057 input: 'flc' output: 'mp3' clienttype: '*':
clientid: '*': '[flac] -dcs --skip=$START$ --until=$END$ $FILE$ |
[lame] --resample 44100 --silent -q 9 -b $BITRATE$ - -'
2004-11-20 09:19:47.6090 input: 'wma' output: 'mp3' clienttype: '*':
clientid: '*': '[wmadec] -r 44100 -b 16 -n 2 $FILE$ | [lame] -x
--resample 44100 --silent -q 9 -b $BITRATE$ - -'
2004-11-20 09:19:47.6124 input: 'mpc' output: 'mp3' clienttype: '*':
clientid: '*': '[mppdec] --raw-le --silent --prev --gain 3 $FILE$ - |
[lame] -x --resample 44100 --silent -q 9 -b $BITRATE$ - -'
2004-11-20 09:19:47.6158 input: 'mp3' output: 'mp3' clienttype: '*':
clientid: '*': '-'
2004-11-20 09:19:47.6180 input: 'aif' output: 'aif' clienttype: '*':
clientid: '*': '-'
2004-11-20 09:19:47.6203 input: 'wav' output: 'wav' clienttype: '*':
clientid: '*': '-'
2004-11-20 09:19:47.6226 input: 'shn' output: 'wav' clienttype: '*':
clientid: '*': '[shorten] -x $FILE$ -'
2004-11-20 09:19:47.6250 input: 'flc' output: 'wav' clienttype: '*':
clientid: '*': '[flac] -dcs --force-raw-format --endian=little
--sign=signed --skip=$START$ --until=$END$ $FILE$'
2004-11-20 09:19:47.6284 input: 'ogg' output: 'wav' clienttype: '*':
clientid: '*': '[oggdec] -Q -o - -R $FILE$'
2004-11-20 09:19:47.6306 input: 'wma' output: 'wav' clienttype: '*':
clientid: '*': '[wmadec] -r 44100 -b 16 -n 2 $FILE$'
2004-11-20 09:19:47.6330 input: 'mpc' output: 'wav' clienttype: '*':
clientid: '*': '[mppdec] --raw-le --silent --prev --gain 2 $FILE$ -'
2004-11-20 09:19:47.6354 input: 'mpc' output: 'aif' clienttype: '*':
clientid: '*': '[mppdec] --raw-be --silent --prev --gain 2 $FILE$ -'
2004-11-20 09:19:47.6379 input: 'mov' output: 'aif' clienttype: '*':
clientid: '*': '[mov123] $FILE$'
2004-11-20 09:19:47.6402 input: 'mp3' output: 'lame' clienttype: '*':
clientid:'*': '[lame] --resample 44100 --silent -b $BITRATE$ $FILE$ -'

----------------------------------------------

When I try to play the WMA file I get hundreds of messages a second.
Here's a sample:

2004-11-20 09:16:53.6228 00:04:20:03:02:bc: Switching to mode stop from
stop
2004-11-20 09:16:53.6242 Already in playmode stop : ignoring mode
change
2004-11-20 09:16:53.6255 **skipahead: opening next song
2004-11-20 09:16:53.6268 opening next song...
2004-11-20 09:16:53.6284 Backtrace:

frame 0: Slim::Player::Source::playmode
(/PerlApp/Slim/Player/Source.pm line 691)
frame 1: Slim::Player::Source::openNext
(/PerlApp/Slim/Player/Source.pm line 480)
frame 2: Slim::Player::Source::skipahead
(/PerlApp/Slim/Player/Source.pm line 462)
frame 3: Slim::Player::Source::underrun
(/PerlApp/Slim/Networking/Stream.pm line 343)
frame 4: Slim::Networking::Stream::gotAck
(/PerlApp/Slim/Networking/Protocol.pm line 64)
frame 5: Slim::Networking::Protocol::processMessage
(/PerlApp/Slim/Networking/Protocol.pm line 139)
frame 6: Slim::Networking::Protocol::readUDP
(/PerlApp/Slim/Networking/Select.pm line 119)
frame 7: Slim::Networking::Select::select (slimserver.pl line 455)
frame 8: main::idle (slimserver.pl line 398)
frame 9: main::main (slimserver.pl line 61)
frame 10: PerlSvc::Interactive (perlsvc line 1203)
frame 11: PerlSvc::_interactive (slimserver.pl line 0)
frame 12: (eval) (slimserver.pl line 0)

2004-11-20 09:16:53.6541 00:04:20:03:02:bc: Switching to mode
playout-stop from stop
2004-11-20 09:16:53.6566 00:04:20:03:02:bc New play mode: playout-stop
2004-11-20 09:16:53.6581 00:04:20:03:02:bc: Current playmode:
playout-stop
2004-11-20 09:16:53.6595 **skipahead: restarting after underrun
2004-11-20 09:16:53.6610 Backtrace:

frame 0: Slim::Player::Source::playmode
(/PerlApp/Slim/Player/Source.pm line 483)
frame 1: Slim::Player::Source::skipahead
(/PerlApp/Slim/Player/Source.pm line 462)
frame 2: Slim::Player::Source::underrun
(/PerlApp/Slim/Networking/Stream.pm line 343)
frame 3: Slim::Networking::Stream::gotAck
(/PerlApp/Slim/Networking/Protocol.pm line 64)
frame 4: Slim::Networking::Protocol::processMessage
(/PerlApp/Slim/Networking/Protocol.pm line 139)
frame 5: Slim::Networking::Protocol::readUDP
(/PerlApp/Slim/Networking/Select.pm line 119)
frame 6: Slim::Networking::Select::select (slimserver.pl line 455)
frame 7: main::idle (slimserver.pl line 398)
frame 8: main::main (slimserver.pl line 61)
frame 9: PerlSvc::Interactive (perlsvc line 1203)
frame 10: PerlSvc::_interactive (slimserver.pl line 0)
frame 11: (eval) (slimserver.pl line 0)





--------------------------------------------------
Howard Darwen hdarwen at btinternet.com
Sat Nov 20 17:10:41 PST 2004

slim.exe should be in task manager if it's running. alternative is to
go
start menu / run and type services.msc - that should give you a list of
all
services (running and not). you can also start and stop services from
there,
as well as set them to run/not run automatically on boot.

-----Original Message-----
From: discuss-bounces at lists.slimdevices.com
[mailto:discuss-bounces at lists.slimdevices.com]On Behalf Of Dan
Barahona
Sent: 20 November 2004 16:03
To: discuss at lists.slimdevices.com
Subject: [slim] WMA SOS


Thanks for the help. I used to think I was fairly technically
competent... I can't even get your cmd line advise to run. When I type
"c:\program files\slimserver\server\slim.exe" --d_source I get the
following message:

2004-11-20 07:57:54.0419 Problem: There is already another copy of the
SlimServer running on this machine. (Unknown error)

I've gone into Task Manager and I don't see any slim.exe processes
running. How do I stop the server?

Quoting Dan Barahona <rdbarahona at yahoo.com>:

> I've been desperately trying to get WMA to work on my Slimp3. I've
> upgraded to 5.4, installed lame.exe and lame_enc.dll, and now can
> listen to the WMA stream on www.kqed.org. However, I cannot play WMA
> files on my local machine (when I try to, the screen flickers very
> quickly and can only be stopped by clearing the playlist). Also, I
> can't seem to play this WMA stream:

screen? the player or your pc?

>
> http://varelasite.com.ar/jazzweb/envivo_domingo.wax

..wax is something else. files and streams are totally different.
>
> I've searched through the archives and can't find any guidance. Any
> help is MUCH appreciated. I'm running a Slimp3 on Slimserver 5.4 on
Win
> XP Pro, SP2.


start->run->
"c:\program files\slimserver\server\slim.exe" --d_source
press enter
try to play your wma files.
watch the output
read it carefully for clues
paste a relevant bit here if its not obvious to you.