PDA

View Full Version : Slimserver Issue/Imac



rp9197
2013-03-26, 10:25
I have a Transporter and a Squeezebox2 and three that I haven't used in many years. I absolutely loved them and they worked wonderfully until I downloaded 6.5 many moons ago. I got so fed up with the bugs, crashes etc. that I packed them away and switched to Sonos. After using Sonos for a while I ran into the dreaded 65,000 track limit that I didn't know even existed. I then had to shorten the tags on all of my classical files. This bought me a short period of time and I have been deleting music ever since! I have had a tremendous amount of music that I can't listen to for way too long now.

So I finally bit the bullet and downloaded Slimserver (version 7.7.2 I think) yesterday. I immediately encountered a problem which is how these things seem to go for me. My Imac shows the Icon in system preferences but a dummy box pops up that says:

To use the “Logitech Media Server” preferences pane, System Preferences must quit and reopen.

I then have to hit cancel or o.k. and that is all that it allows me to do which accomplishes absolutely nothing! I figured a restart was needed to get past this but this resulted in the same situation. Is there any other way to get the software to open other than system preferences? I did a hard drive search but all I see is the dmg file. It is just beyond shocking to me that the Squeezebox2 that I bought in 2006 worked just wonderfully streaming with it's Slimserver software. It was rock solid and this got me hooked on computer audio and it has been one issue after another ever since. I should also warn that I am very far from tech minded in these things. Many thanks for any help or info.

cjfreitag
2013-03-26, 12:47
Which version of the Mac OS are you running, and on what hardware (how old is the iMac)? I've been running LMS on an iMac with no problems for quite a while - currently I am using OSX 10.8 (Mountain Lion), but it worked fine with earlier versions.

What SHOULD happen is that when you click OK on the message that pops up it shows the LMS status window.

rp9197
2013-03-26, 13:41
Thanks for the response, I'm running 10.6.8. I'm not sure exactly how old it is. About this Mac tab shows Imac 9.1/Intel core 2 Duo/2.66ghz/4gb memory.

cjfreitag
2013-03-27, 06:07
OK, that helps. My first recommendation would be to uninstall and then reinstall Logitech Media Server. Instructions for doing that can be found here:
http://logitech-en-amr.custhelp.com/app/answers/detail/a_id/8380/session/L3RpbWUvMTM2NDM4OTQ0MC9zaWQvYzI0aExjbWw%3D

cjfreitag
2013-03-27, 06:12
Here is a link to a thread by someone who had a similar issue. You might find it useful as well.
http://forums.slimdevices.com/showthread.php?94136-LMS-system-preference-must-quit-and-reopen/page2

rp9197
2013-03-27, 16:25
Thanks for the link and information. I just checked the open in 32 bit mode and it is exactly the same. It's pretty ironic that I quit Slimserver for years because of bugs and now I immediately encounter another bug. I removed the icon from system preferences is that all that is needed to remove Slimserver from my computer? I really appreciate the help but I think that I'm just not cut out for this. I can't even put into words how depressing it is. This was a phenomenal product in 2007, it just worked! I had a laptop that wasn't even wired in and the stream was rock solid, never a single problem. I'd rather have no features than bugs but that is just my opinion. The fantastic people that take the time to help folks out on these forums always seemed like Slim/Logitech's best asset.

cjfreitag
2013-03-27, 19:46
To really remove the server completely you should follow the directions I pointed to in my first reply. However, I encourage you not to give up so soon. I don't think you are experiencing a bug, just an installation or configuration problem. There are too many people using this successfully with a Mac, and they are not all propeller heads.

Try doing the full uninstall and then install again...see what happens and report back.

danco
2013-03-28, 02:22
So what happens after System Preferences has quit and reopened?

You should then be able to open the LMS preference pane (I forget if that opens automatically, or whether you have to open it yourself) and do whatever you need to do. And, of course, once you have set it up properly, there is almost no need to go into System Preferences again.

This issue isn't a bug, it's a natural consequence of LMS being 32-bit running on a 64-bit system. At one point when this was discussed Logitech took the view that the issue was a small inconvenience only (which I agree with) and that though it would be nice to fix it the matter was low priority.

It has now been fixed, but only in 7.8, which can easily be obtained but doesn't have an official release.

rp9197
2013-03-28, 13:45
Success!! I deleted the application files per instructions and downloaded 7.8 (great tip!). Just played my first song without a hitch. It's been a very long time so I need to start reading up on what I've missed since 6.5 and how to operate things. I have my Slimserver tied to Itunes. I remember that you could also look through and play from another folder containing music files on your computer (not the Itunes library)? I thought I remembered seeing this as a scrolling option on the units themselves that you could pick instead of your library? Having this capability would be the key thing for my purposes right now. I'm thinking I could use the Transporter in my main room so i could play the 65,000 Sonos limit overflow.

I'm sure i will have more questions. Thanks again for taking the time to help me out.

cjfreitag
2013-03-28, 15:12
Yes, you can designate more than one music folder when you access the server using the web user interface. I have mine set to access the iTunes media folder as well as a second folder where I store purchased FLAC files. I do NOT check the "use iTunes" option and instead access the folder directly.