PDA

View Full Version : Must firmware match between squeezebox devices and squeezebox server?



bengaldave
2013-03-03, 17:27
Hello,

I have two servers running in my house, one running 7.7.2 and one running 7.8.

Does it matter if the squeezebox radio and squeezebox touch are running 7.7.2 or 7.8 firmware?

Does anyone know if there are any new features or updates to the firmware in 7.8?

What happens if I update the firmware on the devices to 7.8 and then keep the server running at 7.7.2?

If anyone wants to know why I am asking about this, my main squeezebox server, is a DS Synology 412+ box and the only version of the squeezebox server available is 7.7.2.

I can run the squeezebox server 7.8 on a mac, I am currently testing the performance of a bitrate limited stream from the squeezebox server to my iphone when I am driving around town.

It is much harder to install the needed software to enable bitrate limiting on the DS Synology DS412+.

toby10
2013-03-04, 04:21
The only common problem when running two different LMS versions is that the players will be prompted to update/downgrade their FW version as they switch between them.

jimbobvfr400
2013-03-04, 07:08
It's not a problem I've had but I do seem to recall there's a "trick" you can do by replacing the firmware files stored on your server?

Sent from my HTC Vision using Tapatalk 2

w3wilkes
2013-03-04, 09:35
I believe the "trick" is to replace the firmware versions in the "\Squeezebox\server\Firmware" directory so they match across your servers. The issue is the firmware for the Touch, Duet controller and the Radio is not stored there, I think it's downloaded from MySB.com to the device to match the server software. Only firmware for the Transporter, SB3, SB2 and I think the Duet receiver is stored on the server.

Mnyb
2013-03-04, 15:05
I believe the "trick" is to replace the firmware versions in the "\Squeezebox\server\Firmware" directory so they match across your servers. The issue is the firmware for the Touch, Duet controller and the Radio is not stored there, I think it's downloaded from MySB.com to the device to match the server software. Only firmware for the Transporter, SB3, SB2 and I think the Duet receiver is stored on the server.

The updates gets into the update folder in the cache folder . thats where you find the Touch Radio and Controller fw you go there put in the desired fw there and also the companion version file (or edit the current version file ) .
But you need to actually have one of these players to recieve these updates in the first place .

w3wilkes
2013-03-04, 19:50
@Mnyb, Thanks for that! So I'm guessing I could put whatever version for my Duet controller in the cache folder and then tell the server not to check for updates and all would be good?

Mnyb
2013-03-04, 19:58
@Mnyb, Thanks for that! So I'm guessing I could put whatever version for my Duet controller in the cache folder and then tell the server not to check for updates and all would be good?

Yes but ,try to upgrade first then turn of upgrades , I think LMS ignores all fw files if you turn of upgrades .

jimbobvfr400
2013-03-05, 02:39
Is there definitely different firmware for 7.7 and 7.8? I also believe you can cancel the firmware. Another factor after reading the op is that the mac running 7.8 is to be used for streaming to an iPhone so the firmware thing is not relevant for that at least, do you also want to connect your hardware players to this server or will you stick with 7.7 on the NAS for your hardware players.
I'm just thinking potentially this firmware issue might not even be an issue depending on your use.

Sent from my HTC Vision using Tapatalk 2

JackOfAll
2013-03-05, 05:25
Is there definitely different firmware for 7.7 and 7.8?

jive/fab4 versions are r16739 with 7.8.0, baby is r9663. All are version r9663 on the released 7.7.2.

w3wilkes
2013-03-05, 13:20
Yes but ,try to upgrade first then turn of upgrades , I think LMS ignores all fw files if you turn of upgrades .

Was wondering if it's just the server that ignores upgrades or does this also affect the receiver and controller. ie; receiver and controller might decide they need FW if the server has different versions even if the server itself is set to ignore updates?

Mnyb
2013-03-06, 00:14
Was wondering if it's just the server that ignores upgrades or does this also affect the receiver and controller. ie; receiver and controller might decide they need FW if the server has different versions even if the server itself is set to ignore updates?

It is the server that pushes upgrades to the players , the player is always happy as it is . Thats why you get that problem

w3wilkes
2013-03-06, 11:25
It is the server that pushes upgrades to the players , the player is always happy as it is . Thats why you get that problem

Thanks again! It's always good to learn some of these finer points.