PDA

View Full Version : RSS new crash



Robin Cooksey
2004-11-18, 15:26
Hi,

I've just updated to 5.4.0, and I've just tried the RSS News Ticker.
Whenever I try to use it (I tried "BBC News World Edition"), SlimServer
crashes with:

Undefined subroutine utf8::decode called at
/home/rbc/slim/local/slimserver/Plugins/RssNews.pm line 350

I'm using Debian 2.2, Perl version v5.6.1

I'm assuming utf8::decode is builtin in Perl 5.8. What about Perl 5.6.1?
Can this be made to work on Perl 5.6.1?


Cheers,
Robin

Robin Cooksey
2004-11-18, 15:43
Correction - I'm using Debian 3.0! Everything else is accurate though.

Cheers,
Robin

On Thu, 18 Nov 2004, Robin Cooksey wrote:

> Hi,
>
> I've just updated to 5.4.0, and I've just tried the RSS News Ticker. Whenever
> I try to use it (I tried "BBC News World Edition"), SlimServer crashes with:
>
> Undefined subroutine utf8::decode called at
> /home/rbc/slim/local/slimserver/Plugins/RssNews.pm line 350
>
> I'm using Debian 2.2, Perl version v5.6.1
>
> I'm assuming utf8::decode is builtin in Perl 5.8. What about Perl 5.6.1?
> Can this be made to work on Perl 5.6.1?
>
>
> Cheers,
> Robin
>
>
>