PDA

View Full Version : LMS can not sucessfully tune in internet radio



friendlyfire
2012-11-19, 10:19
Hello,
My stable LMS + Squeezebox system has suddenly developed an problem. I can no longer tune in any internet radio.

When I select an internet radio station on the Squeezebox it says connecting, and then about 20 seconds later says "stopped"
When I select an internet radio station on LMS it does seem to connect to the stream because the station logo comes up, but then it quits after a few moments.

I do not see anything useful in the server log file. In fact the messages seem positive:

[12-11-19 09:00:39.0284] Slim::Networking::Async::DNS::__ANON__ (105) Got DNS response 209.249.47.13 for opml.radiotime.com (ttl 25)
[12-11-19 09:07:59.0839] Slim::Networking::Async::DNS::__ANON__ (105) Got DNS response 38.100.101.65 for 4293.live.streamtheworld.com (ttl 300)
[12-11-19 09:07:59.2918] Slim::Networking::Async::DNS::cached (124) Using cached DNS response 38.100.101.65 for 4293.live.streamtheworld.com
[12-11-19 09:08:29.5915] Slim::Networking::Async::DNS::__ANON__ (105) Got DNS response 209.249.47.13 for opml.radiotime.com (ttl 170)

I have re-installed LMS.
I installed WinAmp on the server (it is a dedicated machine) and can tune various streaming URLs that cannot be tuned in with LMS.

I have disabled Firewall and ESET antivirus.

Server is running window XP.

I will try accessing internet radio directly from the Squeezbox through the MySqueezebox account (or whatever that is called) and post the result.

thanks for any advice...

toby10
2012-11-19, 10:50
Try turning off WinAmp, reboot LMS, see if it works.
Try LMS > Control Panel > Diagnostics, what is reported for ALL pings, ports, IP's?
Sure LMS > Settings > MySqueezeBox.com has correct login info? Any mention of "invalid"? Note: login password will correctly show as blank

friendlyfire
2012-11-19, 12:44
[QUOTE=toby10;726141]Try turning off WinAmp, reboot LMS, see if it works.
- I had rebooted LMS many times prior to installing WinAmp
Try LMS > Control Panel > Diagnostics, what is reported for ALL pings, ports, IP's?
- server ip, ping all okay. All ports report okay.
Sure LMS > Settings > MySqueezeBox.com has correct login info? Any mention of "invalid"? Note: login password will correctly show as blank[
- I entered my login info here. No change in behavior. I didn't think LMS needed MySqueezebox to tune in streams.

Also, I tried to access MySqueezeBox.Com directly from the unit and it comes back with "cannot find address for mysqueezebox.com".

Not sure if I mentioned that the squeezebox pulls local music with no problem from LMS. The problem is only with internet radio streams.

toby10
2012-11-19, 15:36
Which hardware player? Tried connecting player directly to MySB.com (no computer)?

friendlyfire
2012-11-19, 17:37
yes, as I noted I tried to connect my SB (classic) to mysqueezebox.com and it doesn't seem to know how to resolve the address.

toby10
2012-11-20, 05:19
Something is likely blocking the SB3 from seeing the internet. Try two things...

1. Reboot router, unplug it for 30 seconds, plug it back in. I presume you are using a router?
2. Factory Reset the SB3. Unplug power, press and hold down the add (+) button on the remote, plug power back in (whilst continuing to hold down the add button)

Now try connecting to MySB.com directly (forget LMS for now).

bernt
2012-11-20, 05:51
Had the exact same problem last week. My Boom worked fine with internet radio but not my SB3. Rebooted my router and everything went back to normal.

Mnyb
2012-11-20, 06:46
Had the exact same problem last week. My Boom worked fine with internet radio but not my SB3. Rebooted my router and everything went back to normal.

You are also from Sweden , do you have bahnhof as ISP ?, they had problems with their direct link to sverigesradio.se last week .

So these problems can have external reasons ,so always check if you can browse to mysqueezebox.com with the browser and do dthe same witht the radio provider and also use some service to figure out their ip and try some trace routes or ping ( but most servers don't answer pings these days ).

bernt
2012-11-20, 07:06
You are also from Sweden , do you have bahnhof as ISP ?, they had problems with their direct link to sverigesradio.se last week .

So these problems can have external reasons ,so always check if you can browse to mysqueezebox.com with the browser and do dthe same witht the radio provider and also use some service to figure out their ip and try some trace routes or ping ( but most servers don't answer pings these days ).

I have Telia. The strange thing was that I could play SR direct links on my Boom but the same link did not work on my SB3.