PDA

View Full Version : Using Mapped Drive as Music Folder



Bill Burns
2004-11-14, 10:14
I'm running Slimserver on one WinXP PC, and would like to point it to a
music library on a mapped drive (Z:) on another PC on the same LAN.

When I select either Z:\audio or \\server\audio as the Music Folder in
Server Settings, I get:

"Oops - "Z:\" doesn't seem to be a valid directory. Try again."
or
"Oops - "\\server\\audio" doesn't seem to be a valid directory. Try again."

I can browse to this folder with no problem, and play from it using
Winamp. Is this the way Slim is supposed to work? I'm running 5.4.0
latest nightly build.

--
Bill Burns
Long Island NY USA
mailto:billb (AT) ftldesign (DOT) com

Andrew Lee
2004-11-14, 11:50
Bill Burns wrote:

> I'm running Slimserver on one WinXP PC, and would like to point it to
> a music library on a mapped drive (Z:) on another PC on the same LAN.
>
> When I select either Z:\audio or \\server\audio as the Music Folder in
> Server Settings, I get:
>
> "Oops - "Z:\" doesn't seem to be a valid directory. Try again."
> or
> "Oops - "\\server\\audio" doesn't seem to be a valid directory. Try
> again."
>
> I can browse to this folder with no problem, and play from it using
> Winamp. Is this the way Slim is supposed to work? I'm running 5.4.0
> latest nightly build.

I guess that you are running SlimServer as a service under Windows. By
default services do not have permission to access network drives; see
the following FAQ entry for details of how to change the SlimServer
service logon details to be a user account with network access:

http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume

Best regards,


Andrew

--
Andrew Lee

Bill Burns
2004-11-14, 13:44
Andrew Lee wrote:

> I guess that you are running SlimServer as a service under Windows. By
> default services do not have permission to access network drives; see
> the following FAQ entry for details of how to change the SlimServer
> service logon details to be a user account with network access:
>
> http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume

Yes, I'm running as a service under WinXP. Thanks for the link - I
followed the directions in the FAQ and changed the SlimServer service to
use my XP user account. I had to add a password to the account to do
this, then was able to restart the service with no problem, but Server
Settings still rejected my network drive. Restarting the PC didn't help.

As a related but separate issue, I also tried setting the Music Library
and Playlist directories using Options -> Set Music Library Folder/Saved
Playlist Folder. This routine accepted the network drives without
complaining, and they then appeared on the Server Settings screen. But
clicking Change on this screen produced the same error message as
before. Is the non-validation of these settings in Options -> Set Music
Library a known bug?

--
Bill Burns
Long Island NY USA
mailto:billb (AT) ftldesign (DOT) com

Andrew Lee
2004-11-14, 16:34
Bill Burns wrote:

> Andrew Lee wrote:
>
>> I guess that you are running SlimServer as a service under Windows.
>> By default services do not have permission to access network drives;
>> see the following FAQ entry for details of how to change the
>> SlimServer service logon details to be a user account with network
>> access:
>>
>> http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume
>
> Yes, I'm running as a service under WinXP. Thanks for the link - I
> followed the directions in the FAQ and changed the SlimServer service
> to use my XP user account. I had to add a password to the account to
> do this, then was able to restart the service with no problem, but
> Server Settings still rejected my network drive. Restarting the PC
> didn't help.
>
> As a related but separate issue, I also tried setting the Music
> Library and Playlist directories using Options -> Set Music Library
> Folder/Saved Playlist Folder. This routine accepted the network
> drives without complaining, and they then appeared on the Server
> Settings screen. But clicking Change on this screen produced the same
> error message as before. Is the non-validation of these settings in
> Options -> Set Music Library a known bug?

The FAQ entry worked for me. I use a UNC path though rather than a drive
letter. If you haven't already, try using \\servername\share\path\
rather than X:\path\.

Hope this helps...

Best regards,


Andrew

Bill Burns
2004-11-14, 17:46
Andrew Lee wrote:
> Bill Burns wrote:
>
>> Andrew Lee wrote:
>>
>>> I guess that you are running SlimServer as a service under Windows.
>>> By default services do not have permission to access network drives;
>>> see the following FAQ entry for details of how to change the
>>> SlimServer service logon details to be a user account with network
>>> access:
>>>
>>> http://www.slimdevices.com/su_faq.html#troubleshooting-sharedvolume
>>
>>
>> Yes, I'm running as a service under WinXP. Thanks for the link - I
>> followed the directions in the FAQ and changed the SlimServer service
>> to use my XP user account. I had to add a password to the account to
>> do this, then was able to restart the service with no problem, but
>> Server Settings still rejected my network drive. Restarting the PC
>> didn't help.
>>
>> As a related but separate issue, I also tried setting the Music
>> Library and Playlist directories using Options -> Set Music Library
>> Folder/Saved Playlist Folder. This routine accepted the network
>> drives without complaining, and they then appeared on the Server
>> Settings screen. But clicking Change on this screen produced the same
>> error message as before. Is the non-validation of these settings in
>> Options -> Set Music Library a known bug?
>
>
> The FAQ entry worked for me. I use a UNC path though rather than a drive
> letter. If you haven't already, try using \\servername\share\path\
> rather than X:\path\.

The UNC path worked - thanks for your help.

As the FAQ does note that a drive letter may not work and UNC should
then be used, I now have one potential bug: Options -> Set Music Library
doesn't trap invalid paths. I've posted this to the bugtracker.

--
Bill Burns
Long Island NY USA
mailto:billb (AT) ftldesign (DOT) com

glmason
2005-06-01, 09:24
I hate to bring this topic up again as I see that it has been addressed a lot... but this is a new question I think...

I did all of the thing mentioned in posts and FAQ, I start the service from an my account, I set the slimserver to use a library by using UNC (\\myserver\medialibray) but when I start the service I don't get Web service to start correctly (or at all so it seems) and the softsqueeze that is on the same box as the server does not find the slimserver on the network. Is this normal?

Thanks Larry