PDA

View Full Version : Duet receiver can't connect to Music Libary



itm
2012-10-01, 05:16
My Duet Receiver dropped off my network a while ago and I can't get it to reconnect to my LMS music server (running LMS v7.7.2). So far I have done the following:
- Factory reset the Duet Controller
- Factory reset the Duet Receiver
- Reconnected the Controller to my wireless network
- Attempted to configure the Duet Receiver in both hybrid and wireless modes (neither worked)

The Controller connects to the wireless network correctly, and lists the Duet Receiver, but when I select the Duet Receiver and attempt to connect it to my music library on the LMS server it fails. This happens when I use ethernet mode or wireless mode.

I've tried several factory resets of both the Controller and Receiver, but can't connect the Receiver to my LMS music server.

I have 3 other Squeezebox clients on the network and all of these are working fine (2 Squeezebox booms - connected wirelessly - and a media centre PC connected via ethernet).

Can anyone suggest a way of diagnosing the problem with the Duet Receiver?

w3wilkes
2012-10-01, 10:07
Are you sure you're getting the factory reset on the receiver? There are 2 resets, the first is just a network reset which I've found to be next to useless. To do the full factory reset on the receiver you must press and hold the front button on the receiver for about 20 - 30 seconds. You should notice the LED go to a fast red blink while you're holding the button and when you release it the LED should go to a solid red. You can tell that it has been fully factory reset from the controller when you go to select player, the receiver should be seen by it's MAC address rather than the name you gave it. I've had my best luck by doing a factory reset on both the receiver and controller. I did have a issue one time where the receiver wouldn't go any further than blue LED (got IP from router, but refused to connect to my Squeezebox server). When than happened I ended up having to use Net::UDAP to put my server IP and name in the receiver. I documented that over in the Duet section of the board.

itm
2012-10-01, 10:32
Are you sure you're getting the factory reset on the receiver? There are 2 resets, the first is just a network reset which I've found to be next to useless. To do the full factory reset on the receiver you must press and hold the front button on the receiver for about 20 - 30 seconds. You should notice the LED go to a fast red blink while you're holding the button and when you release it the LED should go to a solid red. You can tell that it has been fully factory reset from the controller when you go to select player, the receiver should be seen by it's MAC address rather than the name you gave it. I've had my best luck by doing a factory reset on both the receiver and controller. I did have a issue one time where the receiver wouldn't go any further than blue LED (got IP from router, but refused to connect to my Squeezebox server). When than happened I ended up having to use Net::UDAP to put my server IP and name in the receiver. I documented that over in the Duet section of the board.

Yes it was a full reset on the receiver - I waited for red flashing LED changing to rapid red flashing LED. The controller listed the receiver by its MAC address, rather than by its previously assigned name.

HeadBanger
2012-10-01, 11:27
I had this recently and a full reset of my router solved the issue. Fortunately I had exported configuration settings so it was a simple reset and upload of config.