PDA

View Full Version : Need help getting Logitech Media Server 7.7.2 to work on GoFlex Home.



maihoaomv
2012-06-26, 19:09
I have a couple questions concerning LMS on the GoFlex Home server running ArchLinux ARM. I had to reload the alarm OS because I couldn't login after I tried to upgrade with pacman. I installed the latest version of alarm (kernel 3.1.10-11-ARCH) but LMS 7.7.1 wouldn't install because perl dependencies need to be < 5.15.

I played around with the .PKGINFO inside the .xz file and after changing the perl dependencies to < 5.17 I was able to get it to install LMS 7.7.1. But when I try to start the daemon it fails with the follwoing error message:

$ /etc/rc.d/logitechmediaserver start
:: Starting logitechmediaserver daemon [BUSY] Can't locate Slim/bootstrap.pm in @INC (@INC contains: /opt/logitechmediaserver /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at ./slimserver.pl line 137.
BEGIN failed--compilation aborted at ./slimserver.pl line 137.
[FAIL]
$


And when I try to start it as root I get this error message instead:

$ sudo /etc/rc.d/logitechmediaserver start
Password:
:: Starting logitechmediaserver daemon [BUSY] The following modules failed to load: EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name


*******

NOTE:

If you're running some unsupported Linux/Unix platform, please use the buildme.sh
script located here:



If 7.6 is outdated by the time you read this, Replace "7.6" with the major version
You should never need to do this if you're on Windows or Mac OSX. If the installers
don't work for you, ask for help and/or report a bug.

of Logitech Media Server you are running.

*******


Exiting..
[DONE]
$
***************************************** END OF ERROR OUTPUT **************************************************

I don't understand why the modules are not being loaded. So I'm stuck. Anyone got any suggestions on how I can get this to work?

I tried to build the package for 7.7.2 but it failed to successively compile. I tried to downgrade perl to 5.14 but was unable to find the .xz package. I also tried to build perl-5.14 from source but couldn't do that either.

I can't find a LMS 7.7.2 pre-compiled package for arm on the internet either. Has anyone succeeded in building a package for LogitechMediaSever 7.7.2 that will run on the GoFlex Home?

I can live with LMS 7.7.1 if only I could get it to run.
thanks
John