T. J. Angstman
2004-11-01, 15:44
Oddly, when I deinstalled the port and deleted any left behind configuration
files, I was able to simply copy 10/31 nightly /slimserver directory (after
removing CPAN/arch) into the /usr/local/ directory and it worked. I am
going to stick with this version for now rather than experiment further. I
have decided it is not *THAT MUCH* work to extract the new files and move
them to the place they belong. I do like your idea to keep the config files
somewhere else so I don't have to save them each time I upgrade.

I also wanted to use your start and stop script in rc.d, but I have had to
replace it with my own crude one that simply starts the server up on

/usr/local/slimserver/slimserver.pl --daemon

This won't stop the server for me, but I seldom want to turn slimserver off.
When the freebsd 5.4 port is released, I will try to upgrade and start using
the port. Until then, I will use this nightly.


T. J. Angstman

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Brooks Davis
Sent: Monday, November 01, 2004 2:21 PM
To: Slim Devices Discussion

On Mon, Nov 01, 2004 at 10:21:21AM -0700, T. J. Angstman wrote:
> > I'm sorry to hear it does not work for you, it works here. I can't do
> > anything to help you if you don't provide a bug report with some content
> > in it.
> My previous post's subject did not identify the Freebsd Port. Sorry for
> linking this up. I want to track the released port for ease of upgrading,
> but everything is working now with the 10/31 nightly. I had previously
> posted the following information:
> I installed a new FreeBSD server (5.2.1). Rather than download from
> website, I installed the FreeBSD port which installed perfectly without
> error. I decided to simply use the FreeBSD port and track the released
> versions rather than track the nightly upgrades, as I have done in the
> The version in the FreeBSD ports collection is 5.3.1.
> The server is up and running and can play Shoutcast streams by using my
> remote. When connecting via a browser, I just get a blank html screen, the
> source of the page served up looks like this:
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <META http-equiv=Content-Type content="text/html;
> charset=windows-1252"></HEAD>
> Using the KDE browser I get the little slimserver icon in the address bar,
> so I know it is connecting to the server. Obviously I cannot set any of
> options, as nothing appears to configure.

Hmm, this is weird. My guess would be a problem with the template
library. You might try running "make depends" in
/usr/ports/audio/slimserver. I've seen cases where portupgrade fails
to install dependences of upgraded ports and we grew several more in the
last update.

-- Brooks