PDA

View Full Version : Browser Interface Hosed



Dogberry2
2012-03-18, 10:43
I switched the LMS browser to the "basic" interface, and now the Settings screen comes up blank. This means that not only can I not control LMS through the browser, I also can't switch back to the default interface.

Can anybody tell me where the LMS browser interface HTML files are stored? I can probably jimmy things back to working order if I can find out where the files are. This is on a Linux system.

Thanks.

JJZolx
2012-03-18, 10:53
Do you mean the "Classic" interface?

It's highly unlikely that the files are corrupted. That just doesn't happen very often. More likely a cache problem in your browser. Try <Shift><F5> to clear the browser cache and reload the interface. Or, it could be a browser incompatibility with the interface. Classic doesn't get tested much any more.

Dogberry2
2012-03-18, 11:00
Do you mean the "Classic" interface?

It's highly unlikely that the files are corrupted. That just doesn't happen very often. More likely a cache problem in your browser. Try <Shift><F5> to clear the browser cache and reload the interface. Or, it could be a browser incompatibility with the interface. Classic doesn't get tested much any more.

Thanks, but no, it isn't a cache problem. Tried that, and also logged into a separate computer that hadn't been into the settings at all. When I said "basic" what I meant was the "Light" interface. I was curious to see what it looked like. I found out.

This is LMS 7.7.1, by the way. Shoulda said that in my OP.

Mnyb
2012-03-18, 11:14
just http://192.168.1.5:9000/default/ but change the ip to your own .

You can do that with all interfaces.

/classic
/default

And some more ( some are removed since 7.5 like fishbone )

JJZolx
2012-03-18, 11:17
The HTML (template) files can be found at

<installation directory>/server/HTML

I don't see a 'Light'. I'm guessing it must be 'EN'.

You can bring up the other web interfaces by name, even if you can no longer switch to them because the browser interface doesn't work. To get to Default, use something like

http://192.168.1.4:9000/Default

Dogberry2
2012-03-18, 11:25
Thanks again, JJ, but that still doesn't get me into the Settings screen. And the files in the HTML directory don't seem to have the Settings index.html file either, though I'm still poking through the HTML itself. I'm also running some find and grep commands to try and find something that way.

JJZolx
2012-03-18, 11:31
???

Are you saying that you can't press the 'Settings' link in the bottom right corner of the Default interface to get to the Settings page? It should open up another window that uses the same Default interface. From there you should be able to reset the web interface. If /Default doesn't work, try /Classic.

Dogberry2
2012-03-18, 11:31
Got it fixed.

Thanks to JJZolx and Mnyb for the clues that helped me get there.

I got into the Classic interface, and in the left-hand panel there's a "server settings" link that brings up the server settings in just that panel (using Classic interface). That let me reset back to the Default, and all is well again now.

Thanks again for the quick help.