PDA

View Full Version : After a while, SB Server stops responding and only 'safe' mode works



robotron2
2012-01-22, 15:14
I have been having this problem for quite a while, and it's been going on across recent SB server releases.

I start with a fresh install of SB server and everything works fine for a while. Eventually, the web client will simply stop responding, even though the SB server monitoring panel says that it's active. I click on 'stop server' and then 'start server," and while the server restarts, I still can't get the web client to respond.

The only thing that seems to work -- other than erasing the entire preferences and library file and then restrating -- is starting the server in 'safe' mode. Of course, in that case I'm just limited to using my local library and can't use any of the apps, so this is not a great solution. And erasing the cache and preferences isn't great either, because it takes a while to rebuild the library.

Does anyone have thoughts or ideas as to what might be causing this? (Admittedly, I've been a SB user since 2004 and I can't really remember a time when it's worked perfectly...it seems like there's 'always someting,' although right now this is the only problem I can identify.)

robotron2
2012-01-22, 15:15
None of my SB client devices see the SB server when it doesn't work either -- ie the problem isn't just the web client, it's seeing/playing any music at all.

pski
2012-01-22, 15:28
Maybe you could include a few details

robotron2
2012-01-22, 15:55
Here is yesterday's log (with a bunch of errors). Then I rebooted without plugins, and things started working. Today I restarted with plugins and things seem to work again

Mnyb
2012-01-22, 21:22
the weird ones is the to many open files errors and the can't save prefs.file ?

And it has problems with the current playlist on some of your players ?

Try 7.7.2

Ofload unused plugins ? You really play slimtris :)

Another way beside safe mode is to disable all third party plugins and see if it is better.
And then reintroduce those one at the time untill it breaks ?

robotron2
2012-01-22, 21:54
Thanks. I just tried disabling plugins...seems to help at first. Now I'm getting a spotifyd.exe crash in a neverending loop (presumably driven by the spotify plug in...but unfortunately I USE that one). Very frustrating! Oh how I wish this thing were stable by now :(

I will try your other suggestions.

robotron2
2012-01-23, 12:55
It seems like amongst other things, the 3rd party spotify plug in is causing problems. I posted a message in that forum to see if someone can help.