PDA

View Full Version : empty itunes playlists continued



SF Tron
2004-10-19, 22:41
OK. I'm beating myself up trying to get my iTunes playlists to show.
If anyone can help, I'd greatly appreciate it.

*all of this is running on the same Windows XP machine SP2.

Start off with an empty I tunes library.
Fresh install of SlimServer nightly build 10/17

iTunes creates its music folder under
C:\Documents and Settings\tron\My Documents\My Music\iTunes

I have a mapped folder 'Z:\' that I've previously created.

This folder contains all of my music. I then add this *mapped* folder to iTunes.

iTunes picks up the music without a problem. I can create playlists
without a problem.

The problem occurs when I try to view these playlists under
SlimServer. They *always* show up as empty. If on the other hand I
add playlists that reference files that are not part of that mapped
folder, than these playlists do show up.

Can anyone offer any advice?

Thanks,

Allen

PS. the mapped Z: drive actually just references a shared folder
(C:/My Music) on the same computer.

SF Tron
2004-10-21, 08:57
For anyone that may have this problem, finally my iTunes playlists
appeared after wiping the cache a few times and waiting till the
import/crawl of my .xml file was complete.

The first time it did not work though. I watched the debug output and
it seemed like it was not properly iterating through the songs in my
iTunes .xml file. Maybe this had something to do with it. Anyway,
just happy to have my playlists back now, but not completely sure why
it wasn't working before.

A few troubleshooting tips if this happens to you.

-Backup your iTunes.xml file.
-Next create a really small iTunes database that includes just a few
albums and a few playlists.
-Then wipe your cache in the SlimServer. This should trigger a re-crawl.
-Check/TurnOn the 'itunes' debug output under the 'debugging' section
of the SlimServer and watch to make sure everything is happening
properly.

IMHO it's a lot easier to work with a smaller iTunes database then
wait a few hours for your 10K plus songs to be imported.

Cheers,

Allen







On Tue, 19 Oct 2004 22:41:59 -0700, SF Tron <sftron (AT) gmail (DOT) com> wrote:
> OK. I'm beating myself up trying to get my iTunes playlists to show.
> If anyone can help, I'd greatly appreciate it.
>
> *all of this is running on the same Windows XP machine SP2.
>
> Start off with an empty I tunes library.
> Fresh install of SlimServer nightly build 10/17
>
> iTunes creates its music folder under
> C:\Documents and Settings\tron\My Documents\My Music\iTunes
>
> I have a mapped folder 'Z:\' that I've previously created.
>
> This folder contains all of my music. I then add this *mapped* folder to iTunes.
>
> iTunes picks up the music without a problem. I can create playlists
> without a problem.
>
> The problem occurs when I try to view these playlists under
> SlimServer. They *always* show up as empty. If on the other hand I
> add playlists that reference files that are not part of that mapped
> folder, than these playlists do show up.
>
> Can anyone offer any advice?
>
> Thanks,
>
> Allen
>
> PS. the mapped Z: drive actually just references a shared folder
> (C:/My Music) on the same computer.
>