PDA

View Full Version : L/R Swap when streaming PCM



Triode
2004-10-19, 11:05
Hi everyone, does anyone have any comment on my previous message (below).
Will the new firmware help (looking at the CVS comments seems to claim to
clear streaming on reboot?). Just wanted to check before I downloaded it.

Adrian

> I noticed that the L/R channels were swapped today for the first time in a
> while. As I only stream flacs this was annoying as I couldn't find an mp3
> to reset it!
>
> I then discovered that I could repeat it (randomly) if I left a track
> playing and then broke the connection from server to client. If I power
> off the client mid track, the server blocks, but seems to leave the
> decoding app (flac in my case) mid track ready to start up again. If I
> then broke the connection from client to server (test case was by
> rebooting the squeezebox), when the track is unpaused it continues, but at
> random left/right status.
>
> It seems to me that its probably best to stop the track playback when the
> power off button it pressed, kill the decoding app (e.g. flac) etc and
> flush out any pcm samples in the path from server to client?
>
> If this is not the only cause of swapped channels, would be it possible to
> create a simple option to reset the pcm firmware and flush the stream of
> samples without needing to find an mp3 file?
>
> Server is running recent nightly (15th I think), client latest firmware.
>

Michel Fombellida
2004-10-19, 11:20
This issue is known for quite a long time. I don't think the new firmware will
help. Sean mentioned a while ago that it could perhaps be related to the code
initialising their DSP and to fix it he needed the support from their supplier.
This fix should also solve another issue I reported (bug 416) and this one is
clearly still present with FW40.

Michel

seanadams
2004-10-19, 12:13
Triode,

The bug is triggered intermittently when switching from mp3 into PCM
mode. It affects the digital outs, but the analog outs are fine. Once
in PCM mode the channels will stay fixed. There are a few workarounds
for this, but not a proper fix yet.

Worakrounds:

- use analog outs instead

or

- make sure all of your music is non-mp3 format - AIFF, FLAC etc. This
will eliminate the format changing on the client, which triggers this.
If the channels come up swapped, do a soft reset. Once they're correct,
they stay locked.

or

- add a line in convert.conf to decode MP3 files on the server. Someone
posted the syntax for this a while back... this is another way to get
everything to play only in PCM format.

or

- change format settings to make everything play in mp3 format


On Oct 19, 2004, at 11:05 AM, Triode wrote:

> Hi everyone, does anyone have any comment on my previous message
> (below). Will the new firmware help (looking at the CVS comments seems
> to claim to clear streaming on reboot?). Just wanted to check before
> I downloaded it.
>
> Adrian
>
>> I noticed that the L/R channels were swapped today for the first time
>> in a while. As I only stream flacs this was annoying as I couldn't
>> find an mp3 to reset it!
>>
>> I then discovered that I could repeat it (randomly) if I left a track
>> playing and then broke the connection from server to client. If I
>> power off the client mid track, the server blocks, but seems to leave
>> the decoding app (flac in my case) mid track ready to start up again.
>> If I then broke the connection from client to server (test case was
>> by rebooting the squeezebox), when the track is unpaused it
>> continues, but at random left/right status.
>>
>> It seems to me that its probably best to stop the track playback when
>> the power off button it pressed, kill the decoding app (e.g. flac)
>> etc and flush out any pcm samples in the path from server to client?
>>
>> If this is not the only cause of swapped channels, would be it
>> possible to create a simple option to reset the pcm firmware and
>> flush the stream of samples without needing to find an mp3 file?
>>
>> Server is running recent nightly (15th I think), client latest
>> firmware.
>
>

kdf
2004-10-19, 12:29
Quoting Sean Adams <sadams (AT) slimdevices (DOT) com>:


> - add a line in convert.conf to decode MP3 files on the server. Someone
> posted the syntax for this a while back... this is another way to get
> everything to play only in PCM format.

maybe that line can be committed to cvs, but set as disabled by default for the
file types prefs?

I have the syntax at home in my copy so it wouldnt' be hard to merge that in.

-kdf

Mike Reeve
2004-10-19, 13:28
Sean Adams <sadams@...> writes:

> ... but not a proper fix yet.

Sean

Any ETA yet on a 'proper fix' ...?

Regards

Mike