PDA

View Full Version : Help, can't find My Music!



mikael_b
2011-12-22, 09:26
Today, suddenly, I lost the content in My Music, all my Squeezeboxes just say "Empty" when I try to play locally stored music.
I'm running 7.7.1, 9558 on Touch and r9557 on my Radios r33750 on LMS.
Tried rescan, restart but no luck. Anyone with an idea??

Mikael

aubuti
2011-12-22, 09:31
Can you get the LMS web interface when you point your browser to http://<server_ip>:9000/? Of course, substitute your server's real IP address in place of <server_ip>.

mikael_b
2011-12-22, 09:34
Yes, no (such) problem.

M

mikael_b
2011-12-22, 09:34
[11-12-22 17:17:04.4890] main::main (200) Starting Logitech Media Server scanner (v7.7.1, r33750, Mon Dec 12 09:42:47 PST 2011) perl 5.014001
[11-12-22 17:17:16.8289] Slim::Music::Import::runImporter (485) Starting Slim::Media::MediaFolderScan scan
[11-12-22 17:17:16.8306] Slim::Utils::Scanner::Local::rescan (171) Discovering audio files in \\SERVER1\Users\Mikael.B\Mina dokument\My Music
[11-12-22 17:17:16.8413] Slim::Utils::Scanner::Local::__ANON__ (254) Removing deleted audio files (0)
[11-12-22 17:17:16.8423] Slim::Utils::Scanner::Local::__ANON__ (332) Scanning new audio files (0)
[11-12-22 17:17:16.8431] Slim::Utils::Scanner::Local::__ANON__ (410) Rescanning changed audio files (0)
[11-12-22 17:17:16.8443] Slim::Music::Import::endImporter (617) Completed Slim::Media::MediaFolderScan Scan in 0 seconds.
[11-12-22 17:17:16.9462] Slim::Music::Artwork::precacheAllArtwork (442) Starting precacheArtwork for 0 albums
[11-12-22 17:17:16.9473] Slim::Music::Import::endImporter (617) Completed precacheArtwork Scan in 0 seconds.
[11-12-22 17:17:17.0002] Slim::Music::Import::runScanPostProcessing (400) Starting Database optimization.
[11-12-22 17:17:17.0311] Slim::Music::Import::endImporter (617) Completed dbOptimize Scan in 0 seconds.

aubuti
2011-12-22, 09:45
Seems strange. Try changing the location where you point LMS to your music library. Change it to something wrong. Then rescan, change it back to the correct location, and rescan again.

If that doesn't work, try deleting your cache file.

Is the music on an external drive? What OS?

mikael_b
2011-12-22, 09:54
Will try that.
No luck, which Cache file do you mean?
My music is stored om a Win7 Enterprise Laptop i.e. internal harddisk.

Mikael

aubuti
2011-12-22, 10:07
I mean the LMS SQL database cache file. On Windows I believe there is an option in the system tray tool (or whatever it's called) to clear the cache.

If that doesn't work, you can find the location of the cache file by going to Settings > Information in the LMS web interface. Then stop LMS and go to that folder and delete the cache files. I can't tell you the filenames because I don't have LMS in front of me at the moment.

toby10
2011-12-22, 10:09
Right click the little LMS icon, select Control Panel > Advanced > Clear Cache > Run Cleanup

mikael_b
2011-12-22, 11:56
Ok, tried that, still no success...

Mikael

aubuti
2011-12-22, 12:09
This may be a red herring, but if the music is on an internal hard drive, why have you specified \\SERVER1\Users\Mikael.B\Mina dokument\My Music as the location of the music library?

What happens if you use the drive letter + pathname?

mikael_b
2011-12-22, 12:18
Short answer; because of the network at my office. But this has worked until today, and changing it didn't help, neither did reinstalling LMS.
Maybe shouls try 7.7.2??

Mikael

aubuti
2011-12-22, 12:32
Last stab: permissions?

mikael_b
2011-12-22, 12:49
Nope, checked and no changes since yesterday, and I can still stream Internet radio, spotify etc, afaict only the local music affected.

Mikael

hajbete
2011-12-31, 03:20
I have this problem as well, dont know what to do at all. The entire My Music option is gone. Please help!

verypsb
2011-12-31, 03:30
Did you try a "clear library & rescan everything"? Did you add the music folder to WMP? This can change permissions on the folder...

hajbete
2011-12-31, 04:39
Did you try a "clear library & rescan everything"? Did you add the music folder to WMP? This can change permissions on the folder...

Well no, but the thing is that the entire meny dropdown where I can choose "My Music" from is gone so I dont think itīll do me much good. I have considered that it might be a result of my squeezecenter (being installed locally) is being connected to "mysqueezebox" in some way. I dont see anywhere that that would be the case, but I found a setting thats called "Music Source" a bit down. And there are two choices, mysqueezebox or localsqueezebox. If try and choose localsqueezebox it tries to connect to some ip Iīve never seen and then it crashes. If I connect to the players with my squeezecenter controller and tell them to connect to my local music repo it starts playing music again. But I never get any option so go for anything but streaming services as "usual".

I have played around a bit with the Server software and installed different versions back and forth (been burnt a few times). Do you think that has anything to do with it?

noxiousdog
2012-04-01, 09:40
I have the same problem. I'm pretty sure it's related to LMS is no longer able to recognize "high" drive letters.

My music is on a music share mapped with "x:", and my playlists "z:".

When I go to settings->basic settings->media folders, I can see where I have manually written it in, but if I hit the browse button I cannot browse to those folders inside LMS. On the pc they come up just fine. (start run ->x:)

A further test (remapping to I:\) doesn't show either. I suspect it can't see any mapped network folders, but that doesn't make much sense.

I avoided doing a UNC path as with some symbolic links it wound up double browsing. If the mapped drive thing doesn't get fixed, (or workaround) I'll have to figure it out I guess.

Mnyb
2012-04-01, 09:46
i think you must use UNC path if have LMS startup as a service

noxiousdog
2012-04-01, 12:53
i think you must use UNC path if have LMS startup as a service

I didn't until the last update ;)