PDA

View Full Version : iTunes playlist can't be found on my QNAP nas



NasDonkey
2011-12-03, 03:19
Hi all,

I bought the squeezebox reciever last week. It took me a while to get it up and running. I finally used my friends remote of his duet and then it was working really quick.
But now it all works exept the playlists i use in iTunes.

What do i have/use?
- QNAP 239P nas system
- SBS 7.6.1 installed through QPKG
- iPad with Squeezepad
- iPhone with iPeng

All my music files are stored on the QMultimedia share in a iTunes folder. I can see the folders with artists names in this folder.
I can see al my music in Squeezepad and iPeng, so no problem there! At least i think...
I guess there must be something wrong with the export/import of the playlist. But i have no idea where to look to solve this annoying problem.
Any help is more than welcome!!

Regards, Don

NasDonkey
2012-01-18, 02:48
To bad nobody replied on my question.
I asume i am not the only one with this problem...

Regards,


Don

pski
2012-01-18, 16:52
Hi all,

I bought the squeezebox reciever last week. It took me a while to get it up and running. I finally used my friends remote of his duet and then it was working really quick.
But now it all works exept the playlists i use in iTunes.

What do i have/use?
- QNAP 239P nas system
- SBS 7.6.1 installed through QPKG
- iPad with Squeezepad
- iPhone with iPeng

All my music files are stored on the QMultimedia share in a iTunes folder. I can see the folders with artists names in this folder.
I can see al my music in Squeezepad and iPeng, so no problem there! At least i think...
I guess there must be something wrong with the export/import of the playlist. But i have no idea where to look to solve this annoying problem.
Any help is more than welcome!!

Regards, Don

Don,

I don't use iTunes except for my cd load. If you have all but playlists working, excellent.

I will add the iTunes plugin and see if I can help.

P

NasDonkey
2012-01-18, 23:54
Hi P,

Still no luck with the iTunes playlists for me. it keeps annoying me so much.
After hours and hours searching the net i still haven't found a solution.
Please let me know if you had any luck or problems.

Regards,


Don

Justme
2012-01-19, 03:51
I'm no expert here, so forgive me if I have misunderstood.

But, as I also discovered when I tried to export an iTunes playlist from my computer to the QNAP squeezebox server, the iTunes playlist is created with all files pointing to the music on my iTunes library, which in my case, was on my computer.

So, although the music the Squeezebox server uses on the QNAP mirrors my iMac in folder structure, the music locations don't exactly match so the playlist doesn't work.

It seems there is no easy work around if this is your situation. One thing you could do is to open the playlist in a file editor, and use a find/replace feature to change the root folders automatically. The other way would be to create a script to do this.

I hope this helps.

NasDonkey
2012-01-19, 11:14
Hi Justme,

Thanks for your story. This could be something that could solve this problem.
But to be honest, it's a little bit to much for me to handle.
Since i'm no expert in these things i have no option then to wait for a new version in which Logitech solves this issue. Which i hope they do...

Regards,


Don

Justme
2012-01-19, 11:23
Hi NasDonkey,

If the problem is what I described, I dear say we both may be in for a long wait. I would imagine it is neither the responsibility of QNAP nor Logitech to make iTunes Playlists that are copied from one device to another easier. I am in the same situation and I know others, so maybe a third party solution will come our way.

NasDonkey
2012-01-19, 11:27
If the problem is what I described, I dear say we both may be in for a long wait. I would imagine it is neither the responsibility of QNAP nor Logitech to make iTunes Playlists that are copied from one device to another easier. I am in the same situation and I know others, so maybe a third party solution will come our way.
Let's hope for the best! ;-)

Just to make things clear, the iTunes music and the exported file of my library are in the same folder on my QNAP nas.
So this means it should work. Should, could, will.... aaaaaaaaaargh!!!

Regards, Don