PDA

View Full Version : Endless "update" message



eschurr
2011-11-28, 18:46
I'm running Squeezebox Server on 64bit Windows 7. The icon in the system tray keeps telling me there is an upgrade. When I click on the icon and choose 'install update" it goes away but later returns to tell me there is an update. What gives?

I tried to find somewhere to manually download and install the latest version but Logitech makes it pretty hard to find the download option -- i never succeeded!

didjean
2011-11-29, 03:19
Latest version (7.7.0) of Squeezebox Server is there: http://www.mysqueezebox.com/download
It has been renamed Logitech Media Server.

w3wilkes
2011-11-29, 10:36
Yes, Logitech makes it extremely difficult to locate the download! However if you type "squeezebox download" as your search in Google you'd find that even with Logitech's best effort to hide the download that the very first link in the search results just happens to be the Logitech Squeezebox (LMS) download page.

eschurr
2011-11-29, 10:40
thanks. It won't be long before they rename LMS to something else, I suppose. I've had a Squeezebox for years and the server software seems to be the most renamed software I know of.

I'm using 7.6.1 and I gather it is trying to update itself to 7.7 but failing. Any idea why? Should I just do a manual install of 7.7?

w3wilkes
2011-11-29, 11:31
On windows there's a missing "C++" library that makes the autoupdate not work. You can manually download and install 7.7 and you should be good to go.

eschurr
2011-11-29, 12:28
wow. shocking. Is there some way to correct the situation so auto update works (Or maybe it's not worth it)?

mherger
2011-11-30, 01:00
> wow. shocking. Is there some way to correct the situation so auto
> update works (Or maybe it's not worth it)?

It should be fixed in 7.7.1.

--
Michael

bozer
2011-12-02, 14:24
This is driving me insane. Every day it needs to update. Every day I update it. Then its back over and over again. ARGGG

toby10
2011-12-03, 03:29
This is driving me insane. Every day it needs to update. Every day I update it. Then its back over and over again. ARGGG

The two most likely causes of such frequent updates:
1. running Beta server which will update every day (FIX: turn off updates or don't use Beta)
2. switching player(s) to both local LMS and MySB.com and your LMS is a different version than is MySB.com (FIX: don't switch between them, just use your local server)