View Full Version : Alienstream - buffering 0%

Patrick Delamere
2004-10-10, 15:48
4th time lucky in sending this mail........hopefully I will now send it
using my correct email, to the correct address and under 40k (I have deleted
most of my original email)!



From: Patrick Delamere [mailto:slimdevices (AT) delamerelocal (DOT) homeip.net]
Sent: 10 October 2004 15:52
To: 'Slim Devices Discussion'
Subject: [slim] Alienstream - buffering 0%

Hi Jules,

Thanks for your quick response! :-)

I am currently trying alienbbc_0.10 that you sent earlier. Currently it
appears to be having the same problems. I started "./alienstream

The odd thing is that it just sits at the following for a long time......

mrl: 'http://www.bbc.co.uk/radio2/realmedia/fmg2.rpm'

Connecting HTTP server... [0%]


Buffering... [0%]

Stream finished (Count = 1)

I suspect that eventually I will get the other messages that I sent earlier.

Having clicked on one of the BBC stream on the web interface, I now get the
following errors:

Message: read() on closed filehandle GEN7613338 at
/usr/lib/perl5/5.8.3/i586-linux-thread-multi/IO/Handle.pm line 431.

Lame has aborted. Cleaning up (waitpid returned: -1)

Closing Down

(this nessage is repeated over and over again, so in some king of loop by
the look of things)

Looks like you were right about LAME being the problem. The odd thing is
that I am already using LAME to convert my WMA's to MP3 format, so in
theory, the SlimServer is able to find LAME with no problems.......

I'd be very happy to try out your new release as you indicated in your email
below. :-)

I'll install the packages you talked about and then your new release. I
should be able to get mplayer from YAST, SuSE's package installation tool.
The w32codec shouldn't be a problem either.

Thanks again Jules! :-)



From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Jules Taplin
Sent: 10 October 2004 13:37
To: Slim Devices Discussion
Subject: [slim] Alienstream - buffering 0%

Hmmm. Ok Patrick... not quite sure what's going on there. The most likely
thing I can think of is that the script can't find 'lame' where it expects
it, so it's not managing to consume from the pipe.

However, at the risk of invalidating all the great work you've done there,
let's try this instead:

I've got a newer version of AlienBBC getting ready for release (it's being
held up by some features that I just don't have the energy to implement
right now *sigh*). It has the ability to use mplayer instead of alienstream,
which is actually rather better in nearly all circumstances.

Basically... you'll only need two external packages with this build:
'mplayer', and 'w32codec'. Both should be easily available (sorry - not a
SuSE user, so I don't know how your preferred package management works - I'm
an APT user myself, and they're trivial packages for that).

I'll send the new release to you off-list (not nice to dump binaries on them
*grin*) - give it a go... it really is rather superior (for starters, it
cuts stream startup time in roughly half!). It's also got better status
reporting (if you point your browser to http://localhost:5123/Status/ ,
it'll tell you rather more about what's going on - should let you know if it
can't find a helper, for example).

Let me know how you get on!

-- Jules

----- Original Message -----

From: Patrick Delamere

To: discuss (AT) lists (DOT) slimdevices.com

Sent: Sunday, October 10, 2004 12:55 PM

Subject: [slim] Alienstream - Buffering 0%


I have spent a long long time trying to get alienstream working with my
Squeezebox but so far now luck! I am running SlimServer 5.3.1 on SuSE Linux

Initially I had big problems just getting the plugin's .pm files to work
since they were missing all sorts of extra Perl libraries. I resolved that
by configuring Perl CPAN and downloading the Perl HTML::Parser and
HTTP:Daemon modules.

Since resolving the Perl issues and installing the latest software - the
following now seems to work:

- ./transcoder_proxy.pl (no Perl errors on startup).

- Slimserver no longer crashes when I try to access a Real audio
stream via the web interface (I still get no sound though..).

- Playing Real audio via XINE by calling 'xine
http://www.bbc.co.uk/radio2/realmedia/fmg2.rpm' from a terminal session.

- Connecting to http://xx.xx.xx.xx:5123/Status gives me the
"STATUS: OK" message.

- "perl -ICPAN -c Plugins/Alien/Plugin.pm" returns 'syntax OK'.

What still doesn't appear to work is as follows:

..rpm using Windows Media player or XMMS or Winamp (See error messages below
- from transcoder_proxy.pl)

- The same result occurs when clicking on one of the BBC streams in
the plugin's web interface.

- './alienstream
rtsp://rmv8.bbc.net.uk/radio4/archers/archers_friday.ra' also produces the
error messages shown below.

What you'll see in the log below is that for some reason, connecting to the
HTTP Server and Buffering always seems to remain at [0%]???