PDA

View Full Version : WMA->MP3 setting not sticky



Roy M. Silvernail
2004-06-02, 06:26
The File Type setting for WMA->MP3 doesn't persist between server
sessions. If I kill and restart, I have to go back and specifically
enable it again. Using CVS from yesterday.
--
Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
Never Forget: It's Only 1's and 0's!
SpamAssassin->procmail->/dev/null->bliss
http://www.rant-central.com

kdf
2004-06-03, 02:30
which conversion lines do you have in your convert.conf and/or
custom-convert.conf files?

I may have some idea why this is happening, but more info will help :)
-kdf

Quoting "Roy M. Silvernail" <roy (AT) rant-central (DOT) com>:

> The File Type setting for WMA->MP3 doesn't persist between server
> sessions. If I kill and restart, I have to go back and specifically
> enable it again. Using CVS from yesterday.
> --
> Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
> Never Forget: It's Only 1's and 0's!
> SpamAssassin->procmail->/dev/null->bliss
> http://www.rant-central.com
>
>

Roy M. Silvernail
2004-06-03, 04:16
On Thu, 2004-06-03 at 05:30, kdf wrote:
> which conversion lines do you have in your convert.conf and/or
> custom-convert.conf files?


I use slimserver-convert. Dunno if that has any effect. It has

wma mp3 * *
[ffmpeg] -v 0 -i $FILE$ -f wav - | [lame] --slient -b $BITRATE$
- -

wma wav squeezebox *
[ffmpeg] -v 0 -i $FILE$ -f wav -

No wmadec on this box.
--
Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
Never Forget: It's Only 1's and 0's!
SpamAssassin->procmail->/dev/null->bliss
http://www.rant-central.com

kdf
2004-06-04, 09:19
That's the problem. The server detects that wmadec isn't there and disabled the
setting on startup. The conversions don't quite support multiple binaries quite
as well as it should. My intent was to make the command table a hash of arrays.
I might be able to get this working next week.
-kdf

Quoting "Roy M. Silvernail" <roy (AT) rant-central (DOT) com>:

> On Thu, 2004-06-03 at 05:30, kdf wrote:
> > which conversion lines do you have in your convert.conf and/or
> > custom-convert.conf files?
>
>
> I use slimserver-convert. Dunno if that has any effect. It has
>
> wma mp3 * *
> [ffmpeg] -v 0 -i $FILE$ -f wav - | [lame] --slient -b $BITRATE$
> - -
>
> wma wav squeezebox *
> [ffmpeg] -v 0 -i $FILE$ -f wav -
>
> No wmadec on this box.
> --
> Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
> Never Forget: It's Only 1's and 0's!
> SpamAssassin->procmail->/dev/null->bliss
> http://www.rant-central.com
>
>

Roy M. Silvernail
2004-06-04, 11:02
kdf wrote:

> That's the problem. The server detects that wmadec isn't there and disabled the
> setting on startup. The conversions don't quite support multiple binaries quite
> as well as it should. My intent was to make the command table a hash of arrays.
> I might be able to get this working next week.

Or perhaps don't make the decision about binaries present/absent until
all the convert.conf-like files have been read. That way, the
slimserver-convert.conf entries would have already overwritten the
convert.conf entries and the server wouldn't have any need to even look
for wmadec.
--
Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
Never Forget: It's Only 1's and 0's!
SpamAssassin->procmail->/dev/null->bliss
http://www.rant-central.com

kdf
2004-06-05, 11:02
Quoting "Roy M. Silvernail" <roy (AT) rant-central (DOT) com>:

> kdf wrote:
>
> > That's the problem. The server detects that wmadec isn't there and
> disabled the
> > setting on startup. The conversions don't quite support multiple binaries
> quite
> > as well as it should. My intent was to make the command table a hash of
> arrays.
> > I might be able to get this working next week.
>
> Or perhaps don't make the decision about binaries present/absent until
> all the convert.conf-like files have been read. That way, the
> slimserver-convert.conf entries would have already overwritten the
> convert.conf entries and the server wouldn't have any need to even look
> for wmadec.

perhaps. both are not just simple rewrites and the hash of arrays has other
advantages, including eventually allowing users to choose which decoder to
enable if multiple are available. I'll see what I can do when I get a chance to
look it over.

-kdf

kdf
2004-06-08, 14:07
Quoting "Roy M. Silvernail" <roy (AT) rant-central (DOT) com>:

> kdf wrote:
>
> > That's the problem. The server detects that wmadec isn't there and
> disabled the
> > setting on startup. The conversions don't quite support multiple binaries
> quite
> > as well as it should. My intent was to make the command table a hash of
> arrays.
> > I might be able to get this working next week.
>
> Or perhaps don't make the decision about binaries present/absent until
> all the convert.conf-like files have been read. That way, the
> slimserver-convert.conf entries would have already overwritten the
> convert.conf entries and the server wouldn't have any need to even look
> for wmadec.

Roy,

I'm tossing around a few ideas for this, but you might want to consider filing
this as a bug and let Vidur decide if its a blocking issue or not for 5.2.
Otherwise, it might not get in there for the next release.
-kdf

-kdf

Roy M. Silvernail
2004-06-08, 14:57
On Tue, 2004-06-08 at 17:07, kdf wrote:

> I'm tossing around a few ideas for this, but you might want to consider filing
> this as a bug and let Vidur decide if its a blocking issue or not for 5.2.

Good idea. I've filed a bug report.
--
Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
Never Forget: It's Only 1's and 0's!
SpamAssassin->procmail->/dev/null->bliss
http://www.rant-central.com