PDA

View Full Version : Slimserver 7.6: Empty Playlist when "Play"-ing a directory of directories



tygar
2011-08-02, 09:24
I have a Transporter. Since updating to Slimserver 7.6, the device's behavior has changed.

I have my music organized in a Music Folder, and I usually browse music through the Music Folder. I have a number of audiobooks which are organized as directories of directories, e.g.,:

* "Book" directory contains directories "Part 1", "Part 2", "Part 3", ....

* "Part 1" directory contains "1-01.mp3", "1-02.mp3", ....

* "Part 2" directory contains "2-01.mp3", "2-02.mp3", ....

With previous versions of Slimserver, I could press "PLAY" on the "Book" directory and it would add all of the mp3 files that were contained in the directory to the playlist -- no matter how deeply nested.

But with 7.6, pressing PLAY on the "Book" directory results in an error message: "Empty Playlist."

I have removed any limits on the size of the playlist in the Slimserver settings. Does anyone have any insights on why this behavior occurs, and if it is possible to have PLAY act as did in previous versions -- e.g., to play all files, no matter how deeply nested?

Thanks in advance.

arztde
2011-08-02, 09:47
Its a known bug in 6.0 and is solved. If you install a nightly build, than all is good. Erland did write inside the wiki a guide how to solve problems. I suggest to have a look there and to follow instructions. Or if you can wait a little because 7.6.1 will solve the major problems of 7.60 and should not take mor so much long.

If you wish this bug be solved in a stable release please vote there: http://bugs.slimdevices.com/show_bug.cgi?id=17347

Ahhhh i forgot. Link for discuss and more infos... http://forums.slimdevices.com/showthread.php?t=89198

tygar
2011-08-02, 09:59
Thanks for the detailed reply!