PDA

View Full Version : One album won't play



Philip Bouscarle
2004-09-28, 02:58
Here are a couple of chunks of log file with d_source turned on.
Certainly looks like there is some sort of problem!

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
Sent: 28 September 2004 09:34
To: Slim Devices Discussion
Subject: [slim] One album won't play

Quoting Philip Bouscarle <pbouscarle (AT) interbar (DOT) co.uk>:

>
> My setup works fine except for the fact that one album will not play.
> It is in the same folder as the rest of my music (itunes), plays fine
> on my PC and Ipod, is seen by the Squeezebox, but when I hit play it
> just hangs. Please see attached log file.(I was not sure which logging

> should be turned on for this problem.) I have stripped out sections of

> repeated text to keep file size below 40k.
>
> The album is saved as AAC, system is graphic SB, win XP pro SP1,
> firmware 38, slimserver 5.3.0.
>
> If you need additional logging, please let me know which bits to turn
> on.
>
> Philip
>


try d_source then play one of the bad songs. it might be due to the
server having some problem reading those songs, whether its permissions,
or some data about the song itself like duration being read in as zero.

-kdf

kdf
2004-09-28, 03:13
Quoting Philip Bouscarle <pbouscarle (AT) interbar (DOT) co.uk>:

> Here are a couple of chunks of log file with d_source turned on.
> Certainly looks like there is some sort of problem!

well, the first log seems to show a missing client, IRmap or mode info. However,
that doesn't seem to fit with your problem. The second isn't very revealing of
anything. What I was thinking of was the command construction, and the start
of playback. you would see things liek "using command" and bitrate/maxrate
info. This will show errors on starting playback of files, and for skipping
certain files.

When it hangs, check on your CPU usage, and see if slimserver is taking an
abnormal amount. Does it hang permanently? Are you able to recover, or does it
mean a restart of the server?

-kdf